Updated EditWorld 32 for 2.x (2.1.x, 2.2.x ...)

Warzone 2.3.x series. (Unsupported!)
If you issue is with 3.1.x, then DON'T post here, instead use technical support

Updated EditWorld 32 for 2.x (2.1.x, 2.2.x ...)

Postby Buginator » 09 Apr 2008, 03:05

NOTE: A new map editor is being worked on here: viewtopic.php?f=5&t=5309&start=0 http://forums.wz2100.net/viewtopic.php?f=5&t=4630
This is windows only (as is EW32), and is written in visual baisc.

=========================================================================================
Step one, get this: http://files.wz2100.net/tools/BetaWorldEditor32.exe and install it.

Step two, get the file below, and use that .exe file when you run it.
=========================================================================================

This should fix it, so that when you create a map, no need to change anything, just drop it in the maps directory, and it should work.

That is assuming you read http://docs.wz2100.net/map%20tutorials/WorldEditor32bitBeta/index.html and followed the tutorials.

No, there is no source to this patched file, since I didn't have any to begin with.  :(

NOTE: cleaning up this thread. All OT posts will be removed.


NOTE, Editworld 32 does NOT support 3/5/6/7 player maps! For that, you *must* use FlaME 1.10+ or manually fix editworld. We do NOT have the source code to fix this.

March 2 2011 - lav_coyote25 - edited - strike through links as they do not work anymore -due to not being relevent :annoyed: :stressed: :x
Attachments
editworld32c.7z
(137.2 KiB) Downloaded 2508 times
Last edited by lav_coyote25 on 03 Mar 2011, 06:14, edited 1 time in total.
Reason: as this topic is not really relevant - i have locked it. it is an history. please do not delete. thanks lav_coyote25
and it ends here.
User avatar
Buginator
Professional
Professional
 
Posts: 3285
Joined: 04 Nov 2007, 01:20

Re: Updated EW32 for 2.1

Postby Buginator » 25 Oct 2008, 04:22

DarkCheetah wrote:DDERR_INVALIDPIXELFORMAT
The pixel format was invalid as specified

file.:\directX.ccp
Line: 584

Your desktop must be set to true color (32bit) mode.
What vid cards do you guys have?
User avatar
Buginator
Professional
Professional
 
Posts: 3285
Joined: 04 Nov 2007, 01:20

Re: Updated EW32 for 2.1

Postby whippersnapper » 25 Oct 2008, 04:41

.

DarkCheetah & Phoenix666 - i think i know what may be the problem and you may be outta luck on a fix. or, you could be in luck. what follows are 2 possibilities.

EW uses 1555 ARGB and it looks like A1R5B5G5 is not supported by your gfx chipset which likely only supports the more modern 565 RGB - therefore your comp cannot roll-out the proper texture map space when it tries to make the dx call. it's any easy fix if your working with the source because you can make EW accept the newer 565 RGB for the 8bit PAL specification...

however, maybe it's a more simple issue at work here like....

this is directly related to the DirectDrawSurface color depth, which is always same as your desktop color depth..... have you played around with your desktop color bit depth setting ? that could be the simple 'fix'....

that's all i can think of..... maybe Buginator can come up with a more appropriate answer or solution.


----->EDIT: Wow... 2 posts while i was writing... and one by Bug.... on the same wavelength there too... i'll let mine stand as is...
.
"I need no warrant for being, and no word of sanction upon my being. I am the warrant and the sanction." Anthem

"Art is the selective recreation of reality according to the artist's metaphysical value judgments." A. Rand
.
User avatar
whippersnapper
Regular
Regular
 
Posts: 1183
Joined: 21 Feb 2007, 14:46

Re: Updated EW32 for 2.1

Postby DarkCheetah » 25 Oct 2008, 11:28

i got Nvidia GeForce 7300 , or something like that , thereafter my colours ARE 32bits , becuase the 16 bit editor works verry properly , so question is , why 32 bits not? and if its posible , can i make maps for beta with 16 bit?
User avatar
DarkCheetah
Trained
Trained
 
Posts: 335
Joined: 30 Apr 2008, 18:44

Re: Updated EW32 for 2.1

Postby whippersnapper » 25 Oct 2008, 13:48

..

that is all together wierd.

i can tell you for sure that your card is not properly rolling out the DirectDrawSurface color depth texture space. why i cannot say since it can handle the older PAL specification (you can run the original EW no prob). maybe Bug can figure it out from your attachment. btw - have you updated your card drivers ? your DX ?
.
"I need no warrant for being, and no word of sanction upon my being. I am the warrant and the sanction." Anthem

"Art is the selective recreation of reality according to the artist's metaphysical value judgments." A. Rand
.
User avatar
whippersnapper
Regular
Regular
 
Posts: 1183
Joined: 21 Feb 2007, 14:46

Re: Updated EW32 for 2.1

Postby whippersnapper » 25 Oct 2008, 14:12

...

yes DX... your set with that version.

NVIDIA released a new driver update for your card just a few days ago (October 20th, 2008) and you can grab it here:

http://newdriverdownloads.com/drivers/v ... awod82c5yw
.
"I need no warrant for being, and no word of sanction upon my being. I am the warrant and the sanction." Anthem

"Art is the selective recreation of reality according to the artist's metaphysical value judgments." A. Rand
.
User avatar
whippersnapper
Regular
Regular
 
Posts: 1183
Joined: 21 Feb 2007, 14:46

Re: Updated EW32 for 2.1

Postby Buginator » 25 Oct 2008, 20:52

Last time I looked at the dump, I could of swore it used 888. Which is why it required a 32bit desktop.
I supposed I can check again, and modify the routine, if it is still looking for 555... but I don't think it does.
User avatar
Buginator
Professional
Professional
 
Posts: 3285
Joined: 04 Nov 2007, 01:20

Re: Updated EW32 for 2.1

Postby DarkCheetah » 25 Oct 2008, 22:10

whippersnapper wrote:...

yes DX... your set with that version.

NVIDIA released a new driver update for your card just a few days ago (October 20th, 2008) and you can grab it here:

http://newdriverdownloads.com/drivers/v ... awod82c5yw

thx , hope it works!
User avatar
DarkCheetah
Trained
Trained
 
Posts: 335
Joined: 30 Apr 2008, 18:44

Re: Updated EditWorld 32 for 2.x

Postby TonyTheSlayer » 26 Jul 2009, 18:13

Firechkn34 wrote:Where do i save the file editworld32c.7z to?


It does not matter, the executable file is inside and will install EditWorld for you. You just need to make the directory changes.
TonyTheSlayer
Trained
Trained
 
Posts: 41
Joined: 15 Dec 2007, 14:48

Re: Updated EditWorld 32 for 2.x

Postby Firechkn34 » 27 Jul 2009, 13:50

i ran the only file in the .7z file and got this:

Error_1.JPG


What do i do now
Dies Irae: Day of Wrath
User avatar
Firechkn34
Trained
Trained
 
Posts: 108
Joined: 06 Feb 2009, 21:07
Location: Ijamsville, MD USA

Re: Updated EditWorld 32 for 2.x

Postby i-NoD » 10 Aug 2009, 17:33

i-NoD
Code contributor
Code contributor
 
Posts: 306
Joined: 29 Nov 2008, 23:42
Location: In the middle of nowhere

Re: Updated EditWorld 32 for 2.x

Postby Dylan Hsu » 10 Aug 2009, 17:36

Well, I Was going to, but then I downloaded this. viewtopic.php?f=5&t=838
Dylan Hsu
Banned
Banned
 
Posts: 183
Joined: 05 Jul 2009, 23:02

Re: Updated EditWorld 32 for 2.x

Postby i-NoD » 10 Aug 2009, 17:47

guess I'm but still
libpng13.7z
(51.28 KiB) Downloaded 434 times

freshly compiled from the 1.2.39rc01 package
i-NoD
Code contributor
Code contributor
 
Posts: 306
Joined: 29 Nov 2008, 23:42
Location: In the middle of nowhere

Re: Updated EditWorld 32 for 2.x (2.1.x, 2.2.x ...)

Postby Korusray » 08 Nov 2009, 22:24

i keep getting the error

error reading PCX when i try to create a new map any ideas?
Korusray
Trained
Trained
 
Posts: 37
Joined: 08 Nov 2009, 22:21

Re: Updated EditWorld 32 for 2.x (2.1.x, 2.2.x ...)

Postby luisynai101 » 13 Nov 2009, 01:07

Any ideas why i get this error when i run the program? :mad;
Attachments
Capture.PNG
this is my error
luisynai101
Trained
Trained
 
Posts: 62
Joined: 31 Jan 2009, 00:37

Next

Return to 2.3.x