Page 1 of 1

Trying to make some upgrades apply better

Posted: 18 Oct 2019, 12:16
by nick87720z
There are two places, mentioned in another thread, where some upgrades are not applied as expected: ... 71#p145671

Armor upgrades is not applied to transport. Only these days I got from betaguide, that HP 500 is maximum, and even Dragon body HP os lower - only 350 at this point. I achieved necessary effect my changing "class" property in body.json from Transports to "Droids". Some other parameters still point to its transport nature. It works as transport as usually, but now has armor upgrades. Not sure about engine ups meaning, unless it has variable mass, depending on payload.

When tested at T4 skirmish, dragon vtol with single lancer took 6 vindicator missiles or 7 sec whirlwind. Heavy transport took 8 missiles or 11.2 sec whirlwind with upgrades, and without - only 2 missiles, with 1 reducing HP by more than half.

As for repair, I still can't make mobile turrets to get them. Heavy turret is expected to be only 1/4 times weaker than facility (30 vs 40). At mentioned thread they recommended to add another block in research.json for Repair type. Not sure if I understood right, but I noticed, "result" block in almost all upgrade researches, which apply to "Building" class. I tried to duplicate element block in results array, but unable to guess correct class to get it working. "Repair" causes error "Component type not found for upgrade".
For classes "Droids" and "Turret" there is not errors, but also no effect. For all experiments I extracted mp.wz into separate mod - ref-mp. Tried to figure out, where "Building" class is set, but found only features.json in base.wz. Definitions in structures.json have more specialized types/classes, and absollutely not word like "Building" (in all mp.wz this mention is only in research.json).

What class should be there to make repair units upgraded?

Re: Trying to make some upgrades apply better

Posted: 28 Apr 2020, 18:07
by aliswe
Sorry I can't help you ... it's sad that you're not seeing any response. I'm mostly doing details and finishes on the game.