Dependencies for master

Discuss the future of Warzone 2100 with us.
User avatar
vexed
Inactive
Inactive
Posts: 2538
Joined: 27 Jul 2010, 02:07

Re: misc stuff moved from testing thread

Post by vexed » 09 Feb 2015, 04:35

Iluvalar wrote:

Code: Select all

piestate.cpp: In function ‘GLuint pie_LoadShader(const char*, const char*, const char*)’:
piestate.cpp:261:8: error: ‘GLEW_VERSION_4_3’ was not declared in this scope
piestate.cpp:261:28: error: ‘GLEW_KHR_debug’ was not declared in this scope
...
I already changed libglew1.5-dev for libglew1.6-dev that's still not good enough ?
It is not.
You want either 1.9.0 or 1.10.0.

And anyway, updating to ubuntu 14.x wouldn't hamper your system by that much, and 12 isn't supported any more. That is why they made a 14.x LTS release.

Terminator, that is odd, it shouldn't make a difference, since the libs that master uses are qt5 specific, nothing should clash with the qt 4.x.
/facepalm ...Grinch stole Warzone🙈🙉🙊 contra principia negantem non est disputandum
Super busy, don't expect a timely reply back.

User avatar
Terminator
Regular
Regular
Posts: 1074
Joined: 05 Aug 2006, 13:46
Location: Ukraine
Contact:

Re: misc stuff moved from testing thread

Post by Terminator » 09 Feb 2015, 13:20

vexed wrote:Terminator, that is odd, it shouldn't make a difference, since the libs that master uses are qt5 specific, nothing should clash with the qt 4.x.
this is nothing odd I guess, if you install two QT versions, you should choose somehow one of them. by default Kubuntu environment "looks" for qt4 folder, qtchooser let you change that.
Death is the only way out... sh*t Happens !

Russian-speaking Social network Group http://vk.com/warzone2100

Per
Warzone 2100 Team Member
Warzone 2100 Team Member
Posts: 3777
Joined: 03 Aug 2006, 19:39

Re: misc stuff moved from testing thread

Post by Per » 09 Feb 2015, 20:59

Iluvalar wrote:I already changed libglew1.5-dev for libglew1.6-dev that's still not good enough ?
GLEW 1.6 was released in 2011.

Current version is 1.12.

But in an effort to make you happy, I pushed a workaround that sets these defines to false if you happen to have an ancient version of GLEW on your system.

User avatar
Iluvalar
Regular
Regular
Posts: 1819
Joined: 02 Oct 2010, 18:44

Re: misc stuff moved from testing thread

Post by Iluvalar » 09 Feb 2015, 22:27

Per wrote: GLEW 1.6 was released in 2011.

Current version is 1.12.

But in an effort to make you happy, I pushed a workaround that sets these defines to false if you happen to have an ancient version of GLEW on your system.
Ty. But still have the same error with.

Code: Select all

#define GLEW_VERSION_4_3 false
#define GLEW_KHR_debug false
Heretic 2.3 improver and proud of it.

User avatar
vexed
Inactive
Inactive
Posts: 2538
Joined: 27 Jul 2010, 02:07

Re: misc stuff moved from testing thread

Post by vexed » 22 Feb 2015, 04:13

Terminator wrote: this is nothing odd I guess, if you install two QT versions, you should choose somehow one of them. by default Kubuntu environment "looks" for qt4 folder, qtchooser let you change that.
Just to clarify, because some people keep e-mailing me about it, qtchooser -list-versions shows you what versions of Qt you have on system.
Then you do export QT_SELECT = qt5 (or one of the ones listed by qtchooser) and it should work.
/facepalm ...Grinch stole Warzone🙈🙉🙊 contra principia negantem non est disputandum
Super busy, don't expect a timely reply back.

Post Reply