Objective failed?

Do you need help? Ask here!

Bug reporting belongs here: http://developer.wz2100.net/newticket
dumgrunt
New user
Posts: 4
Joined: 24 Sep 2011, 20:38

Objective failed?

Post by dumgrunt » 24 Sep 2011, 20:46

The lvl that says "Do not allow any enemies to leave the area"... I get stop the baddies, get the artifact, destroy the bases, and .........nothing. Only have 30 minutes for lvl. says objective failed? what is going on?

User avatar
lav_coyote25
Professional
Professional
Posts: 3434
Joined: 08 Aug 2006, 23:18

Re: Objective failed?

Post by lav_coyote25 » 24 Sep 2011, 21:55

dumgrunt wrote:The lvl that says "Do not allow any enemies to leave the area"... I get stop the baddies, get the artifact, destroy the bases, and .........nothing. Only have 30 minutes for lvl. says objective failed? what is going on?
OK - as you look at your screen - look at the mini map. up is north - left is west and right is east and down is south. now, your wanting to explore due west - the extreme left side is what your after. if you try and follow what is your front ( to the north ) you will eventually come all the way around to where you want to be - thing is - you dont have that much time. there is a walk through if you want.

http://members.shaw.ca/kgmetcalfe/walk% ... index.html

should still be relevant.

User avatar
NoQ
Special
Special
Posts: 6226
Joined: 24 Dec 2009, 11:35
Location: /var/zone

Re: Objective failed?

Post by NoQ » 24 Sep 2011, 22:09


User avatar
lav_coyote25
Professional
Professional
Posts: 3434
Joined: 08 Aug 2006, 23:18

Re: Objective failed?

Post by lav_coyote25 » 24 Sep 2011, 22:15

hmmm... i am not certain as there is really no info on what level he has got to... but - from the sounds of it - it is this one.
ie: http://members.shaw.ca/kgmetcalfe/walk% ... eta_4.html

dumgrunt
New user
Posts: 4
Joined: 24 Sep 2011, 20:38

Re: Objective failed?

Post by dumgrunt » 24 Sep 2011, 23:15

the mission is alpha 11. even tried the cheat code to end mission. nothing works. any ideas? thanks for the swift replys.

dumgrunt
New user
Posts: 4
Joined: 24 Sep 2011, 20:38

Re: Objective failed?

Post by dumgrunt » 24 Sep 2011, 23:26

alpha 11 is the mission.


User avatar
Shadow Wolf TJC
Regular
Regular
Posts: 1047
Joined: 16 Apr 2011, 05:12
Location: Raleigh, NC

Re: Objective failed?

Post by Shadow Wolf TJC » 26 Sep 2011, 14:13

There is this bug that I experienced (along with YouTube user DarkyErinyes, who did a let's play on this game) where destroying NEXUS's base during the final mission apparently doesn't cause the mission to end, forcing players to have to cheat to see the ending. :annoyed:
Creator of Warzone 2100: Contingency!
Founder of Wikizone 2100: http://wikizone2100.wikia.com/wiki/Wikizone_2100

User avatar
NoQ
Special
Special
Posts: 6226
Joined: 24 Dec 2009, 11:35
Location: /var/zone

Re: Objective failed?

Post by NoQ » 26 Sep 2011, 14:21

bug
Is there a ticket for this?
DarkyErinyes
Any chance you have a link to the video please? Just painful to watch through 144 vids :/
destroying ... base
In this level, the objective is to get the artifact and destroy all New Paradigm droids.

User avatar
Shadow Wolf TJC
Regular
Regular
Posts: 1047
Joined: 16 Apr 2011, 05:12
Location: Raleigh, NC

Re: Objective failed?

Post by Shadow Wolf TJC » 26 Sep 2011, 14:29

It's the very last video of his Warzone 2100 playthrough (video 144) where DarkyErinyes was forced to cheat to finish the very last level in the campaign. Apparently, the bug hasn't been fixed since 1 year later.

Edit: someone who commented on that video mentioned that destroying NEXUS's VTOL base causes the bug to occur.
Creator of Warzone 2100: Contingency!
Founder of Wikizone 2100: http://wikizone2100.wikia.com/wiki/Wikizone_2100

User avatar
NoQ
Special
Special
Posts: 6226
Joined: 24 Dec 2009, 11:35
Location: /var/zone

Re: Objective failed?

Post by NoQ » 26 Sep 2011, 15:23

the very last level
That's certainly not related to the mission discussed in this thread.

User avatar
Shadow Wolf TJC
Regular
Regular
Posts: 1047
Joined: 16 Apr 2011, 05:12
Location: Raleigh, NC

Re: Objective failed?

Post by Shadow Wolf TJC » 27 Sep 2011, 05:14

True, but it definitely seems like an actual bug, unlike Alpha 11, where it's pretty much a search-&-destroy mission towards New Paradigm units (some of which could be hard to find). A similar bug seems to also occur at one of the Beta missions that is located away from your base. I think that it's the one where you destroy every SAM site (Beta 9), where sometimes, if you destroy every base, it doesn't end the mission right away.

As for the final Gamma level, isn't the only mission objective supposed to be to destroy NEXUS's core base? There's no mention to destroy NEXUS's other bases, or to keep them alive either, so players would assume that destroying those other bases would be optional.
Creator of Warzone 2100: Contingency!
Founder of Wikizone 2100: http://wikizone2100.wikia.com/wiki/Wikizone_2100

User avatar
NoQ
Special
Special
Posts: 6226
Joined: 24 Dec 2009, 11:35
Location: /var/zone

Re: Objective failed?

Post by NoQ » 27 Sep 2011, 09:30

By the way, i've never experienced the bugs you're talking about.
isn't the only mission objective supposed to be to destroy NEXUS's core base?
It is.

User avatar
Shadow Wolf TJC
Regular
Regular
Posts: 1047
Joined: 16 Apr 2011, 05:12
Location: Raleigh, NC

Re: Objective failed?

Post by Shadow Wolf TJC » 27 Sep 2011, 09:50

I already submitted a ticket describing this bug. What I did before I destroyed NEXUS's main base was that I destroyed most, if not all, of NEXUS's structures outside of NEXUS's main base, including his VTOL base to the south, and his artillery installations in the center, northwest, and southeast. My version was 2.3.8 when this bug happened, though DarkyErinyes was undoubtedly playing an older version when he did his playthrough of the game over a year ago.
Creator of Warzone 2100: Contingency!
Founder of Wikizone 2100: http://wikizone2100.wikia.com/wiki/Wikizone_2100

User avatar
effigy
Regular
Regular
Posts: 1217
Joined: 22 Jan 2010, 03:21
Contact:

Re: Objective failed?

Post by effigy » 28 Sep 2011, 04:46

I wouldn't be surprised if there was a vtol stuck behind a feature (building), keeping the mission alive.
This is why some features aren't implemented: http://forums.wz2100.net/viewtopic.php?f=30&t=7490&view=unread#p87241

Post Reply