Cannot install on Linux Mint 19/19.2

Other talk that doesn't fit elsewhere.
This is for General Discussion, not General chat.
Post Reply
New user
Posts: 1
Joined: 01 Jan 2020, 20:37

Cannot install on Linux Mint 19/19.2

Post by Troubled » 01 Jan 2020, 20:54

Tried installing v. 3.3.0 on three computers.
1: Mint 19
2: Mint 19.2(fresh install)
3: Windows 10

On the windows computer it was not a problem at all.

Tried following the compiling guide, after a lot of trouble, I managed to get it to work in mint 19.
But synaptic and the software manager is gone, due to some "xenial" error...

On mint 19.2 it does not work at all, same "xenial" error.
If i use the software manager, i can install the game and it sort of works.
Cant play multiplayer, since the current version isnt supported.

Is there someone who could give a step by step instruction?

User avatar
Posts: 175
Joined: 02 Jan 2016, 12:44

Re: Cannot install on Linux Mint 19/19.2

Post by andrvaut » 01 Jan 2020, 22:41


Code: Select all

sudo snap install warzone2100
or describe in more detail at what stage of compilation errors and text errors occur.
You do not need to install sdl from third-party software, the necessary version is already in the distribution
vaut ΣΑ [GN], ru streamer.
Tournaments channel:

User avatar
Berserk Cyborg
Code contributor
Code contributor
Posts: 837
Joined: 26 Sep 2016, 19:56

Re: Cannot install on Linux Mint 19/19.2

Post by Berserk Cyborg » 01 Jan 2020, 23:28

Probably caused by weird instructions for a, not so relevant anymore, problem when SDL 2.0.6 was the latest release (see the mint and ubuntu sections in our linux compile guide). The compile guides need to be cleaned up and updated.

Post Reply