problem with linux64bit and text in menus in 2.1

Warzone 2.1.x series. (Unsupported--read only!)
Locked
User avatar
lav_coyote25
Professional
Professional
Posts: 3434
Joined: 08 Aug 2006, 23:18

problem with linux64bit and text in menus in 2.1

Post by lav_coyote25 » 10 Jun 2008, 00:19

Sorry - i dont have very much experience with linux - especially 64 bit - i am still living in the dark ages with old architecture and xpsp3windows. so i am taking the liberty to post - hopefully someone will have an answer for you , scosu. and as for threads being closed... there is never such an animal as a closed topic - it will just rear its ugly ol head , especially when people have forgotten about it and moved on... ;)
From: scosu
To: lav_coyote25
Hi

i just found the closed topic about no text in menus in beta 2.1. i have this problem. i installed quesoglc-0.7.1 but that changed nothing. My architekture is x86_64, distribution archlinux. here is the output:

Code: Select all

which: no gdb in (/bin:/usr/bin:/sbin:/usr/sbin:/usr/share/eclipse:/opt/java/bin:/opt/java/jre/bin:/opt/mozilla/bin:/usr/bin/perlbin/site:/usr/bin/perlbin/vendor:/usr/bin/perlbin/core:/opt/torcs/bin)
open /dev/[sound/]dsp: Datei oder Verzeichnis nicht gefunden
error : OpenAL Vendor: (null)
error : OpenAL Version: (null)
error : OpenAL Renderer: (null)
error : OpenAL Extensions: (null)
error : Couldn't open audio device.
error : Cannot init sound library
error : iV_initializeGLC: Failed to select font family DejaVu Sans Mono as regular font
error : iV_initializeGLC: Failed to select font family DejaVu Sans Mono for the bold font
i don't want to open a new topic, i think there is just a small mistake i made.

thank you
scosu

User avatar
kage
Regular
Regular
Posts: 751
Joined: 05 Dec 2006, 21:45

Re: problem with linux64bit and text in menus in 2.1

Post by kage » 10 Jun 2008, 04:24

assuming you're using a distro (if not, you would've figured it out already), look for and install a software package/tarball/whatever with 'dejavu' in the name. it's a true-type font library. my guess is that this is the critical error, since it didn't terminate after the OpenAL errors.

as for the OpenAL issue, /dev/sound/dsp is the legacy OSS notation. you may still be using that, but most people are using ALSA these days (especially if it's 64-bit). if you are using ALSA, you should make sure the following line is somewhere in your ~/.openalrc file:

Code: Select all

(define devices '(alsa))

scosu
New user
Posts: 1
Joined: 09 Jun 2008, 10:42

Re: problem with linux64bit and text in menus in 2.1

Post by scosu » 11 Jun 2008, 12:22

hi

thank you for posting it here and the answer. sound works great now with that line in .openalrc :).

the textproblem i simply solved by extracting the game again and build it from the beginning.

Made also the quesoglc-0.7.1 package now and added quesoglc to the warzone-svn package. Should compile on a day the sources compile on linux ;).
Only the normal warzone2100 package has to be updated, but i don't have the rights to do that.

so thanks for your help :) it's a great game

Locked