Multiplayer hosting issue

Discussions about AI types, units, tactics & strategy.
Post Reply
kotek900
New user
Posts: 3
Joined: 13 Apr 2019, 22:34

Multiplayer hosting issue

Post by kotek900 » 12 Oct 2019, 20:32

Hello, recently I downloaded the newest version of Warzone 2100 on my new laptop and decided that it will be a good idea to play some multiplayer.
There were no games online so I decided to host one, however I got an error saying:
Server message:
Error while connecting to the lobby server: Connection timed out
Make sure port 2100 can receive incoming connections.

I disabled my firewall, restarted the game and tried again, same error.
I tried hosting a game when there were games online, same thing.
There were no issues with joining a game, that worked just fine.

If anyone has any idea on how to fix this issue, please help, it would be greatly appreciated.

User avatar
WZ2100ModsFAn
Trained
Trained
Posts: 365
Joined: 15 Apr 2018, 17:25
Location: United States.

Re: Multiplayer hosting issue

Post by WZ2100ModsFAn » 12 Oct 2019, 20:48

Do you have multiple instances of warzone 2100 opened?
That can be the cause for port 2100 in use you might also have warzone 2100 running in the background.
Close those other processes and try again. If it's running in the background you might have to open task manager.
Or maybe the servers are down.
I use Ubuntu GamePack By UALinux for gaming. Best Ubuntu Distro for Warzone :D

kotek900
New user
Posts: 3
Joined: 13 Apr 2019, 22:34

Re: Multiplayer hosting issue

Post by kotek900 » 12 Oct 2019, 20:57

WZ2100ModsFAn wrote:
12 Oct 2019, 20:48
Do you have multiple instances of warzone 2100 opened?
That can be the cause for port 2100 in use you might also have warzone 2100 running in the background.
Close those other processes and try again. If it's running in the background you might have to open task manager.
Or maybe the servers are down.
I don't I just have one process of it running, once I installed the game I went straight to multiplayer,
Can't be servers shutting down either, I tried hosting it multiple times a day in multiple days, no luck.

User avatar
WZ2100ModsFAn
Trained
Trained
Posts: 365
Joined: 15 Apr 2018, 17:25
Location: United States.

Re: Multiplayer hosting issue

Post by WZ2100ModsFAn » 13 Oct 2019, 02:01

Then you must have another application opening port 2100.
Check here: https://github.com/Warzone2100/warzone2100/issues/476
Or error 606 on 2100.
I use Ubuntu GamePack By UALinux for gaming. Best Ubuntu Distro for Warzone :D

User avatar
Berserk Cyborg
Code contributor
Code contributor
Posts: 816
Joined: 26 Sep 2016, 19:56

Re: Multiplayer hosting issue

Post by Berserk Cyborg » 13 Oct 2019, 03:27

^ Highly unlikely. It's going to be some settings aren't properly configured before that is a problem.

Afraid I'm not well versed in this area, but I'll give it a try. There are two firewalls to worry about. The software-level one and the router one.

1. Have you made sure Warzone2100 is an exemption in the software firewall?
2. Are you sure the software firewall is allowing port 2100 to be open?
3. Is a security program (anti-virus) interfering (try disabling that)?
4. Setup a port forwarding rule in your router settings for port 2100.

You could also try and enable UPnP in your router and see if that works. Another alternative is to disable the software firewall, but, with correct use of application exemptions that shouldn't be necessary.

If all else fails, you'll need to check that you have a static IP address for the device that wants port forwarding.

kotek900
New user
Posts: 3
Joined: 13 Apr 2019, 22:34

Re: Multiplayer hosting issue

Post by kotek900 » 13 Oct 2019, 11:15

Tank you, turns out my UPnP in my router was disabled. I just had to login to my router and enable it. :D

Post Reply