Help needed testing 3.2.x Campaign games!

The projects speaking tube.
Add your two cents if you want to.
alfred007
Trained
Trained
Posts: 408
Joined: 31 Jul 2016, 06:25
Location: Stuttgart, Germany

Re: Help needed testing 3.2.x Campaign games!

Post by alfred007 » 19 Aug 2018, 23:32

WZ2100ModsFAn wrote:Is the hold order going to be fixed?

Or has it already been fixed?

Somebody is saying that the hold order does not work the way it originally did.
Ticket #4303 is assigned to Forgon. If you have any questions, ask him.

And yes, the hold order is not working like in 3.1.5.

alfred007
Trained
Trained
Posts: 408
Joined: 31 Jul 2016, 06:25
Location: Stuttgart, Germany

Re: Help needed testing 3.2.x Campaign games!

Post by alfred007 » 20 Aug 2018, 22:24

I have problems to install new master versions. When I try to install newer master versions the files didn't get updated. I tried to install commit 32eb3c3 and 9dca83b but the files still had the date of August 10th and the game shows me that my current version is commit de158c5. Even if I chose manually the folder where the files should be saved in, I failed.

Edit: I looked into the commit list in the GitHub master branch and commit 64b7420 from August 11th shows a red x. And this is the commit after commit de158c5. Could it be that something went wrong with this commit so that newer commits can't be installed? And if this is right, commit ffb5b9b from August 14th shows also a red x instead of a green check.

User avatar
Berserk Cyborg
Code contributor
Code contributor
Posts: 599
Joined: 26 Sep 2016, 19:56

Re: Help needed testing 3.2.x Campaign games!

Post by Berserk Cyborg » 20 Aug 2018, 23:08

alfred007 wrote:I have problems to install new master versions. When I try to install newer master versions the files didn't get updated. I tried to install commit 32eb3c3 and 9dca83b but the files still had the date of August 10th and the game shows me that my current version is commit de158c5. Even if I chose manually the folder where the files should be saved in, I failed.

Edit: I looked into the commit list in the GitHub master branch and commit 64b7420 from August 11th shows a red x. And this is the commit after commit de158c5. Could it be that something went wrong with this commit so that newer commits can't be installed? And if this is right, commit ffb5b9b from August 14th shows also a red x instead of a green check.
Maybe download the latest portable again. Do you use multiple portable builds? If so, check that you are using the right executable. I'll see if it happens to me shortly.

Those commits were green at one point. So the continuous integration probably rechecks everything once a day if nothing new was committed, I am guessing, and encountered an outside error. Both times they failed to download some file when trying to compile Warzone.

pastdue
Code contributor
Code contributor
Posts: 102
Joined: 13 Aug 2017, 17:44

Re: Help needed testing 3.2.x Campaign games!

Post by pastdue » 20 Aug 2018, 23:14

There was a change to the location of the executable / DLL files on Windows (now in a "bin" subfolder). If you are installing over an older version, the old "warzone2100.exe" will still exist in the root install folder.
You should now start the EXE in: "<InstallDirectory>\bin\".

alfred007
Trained
Trained
Posts: 408
Joined: 31 Jul 2016, 06:25
Location: Stuttgart, Germany

Re: Help needed testing 3.2.x Campaign games!

Post by alfred007 » 21 Aug 2018, 01:17

pastdue wrote:There was a change to the location of the executable / DLL files on Windows (now in a "bin" subfolder). If you are installing over an older version, the old "warzone2100.exe" will still exist in the root install folder.
You should now start the EXE in: "<InstallDirectory>\bin\".
This was the problem. I use shortcuts, so the shortcut still used the old exe-file. It would be helpful to announce such a change. Can I delete the old .dll files in the old dll-location-folder?

alfred007
Trained
Trained
Posts: 408
Joined: 31 Jul 2016, 06:25
Location: Stuttgart, Germany

Re: Help needed testing 3.2.x Campaign games!

Post by alfred007 » 22 Aug 2018, 16:00

I updated to master 32eb3c3 and played gamma 05 again. Everything looks fine now. Research labs were absorbed, absorbed factories produce nexus units and absorbed trucks build nexus defences. The only issue is the already reported sound that structures get neutralized when they get absorbed in German. But this is a minor issue. I don't think that many players will notice this and even if, it has no influence to gameplay so I think we can ignore it. Logs are added.
Attachments
logs gamma 05.zip
(2.34 KiB) Downloaded 19 times

User avatar
WZ2100ModsFAn
Trained
Trained
Posts: 267
Joined: 15 Apr 2018, 17:25
Location: United States.

Re: Help needed testing 3.2.x Campaign games!

Post by WZ2100ModsFAn » 22 Aug 2018, 17:04

I was playing the campaign and was comparing it to 1.10.

The problem is when your units return for repair the other ones are in the way :annoyed: . Version Master

In 1.10 they move out the way for you.

Also i use WZstarter for 1.10 as i can see it's helpful for running it in debug mode.
Apologies if i dont see your post
central time usa

Post Reply