Effects missing and Fixing

Get some help with creating maps or modding.
Need a map editor or other tools, look here!
Post Reply
User avatar
Berg
Regular
Regular
Posts: 2140
Joined: 02 Sep 2007, 23:25
Location: Australia

Effects missing and Fixing

Post by Berg » 28 May 2013, 02:31

OK Im Not sure where to put this thread so start here if it needs moving please do and delete this sentence.

This started with the missing cannon muzzle flash cannon fortress and after searching through the files (what a mess) I found these errors/missing/deleted things
To start with the Cannon Fortress it was not too hard we just had to change the frame rate in the pie file odd that the connector is missing from the barrel pie but it looked like it was not needed.

Code: Select all

Original
4200 3 0 1 2 16 1 32 64 0 64 32 64 32 0
Updated
4200 3 0 1 2 16 5 32 64 0 64 32 64 32 0

This is way faster then the frame rate you could possibly see or render I think.
fxshcanm.pie is the pie used for that effect.

PS: Please don’t hijack the thread with random unrelated topics thank you
Last edited by Berg on 28 May 2013, 04:10, edited 1 time in total.

User avatar
Berg
Regular
Regular
Posts: 2140
Joined: 02 Sep 2007, 23:25
Location: Australia

Re: Effects missing and Fixing

Post by Berg » 28 May 2013, 02:39

The Gauss Cannon Fortress
The effects pie that is used for that is the electric effect rolling down the barrel.
fxshgssm.pie
This was totaly missing from the fortress when it fired I added a connector too gnwpfgss.pie which is the barrel pie file found in data/mp/components/weapons

Code: Select all

Missing data on end of file
CONNECTORS 1
	0 -120 0
Also the frame rate needed changing on the effects file

Code: Select all

Original
	4200 3 0 1 2 16 1 32 41 0 0 0 41 16 41
Updated
	4200 3 0 1 2 16 100 32 41 0 0 0 41 16 41
Do Note that the frame rate here is negotiable I have taken a stab at what’s a good rate so Input needed

User avatar
Berg
Regular
Regular
Posts: 2140
Joined: 02 Sep 2007, 23:25
Location: Australia

Re: Effects missing and Fixing

Post by Berg » 28 May 2013, 02:59

The Missile Fortress Was using the mortar effect here is the weapons.text file from the data/MP/stats folder
MissileSuper,Level Three,1600,1200,120000,1,10,50,gnwpfmsl.PIE,Trwpfmsl.PIE,FXMMort.PIE,FXHPLME.PIE,FXMExp.PIE,FXMExp.PIE,FXSSplsh.PIE,0,640,3072,80,90,8,2,4,200,1100,64,100,100,0,0,0,0,10,1500,20,YES,KINETIC,MISSILE,HOMING-DIRECT,ANTI TANK,180,90,-30,YES,NO,10,128,YES,100,100,0,0,0


There was a few things wrong with that the actual effect again used a frame rate of 1 millisecond you dont even see it scroll through the textures so thats a no no the effect was hardly suitable for a rocket flash (or missile)
Then comes the question do we use the effect that is used on the rocket fortress FXMRocAt.PIE or add an effect thats more suited?
For now I added the modified cannon flash if you like to test it out.

This is a concept mod for all of the afore mentions fortresses.

Because these effects are missing but they are in the system I think they should be enabled edited corrected to actually work
Attachments
neweffect.wz
Mod for cannon missle and guass fortresses
(12.98 KiB) Downloaded 250 times

AWarZoner
Trained
Trained
Posts: 129
Joined: 21 May 2013, 17:03

Re: Effects missing and Fixing

Post by AWarZoner » 28 May 2013, 21:41

This should be included as a bug fix in newer versions.
@Berg:
This is coool... :cool1:
Cheers and thanks for fixing... :drinks:

Lord Apocalypse
Regular
Regular
Posts: 678
Joined: 29 Jul 2009, 18:01

Re: Effects missing and Fixing

Post by Lord Apocalypse » 29 May 2013, 05:05

I think I remember strata mentioning something about all of the muzzle anims out of synch with timing. Are these the only ones left or are they all still in need of repair?

User avatar
Berg
Regular
Regular
Posts: 2140
Joined: 02 Sep 2007, 23:25
Location: Australia

Re: Effects missing and Fixing

Post by Berg » 29 May 2013, 05:09

If you know whats going on with it then you can help its not just these there are many effects missing from weapons just have to redo the frame rates and maybe add connectors all help welcome.
I just started in the MP/components/weapons folder cause there is less in it.
If you edit and fix a weapon Please put the mod and your changed on this thread.
Last edited by Berg on 29 May 2013, 06:21, edited 1 time in total.

Lord Apocalypse
Regular
Regular
Posts: 678
Joined: 29 Jul 2009, 18:01

Re: Effects missing and Fixing

Post by Lord Apocalypse » 29 May 2013, 05:22

PM or point me to a rundown or that particular section of the pie file. I have no clue what any of it means. With that in hand I will dig around and see what I can do.

User avatar
Berg
Regular
Regular
Posts: 2140
Joined: 02 Sep 2007, 23:25
Location: Australia

Re: Effects missing and Fixing

Post by Berg » 29 May 2013, 09:22

Lord Apocalypse wrote:PM or point me to a rundown or that particular section of the pie file. I have no clue what any of it means. With that in hand I will dig around and see what I can do.
I got the urge to fix it from this thread viewtopic.php?f=6&t=9628&hilit=animation#p106895
there is some info there that will help and read this thread thats about all there is on it.

Lord Apocalypse
Regular
Regular
Posts: 678
Joined: 29 Jul 2009, 18:01

Re: Effects missing and Fixing

Post by Lord Apocalypse » 30 May 2013, 04:47

Yep, that's the thread I was referring to. The thread helps a little with understanding "4200 3 0 1 2 16 1 32 41 0 0 0 41 16 41" but what are the rest of the numbers for? That is what i'm a bit lost on.

User avatar
Berg
Regular
Regular
Posts: 2140
Joined: 02 Sep 2007, 23:25
Location: Australia

Re: Effects missing and Fixing

Post by Berg » 30 May 2013, 11:42

Lord Apocalypse wrote:Yep, that's the thread I was referring to. The thread helps a little with understanding "4200 3 0 1 2 16 1 32 41 0 0 0 41 16 41" but what are the rest of the numbers for? That is what i'm a bit lost on.
Quick explain of the PIE2 format


PIE 2 the pie format
TYPE 200 Type is actualy a flag holder 10200 is TCMASK flag
TEXTURE 0 page-8-player-buildings-bases.png 256 256 texture used
LEVELS 1 levels is used for ani animation this one has only 1
LEVEL 1
POINTS 4 3d positioned points
-131 0 -131 The X Y and Z position of a point
131 0 -131
131 0 131
-131 0 131
POLYGONS 2 the number of polygones-triangles
200 3 3 1 0 0 128 128 128 128 255 0 255 the 3 is the number of

4200 3 0 1 2 16 1 32 41 0 0 0 41 16 41
ok the 4000 is the animation flag 200 is standard polygon flag = 4200
3 is the number of points in the polygon = 0 1 2
now the animation data is the next 4 data. 16 1 32 41
16 is the number of frame
1 is the frame rate in milliseconds at 1 id don’t function correctly i think 16 is about 60 frames per second
so yeah 16 is a starting point.
the 32 and 41 or the texture size of each frame.
now after that you have 3 pairs of texture co-ords for each point used so = 6 data
this is quick and nasty explanation.

User avatar
Berg
Regular
Regular
Posts: 2140
Joined: 02 Sep 2007, 23:25
Location: Australia

Re: Effects missing and Fixing

Post by Berg » 11 Jan 2016, 01:27

just a bump for this, anyone wanting to invest time in fixing effects please do and post your findings.

Post Reply