Page 2 of 2

Re: [AI] "BoneCrusher! 2" bot player for 3.1.5 and 3.2+

PostPosted: 05 Nov 2017, 05:21
by JimmyJack
I just downloaded 2.1 and can not play it. It makes the game (3.2.3) lag and the longer the game runs the more the lag until it locks up all together. Maybe I should not play with 7 bots but it lags in 2 player also.

Tried it with 3.1.1 and got the same.

Re: [AI] "BoneCrusher! 2" bot player for 3.1.5 and 3.2+

PostPosted: 05 Nov 2017, 06:57
by Berserk Cyborg
If it helps, I did a 4v4 AI test (all normal difficulty) on the map mero_WarPaths and attached the logs. Some of your averages get really high (~50000 in some cases) while the worst column can be almost 1/4 of a second. eventResearched, eventDroidIdle, and eventStructureBuilt are the ones I remember being bad with performance. Not that my bot has amazing performance, but I think a goal of 5ms should be the max of any one function.

perf.zip
(6.73 KiB) Downloaded 6 times

Re: [AI] "BoneCrusher! 2" bot player for 3.1.5 and 3.2+

PostPosted: 05 Nov 2017, 20:30
by Prot
JimmyJack wrote:I just downloaded 2.1 and can not play it. It makes the game (3.2.3) lag and the longer the game runs the more the lag until it locks up all together. Maybe I should not play with 7 bots but it lags in 2 player also.

Tried it with 3.1.1 and got the same.

Can you say, how much RAM you have, what a CPU, and OS?

Re: [AI] "BoneCrusher! 2" bot player for 3.1.5 and 3.2+

PostPosted: 06 Nov 2017, 08:05
by JimmyJack
Tech Support Guy System Info Utility version 1.0.0.4

OS Version: Microsoft Windows 10 Home, 64 bit
Processor: Intel(R) Pentium(R) CPU N3540 @ 2.16GHz, Intel64 Family 6 Model 55 Stepping 8
Processor Count: 4
RAM: 3985 Mb
Graphics Card: Intel(R) HD Graphics, -2039 Mb
Hard Drives: C: 446 GB (398 GB Free); D: 18 GB (1 GB Free);
Motherboard: Hewlett-Packard, 233F
Antivirus: Windows Defender