Ubuntu 18.04 fails to compile

Do you need help? Ask here!

Bug reporting belongs here: http://developer.wz2100.net/newticket
Post Reply
LisaNels
Greenhorn
Posts: 6
Joined: 30 Sep 2016, 00:35

Ubuntu 18.04 fails to compile

Post by LisaNels » 23 Feb 2019, 03:55

Love the game, when I clicked on the 'check for new versions' it routed me to the web site, long story short, I'm not new to compiling from github. So I'll skip most of the details, my problem is that when doing ./configure it fails at this point:

checking for CFPreferencesCopyAppValue... no
checking for CFLocaleCopyCurrent... no
checking for GNU gettext in libc... yes
checking whether to use NLS... yes
checking where the gettext function comes from... libc
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for pkg-config >= 0.9... found 0.29.1, ok
checking for QT5... no
configure: error: Qt 5.4 not found -- required!

lisa@lisa-Inspiron-7720:~/src/warzone2100$ dpkg -l | grep qtbase
ii qtbase5-dev:amd64 5.9.5+dfsg-0ubuntu1 amd64 Qt 5 base development files
ii qtbase5-dev-tools 5.9.5+dfsg-0ubuntu1 amd64 Qt 5 base development programs
ii qtbase5-doc 5.9.5+dfsg-0ubuntu1 all Qt 5 base documentation

So far I've not found what is missing.

Cyp
Evitcani
Evitcani
Posts: 753
Joined: 17 Jan 2010, 23:35

Re: Ubuntu 18.04 fails to compile

Post by Cyp » 23 Feb 2019, 08:28

Not sure. Try qtscript5-dev if you don't have it already.

Post Reply