Page 1 of 1

Fast play using skirmish instead of campaign.

PostPosted: 10 Aug 2018, 16:32
by WZ2100ModsFAn
when i load fast play it says host has quit the game.

here's my logs.

it's something wrong with the game because i have no mods loaded and nothing modified.

Code: Select all
info    |09:27:50: [openLoadFile:149] file messages/multiplay.txt could not be opened: not found
info    |09:27:50: [openLoadFile:149] Assert in Warzone: c:\projects\warzone2100\lib\framework\frame.cpp:149 (!"unable to open file"), last script event: '<none>'
error   |09:27:50: [resLoadFile:526] resLoadFile: Unable to retreive resource - messages/multiplay.txt
info    |09:27:50: [openLoadFile:149] file multiplay/skirmish/rules.js could not be opened: not found
info    |09:27:50: [openLoadFile:149] Assert in Warzone: c:\projects\warzone2100\lib\framework\frame.cpp:149 (!"unable to open file"), last script event: '<none>'
error   |09:27:50: [loadPlayerScript:615] Failed to read script file "multiplay/skirmish/rules.js"
info    |09:27:50: [openLoadFile:149] file multiplay/skirmish/nb_generic.js could not be opened: not found
info    |09:27:50: [openLoadFile:149] Assert in Warzone: c:\projects\warzone2100\lib\framework\frame.cpp:149 (!"unable to open file"), last script event: '<none>'
error   |09:27:50: [loadPlayerScript:615] Failed to read script file "multiplay/skirmish/nb_generic.js"
info    |09:27:50: [openLoadFile:149] file multiplay/skirmish/nb_generic.js could not be opened: not found
info    |09:27:50: [openLoadFile:149] Assert in Warzone: c:\projects\warzone2100\lib\framework\frame.cpp:149 (!"unable to open file"), last script event: '<none>'
error   |09:27:50: [loadPlayerScript:615] Failed to read script file "multiplay/skirmish/nb_generic.js"
info    |09:27:50: [openLoadFile:149] file multiplay/skirmish/nb_generic.js could not be opened: not found
info    |09:27:50: [openLoadFile:149] Assert in Warzone: c:\projects\warzone2100\lib\framework\frame.cpp:149 (!"unable to open file"), last script event: '<none>'
error   |09:27:50: [loadPlayerScript:615] Failed to read script file "multiplay/skirmish/nb_generic.js"
error   |09:27:50: [callFunction:243] 0 : camSetArtifacts(artifacts = [object Object]) at script/campaign/libcampaign.js:764
error   |09:27:50: [callFunction:243] 1 : eventStartLevel() at script/fastplay/fastdemo.js:171
error   |09:27:50: [callFunction:243] 2 : <global>() at -1
info    |09:27:50: [callFunction:246] Uncaught exception calling function "eventStartLevel" at line 764: TypeError: Result of expression 'pos' [undefined] is not an object.
info    |09:27:50: [callFunction:246] Assert in Warzone: c:\projects\warzone2100\src\qtscript.cpp:246 (false), last script event: '<none>'

Re: Fast play using skirmish instead of campaign.

PostPosted: 11 Aug 2018, 01:10
by Berg
Im not sure but fast play is not ment to have Mods!!
Try playing it without mods and if it works you have broken it with your mods

Re: Fast play using skirmish instead of campaign.

PostPosted: 11 Aug 2018, 04:58
by WZ2100ModsFAn
Berg wrote:Im not sure but fast play is not ment to have Mods!!
Try playing it without mods and if it works you have broken it with your mods

WZ2100ModsFAn wrote:i have no mods loaded


ok well now it works.

that bug / error suddenly happened rarely.

Re: Fast play using skirmish instead of campaign.

PostPosted: 11 Aug 2018, 19:49
by Berserk Cyborg
True, they are campaigns (at least when I last worked on tutorial/fast-play). I don't see any errors with fast-play when I tested it on latest master (no mods).

The one thing out of the ordinary is a net log is created when going into fast-play now. :hmm:

Re: Fast play using skirmish instead of campaign.

PostPosted: 11 Aug 2018, 20:02
by pastdue
I wonder if there's a state issue.

WZ2100ModsFAn: Did you play any other mode of the game / other game match before starting that Fastplay that failed? (Or had you freshly started the Warzone executable?)

Re: Fast play using skirmish instead of campaign.

PostPosted: 11 Aug 2018, 22:46
by WZ2100ModsFAn
pastdue wrote:I wonder if there's a state issue.

WZ2100ModsFAn: Did you play any other mode of the game / other game match before starting that Fastplay that failed? (Or had you freshly started the Warzone executable?)

Well i played tutorial and it works perfectly fine.

I'm now playing WarzoneDemoCD instead of master.