Cannot install vcpkg with Windows 7

Do you need help? Ask here!

Bug reporting belongs here:

Cannot install vcpkg with Windows 7

Postby Forgon » 03 Mar 2018, 11:30

On a fresh installation of Windows 7 Home Premium, the powershell script `get-dependencies.ps1` inside the source code directory failed because `vcpkg` could not be installed due to this routine failing. Could someone tell me what I have done wrong? The command output:

Code: Select all
git.exe : Cloning into 'vcpkg'...
At C:\Users\x\warzone2100\get-dependencies.ps1:1 char:4
+ git <<<<  clone;
    + CategoryInfo          : NotSpecified: (Cloning into 'vcpkg'...:String) [], RemoteException
    + FullyQualifiedErrorId : NativeCommandError
Downloading vswhere...
WARNING: Github has dropped support for TLS versions prior to 1.2, which is not available on your
WARNING: Please manually download to
bootstrap-vcpkg.bat : Download failed
At C:\Users\x\warzone2100\get-dependencies.ps1:3 char:22
+ .\bootstrap-vcpkg.bat <<<< ;
    + CategoryInfo          : NotSpecified: (Download failed:String) [], RemoteException
    + FullyQualifiedErrorId : NativeCommandError
At C:\Users\x\warzone2100\vcpkg\scripts\VcpkgPowershellUtils.ps1:143 char:18

+             throw <<<<  "Download failed"

    + CategoryInfo          : OperationStopped: (Download failed:String) [], RuntimeException

    + FullyQualifiedErrorId : Download failed


The term '.\vcpkg' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spe
lling of the name, or if a path was included, verify that the path is correct and try again.
At C:\Users\x\warzone2100\get-dependencies.ps1:4 char:8
+ .\vcpkg <<<<  install physfs harfbuzz libiconv libogg libtheora libvorbis libpng openal-soft sdl2 glew freetype gette
xt zlib
    + CategoryInfo          : ObjectNotFound: (.\vcpkg:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

output of powershell when executing `get-dependencies.ps1` on newly installed Windows 7 Home Premium
msvc_dependencies_script_error.png (48.64 KiB) Viewed 98 times
Code contributor
Code contributor
Posts: 74
Joined: 07 Dec 2016, 22:23

Re: Cannot install vcpkg with Windows 7

Postby pastdue » 03 Mar 2018, 19:52

Follow the instructions in the warning to manually download: ... swhere.exe

Then re-run get-dependencies.ps1

As the warning indicates, GitHub has dropped support for TLS versions prior to 1.2, and this impacts the ability of the vcpkg bootstrapping script to automatically download everything on earlier versions of Windows.
Code contributor
Code contributor
Posts: 37
Joined: 13 Aug 2017, 17:44

Return to Technical Help / Troubleshooting