Game crash 40 minutes after start playing

Do you need help? Ask here!

Bug reporting belongs here: http://developer.wz2100.net/newticket

Game crash 40 minutes after start playing

Postby Cpablo » 05 May 2017, 19:14

I turn off shaders, set graphic to minimun, and it still the same. the game go stead, and works perfect but from nothing it crash. Here is the log

--- Starting log [C:\Users\cpablo\Documents\Warzone 2100 3.2\logs\WZlog-0505_101007.txt]---
info |10:10:07: [realmain:938] Using C:\Users\cpablo\Documents\Warzone 2100 3.2\logs\WZlog-0505_101007.txt debug file
info |10:32:58: [getComponentRadius:114] No ComponentIMD!
info |10:32:58: [getComponentRadius:114] Assert in Warzone: component.cpp:114 (ComponentIMD), last script event: 'N/A'
info |10:32:58: [displayComponentButton:283] No ComponentIMD
info |10:32:58: [displayComponentButton:283] Assert in Warzone: component.cpp:283 (ComponentIMD), last script event: 'N/A'
info |10:32:58: [getComponentRadius:114] No ComponentIMD!
info |10:32:58: [getComponentRadius:114] Assert in Warzone: component.cpp:114 (ComponentIMD), last script event: 'N/A'
info |10:32:58: [displayComponentButton:283] No ComponentIMD
info |10:32:58: [displayComponentButton:283] Assert in Warzone: component.cpp:283 (ComponentIMD), last script event: 'N/A'
info |10:32:58: [getComponentRadius:114] No ComponentIMD!
info |10:32:58: [getComponentRadius:114] Assert in Warzone: component.cpp:114 (ComponentIMD), last script event: 'N/A'
info |10:32:58: [displayComponentButton:283] No ComponentIMD
info |10:32:58: [displayComponentButton:283] Assert in Warzone: component.cpp:283 (ComponentIMD), last script event: 'N/A'
info |10:32:58: [getComponentRadius:114] No ComponentIMD!
info |10:32:58: [getComponentRadius:114] Assert in Warzone: component.cpp:114 (ComponentIMD), last script event: 'N/A'
info |10:32:58: [displayComponentButton:283] No ComponentIMD
info |10:32:58: [displayComponentButton:283] Assert in Warzone: component.cpp:283 (ComponentIMD), last script event: 'N/A'
info |10:32:58: [getComponentRadius:114] No ComponentIMD!
info |10:32:58: [getComponentRadius:114] Assert in Warzone: component.cpp:114 (ComponentIMD), last script event: 'N/A'
info |10:32:58: [displayComponentButton:283] No ComponentIMD
info |10:32:58: [displayComponentButton:283] Assert in Warzone: component.cpp:283 (ComponentIMD), last script event: 'N/A'
info |10:32:58: [getComponentRadius:114] No ComponentIMD!
info |10:32:58: [getComponentRadius:114] Assert in Warzone: component.cpp:114 (ComponentIMD), last script event: 'N/A'
info |10:32:58: [displayComponentButton:283] No ComponentIMD
info |10:32:58: [displayComponentButton:283] Assert in Warzone: component.cpp:283 (ComponentIMD), last script event: 'N/A'
info |10:32:59: [getComponentRadius:114] No ComponentIMD!
info |10:32:59: [getComponentRadius:114] Assert in Warzone: component.cpp:114 (ComponentIMD), last script event: 'N/A'
info |10:32:59: [displayComponentButton:283] No ComponentIMD
info |10:32:59: [displayComponentButton:283] Assert in Warzone: component.cpp:283 (ComponentIMD), last script event: 'N/A'
info |10:32:59: [getComponentRadius:114] No ComponentIMD!
info |10:32:59: [getComponentRadius:114] Assert in Warzone: component.cpp:114 (ComponentIMD), last script event: 'N/A'
info |10:32:59: [displayComponentButton:283] No ComponentIMD
info |10:32:59: [displayComponentButton:283] Assert in Warzone: component.cpp:283 (ComponentIMD), last script event: 'N/A'
Cpablo
Greenhorn
 
Posts: 11
Joined: 05 May 2017, 19:11

Re: Game crash 40 minutes after start playing

Postby Per » 05 May 2017, 20:02

Are you running a mod? Does it generate a crash log (.RPT file somewhere)?
Per
Warzone 2100 Team Member
Warzone 2100 Team Member
 
Posts: 3605
Joined: 03 Aug 2006, 19:39

Re: Game crash 40 minutes after start playing

Postby Cpablo » 05 May 2017, 20:19

Here is another one. No i dont see any rpt files, just these ones. I dont play any mod, i used debug mode but no mods. Also my game is frozed in alpha 2 mission, the same than viewtopic.php?f=4&t=12754

No mods, nothing rare, i just was testing the game. I think what i should play the warzone 2100 rom for psx :|

--- Starting log [C:\Users\cpablo\Documents\Warzone 2100 3.2\logs\WZlog-0504_210208.txt]---
info |09:02:08: [realmain:938] Using C:\Users\cpablo\Documents\Warzone 2100 3.2\logs\WZlog-0504_210208.txt debug file
error |09:07:30: [gameTimeUpdate:217] Synch error, gameTimes were: { 103202, 103202, 0, 0, 0, 0, 0, 0, 0, 0}
error |09:07:30: [gameTimeUpdate:218] Synch error, CRCs were: { 0xA9DE, 0xA9DE, 0x0000, 0x0000, 0x0000, 0x0000, 0x0000, 0x0000, 0x0000, 0x0000}
error |09:07:33: [gameTimeUpdate:217] Synch error, gameTimes were: { 106202, 106202, 0, 0, 0, 0, 0, 0, 0, 0}
error |09:07:33: [gameTimeUpdate:218] Synch error, CRCs were: { 0x1400, 0x1400, 0x0000, 0x0000, 0x0000, 0x0000, 0x0000, 0x0000, 0x0000, 0x0000}
error |09:15:32: [gameTimeUpdate:217] Synch error, gameTimes were: { 291702, 291702, 0, 0, 0, 0, 0, 0, 0, 0}
error |09:15:32: [gameTimeUpdate:218] Synch error, CRCs were: { 0x1D7A, 0x1D7A, 0x0000, 0x0000, 0x0000, 0x0000, 0x0000, 0x0000, 0x0000, 0x0000}
error |09:15:49: [gameTimeUpdate:217] Synch error, gameTimes were: { 309102, 309102, 0, 0, 0, 0, 0, 0, 0, 0}
error |09:15:49: [gameTimeUpdate:218] Synch error, CRCs were: { 0x0994, 0x0994, 0x0000, 0x0000, 0x0000, 0x0000, 0x0000, 0x0000, 0x0000, 0x0000}
error |09:15:52: [gameTimeUpdate:217] Synch error, gameTimes were: { 311702, 309102, 311702, 0, 0, 0, 0, 0, 0, 0}
error |09:15:52: [gameTimeUpdate:218] Synch error, CRCs were: { 0x4813, 0x0994, 0x4813, 0x0000, 0x0000, 0x0000, 0x0000, 0x0000, 0x0000, 0x0000}
error |09:15:54: [gameTimeUpdate:217] Synch error, gameTimes were: { 311702, 309102, 313502, 313502, 0, 0, 0, 0, 0, 0}
error |09:15:54: [gameTimeUpdate:218] Synch error, CRCs were: { 0x4813, 0x0994, 0x2E7A, 0x2E7A, 0x0000, 0x0000, 0x0000, 0x0000, 0x0000, 0x0000}
error |09:15:56: [gameTimeUpdate:217] Synch error, gameTimes were: { 311702, 309102, 313502, 315702, 0, 0, 315702, 0, 0, 0}
error |09:15:56: [gameTimeUpdate:218] Synch error, CRCs were: { 0x4813, 0x0994, 0x2E7A, 0xEF67, 0x0000, 0x0000, 0xEF67, 0x0000, 0x0000, 0x0000}
error |09:16:00: [gameTimeUpdate:217] Synch error, gameTimes were: { 311702, 309102, 313502, 315702, 0, 319602, 319602, 0, 0, 0}
error |09:16:00: [gameTimeUpdate:218] Synch error, CRCs were: { 0x4813, 0x0994, 0x2E7A, 0xEF67, 0x0000, 0x07DA, 0x07DA, 0x0000, 0x0000, 0x0000}
error |09:16:03: [gameTimeUpdate:217] Synch error, gameTimes were: { 311702, 309102, 313502, 315702, 0, 322702, 322702, 0, 0, 0}
error |09:16:03: [gameTimeUpdate:218] Synch error, CRCs were: { 0x4813, 0x0994, 0x2E7A, 0xEF67, 0x0000, 0x45D1, 0x45D1, 0x0000, 0x0000, 0x0000}
error |09:16:36: [gameTimeUpdate:217] Synch error, gameTimes were: { 353202, 309102, 313502, 315702, 0, 322702, 353202, 0, 0, 0}
error |09:16:36: [gameTimeUpdate:218] Synch error, CRCs were: { 0x67F3, 0x0994, 0x2E7A, 0xEF67, 0x0000, 0x45D1, 0x67F3, 0x0000, 0x0000, 0x0000}
error |09:39:15: [gameTimeUpdate:217] Synch error, gameTimes were: { 705802, 309102, 313502, 315702, 0, 322702, 705802, 0, 0, 0}
error |09:39:15: [gameTimeUpdate:218] Synch error, CRCs were: { 0x1F85, 0x0994, 0x2E7A, 0xEF67, 0x0000, 0x45D1, 0x1F85, 0x0000, 0x0000, 0x0000}
error |09:39:51: [gameTimeUpdate:217] Synch error, gameTimes were: { 705802, 309102, 313502, 315702, 0, 322702, 742502, 742502, 0, 0}
error |09:39:51: [gameTimeUpdate:218] Synch error, CRCs were: { 0x1F85, 0x0994, 0x2E7A, 0xEF67, 0x0000, 0x45D1, 0xFD68, 0xFD68, 0x0000, 0x0000}
error |09:39:55: [gameTimeUpdate:217] Synch error, gameTimes were: { 746602, 309102, 313502, 315702, 0, 322702, 742502, 746602, 0, 0}
error |09:39:55: [gameTimeUpdate:218] Synch error, CRCs were: { 0x8D65, 0x0994, 0x2E7A, 0xEF67, 0x0000, 0x45D1, 0xFD68, 0x8D65, 0x0000, 0x0000}
Cpablo
Greenhorn
 
Posts: 11
Joined: 05 May 2017, 19:11

Re: Game crash 40 minutes after start playing

Postby Cpablo » 05 May 2017, 20:54

I think now what the Graphic card is the problem, i know what it is old and i see wht is Intel. But the game works perfectly (except when it crash, and the fact what i can do mission 2...but i dont see any error)
Is here a solution different from buy another computer or play warzone in the psx?

Modules
Operating System
Windows 7 Starter ‎(X86)‎ Service Pack 1
System install date: 5/16/2016
Processor
Intel Celeron E3400 clocked at 2.60 GHz
Processor frequency measure (core0): 1.20 GHz
Number of cores: 2 físico, 2 lógico
Processor socket: Socket 775 LGA
CPU Temperature (core 0): 45 °C
Motherboard
Gigabyte Technology Co., Ltd. G41MT-S2 x.x
Bios version: F7
Date: 8/3/2011
Chipset
Northbridge : Intel G41
Revision ID: A3
Southbridge : Intel 82801GB (ICH7/R)
Revision ID: A1
Memory
2 GB total memory type DDR3 to 400.48 MHz
Memory timing: 6.0 clocks-6 clocks-6 clocks-15 clocks-2 TT
Memory chip NovaTech Solutions of 2 GB
Maximum frequency: 667 MHz
Max bandwidth: PC3-10700
Graphics card
Intel(R) G41 Express Chipset
DirectX version installed: 11.0
Harddrive
Harddrive WDCWD5000AAKX-083CA0 of 465.76 GB SATA III
Firmware: 15.01H15
SATA version: SATA Rev 2.6
Serial number: WD-WCAYUL994785
HDD Temperature: 42 °C
Power time: 43097 hours
Harddrive USB Mass Storage Device USB Device
CD-ROM
TSSTcorp CDDVDW SH-224DB
Event type: DVD-R/DL sequential recording Recorder
Firmware version: SB00
Network
Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet
Adapter type: ethernet
Software Loopback Interface 1
Adapter type: Loopback
Multimedia cards
Intel Corporation NM10/ICH7 Family High Definition Audio Controller
Keyboard
Primax Electronics, Ltd USB Multimedia Keyboard
Mouse
(Defined at Interface level)
Screen(s)
E1941
Manufacturer: LG Electronics Inc. (GoldStar Technology, Inc.)
Maximum resolution: 1366 x 768
Screen size: 18.5" (41 cm x 23 cm)
Manufacture date: 3/4/2011
Aspect ratio: 16:9
Video input type: Reserved Analog Signal
USB peripheral
(Defined at Interface level)
Supported USB version: 1.10
Primax Electronics, Ltd USB Multimedia Keyboard
Supported USB version: 1.10
Super Top USB Mass Storage Device
Supported USB version: 2.0
Cpablo
Greenhorn
 
Posts: 11
Joined: 05 May 2017, 19:11

Re: Game crash 40 minutes after start playing

Postby Cpablo » 07 May 2017, 16:57

The game starts generating rpt files each time what crash. Notice what i can play the game, i am actually in the last alpha missión, but i need save often becouse it continue crashing. It dont run slow, it dont have issues, just crash for nothing! it is very annoying

Error occured on Saturday, May 6, 2017 at 22:19:42.

Program: D:\Program Files\Warzone 2100-3.2.3\warzone2100.exe(warzone2100)
Command line: "D:\Program Files\Warzone 2100-3.2.3\warzone2100.exe"
Version: Version: 3.2.3, Built:Apr 23 2017
Distributor: wz2100.net
Compiled on: Apr 23 2017 15:17:04
Compiled by: GCC 4.9.3
Compiled mode: Release build
Executed on: Sat May 06 22:05:09 2017

Pointers: 32bit

Compiled against PhysicsFS version: 2.0.3
Running with PhysicsFS version: 2.0.3

Misc Data:
[22:05:09]Video Mode 1024 x 768 (window)
[22:05:09]OpenGL Vendor: Intel
[22:05:09]OpenGL Renderer: Intel(R) G41 Express Chipset
[22:05:09]OpenGL Version: 2.1.0 - Build 8.15.10.2869
[22:05:09]GLEW Version: 1.12.0
[22:05:09]OpenGL GLSL Version : 1.20 - Intel Build 8.15.10.2869
[22:05:10]OpenAL Device Name: OpenAL Soft
[22:05:10]OpenAL Vendor: OpenAL Community
[22:05:10]OpenAL Version: 1.1 ALSOFT 1.16.0
[22:05:10]OpenAL Renderer: OpenAL Soft
[22:05:10]OpenAL Extensions: AL_EXT_ALAW AL_EXT_DOUBLE AL_EXT_EXPONENT_DISTANCE AL_EXT_FLOAT32 AL_EXT_IMA4 AL_EXT_LINEAR_DISTANCE AL_EXT_MCFORMATS AL_EXT_MULAW AL_EXT_MULAW_MCFORMATS AL_EXT_OFFSET AL_EXT_source_distance_model AL_LOKI_quadriphonic AL_SOFT_block_alignment AL_SOFT_buffer_samples AL_SOFT_buffer_sub_data AL_SOFT_deferred_updates AL_SOFT_direct_channels AL_SOFT_loop_points AL_SOFT_MSADPCM AL_SOFT_source_latency AL_SOFT_source_length
[22:05:10]Using Backend: SDL
[22:05:10]Using language: English
[22:05:28]Current Level/map is CAM_1A-C
[22:12:11]Current Level/map is SUB_1_7S
[22:13:12]Current Level/map is SUB_1_7


D:\Program Files\Warzone 2100-3.2.3\warzone2100.exe caused an Access Violation at location 125db2e9 in module C:\Windows\system32\ig4icd32.dll Writing to location 099f6844.

Log message: info |10:13:11: [triggerEventSeen:1278] Scripts not initialized yet
Log message: info |10:13:11: [triggerEventSeen:1278] Assert in Warzone: qtscript.cpp:1278 (scriptsReady), last script event: 'N/A'
Log message: info |10:13:11: [triggerEventSeen:1278] Scripts not initialized yet
Log message: info |10:13:11: [triggerEventSeen:1278] Assert in Warzone: qtscript.cpp:1278 (scriptsReady), last script event: 'N/A'
Log message: info |10:13:11: [triggerEventSeen:1278] Scripts not initialized yet
Log message: info |10:13:11: [triggerEventSeen:1278] Assert in Warzone: qtscript.cpp:1278 (scriptsReady), last script event: 'N/A'
Log message: info |10:13:11: [triggerEventSeen:1278] Scripts not initialized yet
Log message: info |10:13:11: [triggerEventSeen:1278] Assert in Warzone: qtscript.cpp:1278 (scriptsReady), last script event: 'N/A'
Log message: info |10:13:11: [triggerEventSeen:1278] Scripts not initialized yet
Log message: info |10:13:11: [triggerEventSeen:1278] Assert in Warzone: qtscript.cpp:1278 (scriptsReady), last script event: 'N/A'
Log message: info |10:13:11: [triggerEventSeen:1278] Scripts not initialized yet
Log message: info |10:13:11: [triggerEventSeen:1278] Assert in Warzone: qtscript.cpp:1278 (scriptsReady), last script event: 'N/A'
Log message: info |10:13:11: [triggerEventSeen:1278] Scripts not initialized yet
Log message: info |10:13:11: [triggerEventSeen:1278] Assert in Warzone: qtscript.cpp:1278 (scriptsReady), last script event: 'N/A'
Log message: info |10:13:11: [triggerEventSeen:1278] Scripts not initialized yet
Log message: info |10:13:11: [triggerEventSeen:1278] Assert in Warzone: qtscript.cpp:1278 (scriptsReady), last script event: 'N/A'
Log message: info |10:13:11: [triggerEventSeen:1278] Scripts not initialized yet
Log message: info |10:13:11: [triggerEventSeen:1278] Assert in Warzone: qtscript.cpp:1278 (scriptsReady), last script event: 'N/A'
Log message: info |10:13:11: [triggerEventStructBuilt:1118] Scripts not initialized yet
Log message: info |10:13:11: [triggerEventStructBuilt:1118] Assert in Warzone: qtscript.cpp:1118 (scriptsReady), last script event: 'N/A'

Registers:
eax=00000001 ebx=5bcbf760 ecx=099f6844 edx=0022ea58 esi=00000001 edi=099f6844
eip=125db2e9 esp=0022e958 ebp=00000000 iopl=0 nv up ei pl nz na pe nc
cs=001b ss=0023 ds=0023 es=0023 fs=003b gs=0000 efl=00010202

Call stack:
Cpablo
Greenhorn
 
Posts: 11
Joined: 05 May 2017, 19:11

Re: Game crash 40 minutes after start playing

Postby Per » 07 May 2017, 22:19

Crashes inside the Intel graphics driver - no call stack, so no way of knowing what caused it... Maybe try to upgrade your graphics driver?
Per
Warzone 2100 Team Member
Warzone 2100 Team Member
 
Posts: 3605
Joined: 03 Aug 2006, 19:39

Re: Game crash 40 minutes after start playing

Postby Cpablo » 08 May 2017, 00:17

1) i update them to the last driver avaible. Before that here the game doestn even generate crash reports. It now generate them
2) intry to use titanium gl but the game doesnt start even. It tell a clash contact
3) i try to put graphic off but no way. The game runs perfectly but it crash after an amount of time. Even if i let it in main menu. I turn off music(thinking what it is a music damage problem cos it change random while playing) but.it.keeps the same...

I am now in beta campaign but it so annoying 😭😭😭😭😭
Cpablo
Greenhorn
 
Posts: 11
Joined: 05 May 2017, 19:11

Re: Game crash 40 minutes after start playing

Postby vexed » 13 May 2017, 23:44

Thing is, you are crashing because Intel's video drivers are crap (ig4icd32.dll).

About the only thing you can do is file bug reports with Intel, and maybe they will fix their drivers one day, however, going by how old Intel(R) G41 is, doubt they will do anything. :(
/facepalm ...Grinch stole Warzone🙈🙉🙊 contra principia negantem non est disputandum
Super busy, don't expect a timely reply back.
User avatar
vexed
Inactive
Inactive
 
Posts: 2407
Joined: 27 Jul 2010, 02:07

Re: Game crash 40 minutes after start playing

Postby Cpablo » 28 May 2017, 06:08

I am playing 2.3.9 now. It doesnt crash and works smothly. So at least i can replay it😺
Cpablo
Greenhorn
 
Posts: 11
Joined: 05 May 2017, 19:11


Return to Technical Help / Troubleshooting

cron