FPS drops bellow 8 and lag in skirmish, huge 160x250 map

Do you need help? Ask here!

Bug reporting belongs here: http://developer.wz2100.net/newticket

FPS drops bellow 8 and lag in skirmish, huge 160x250 map

Postby Doruletz » 12 Apr 2017, 11:11

Hi.

I have a top of the line PC, using Linux, so ZERO possibility of viruses or other typical Microsoft malware...
I made this huge 5 player map in FlaME, it's 160 by 250 with lots of details, water, scavs have lots of structures, etc.
Skirmish game play lags and FPS drops to 8 or even 4 at times.
I tried lowering FSAA to x4, x2 or OFF, same thing. I tried V-Sync both on and off, I even reduced Texture Size from 2048 to 1024, same problem.
I cannot imagine what can cause this, so please help...

Here are my Gaming PC specs:

OS: Linux Mint 18 Sarah MATE 64-bit
MOTHERBOARD: Gigabyte Z97X-Gaming 7
CPU: Intel Core i7-4790K CPU @ 4.00GHz × 8 (quad core with hyper-threading) - Liquid cooled with a Thermaltake Water 2.0 PRO 120mm radiator
RAM: 32GB DDR3 1600 MHz (4x8GB) of G.SKILL Ripjaws X Series
GPU: EVGA Superclocked nVidia GTX 960 with 2GB GDDR5
- soon to be upgraded to a GTX 1080
Two SATA III @ 6 GB/s Toshiba SSD Drives: one 128GB Toshiba SSD mounted as "/" (ROOT), for Linux OS System Files and one 960GB Toshiba SSD mounted as "/home", for my User Home Folder (Personal Files and Settings).
NOTE: This PC also has 3 additional internal storage SATA III @ 6 GB/s HDD of 2TB, 5.6TB and 6TB respectively, used for storing all my Movies, TV Series, music, pictures, lots of Live-Install ISO files of various Linux Distros, etc.
PSU: 850W Gold Rated Thermaltake Smart Series - Fully Modular PSU
All of the above is housed in a cool Rosewill THOR Gaming ATX Full Tower Computer Case

NOTE: This Rosewill THOR case is considered among the very best, by having lots of space and excellent cable management as well as good peripherals quick change capabilities.
All of the above mentioned features of the THOR PC Case amounts to having an excellent air flow and cooling, which is also provided by 3 huge 230 mm fans
(one RED LED 230mm fan in the front, one each 230 mm topside and side panel).
Another 120 mm fan is mounted at the bottom, next to the PSU.


I built this gaming PC myself, with parts I purchased online, from Newegg.com and Amazon. Building computers is my one and only hobby, I have a total of 7 desktop PCs around the house, but this one is my main machine...
And I am strictly an Intel + nVidia guy, never used any AMD/ATI GPU in my entire life, and only have one AMD CPU based PC, which I built out of pure curiosity, back when the "new" AMD Bulldozer Series was launched and praised to the max as being a worthy competitor to Intel Core i CPUs (which ended up being just a big load of crap).

Here is my "inxi -F" Terminal listing:

Code: Select all
<MY-USER-NAME>@THOR-PC-Z97X-Gaming-7 ~ $ inxi -F
System:    Host: THOR-PC-Z97X-Gaming-7 Kernel: 4.10.0-14-generic x86_64 (64 bit)
           Desktop: MATE 1.14.1  Distro: Linux Mint 18 Sarah
Machine:   Mobo: Gigabyte model: Z97X-Gaming 7 v: x.x
           Bios: American Megatrends v: F6 date: 05/30/2014
CPU:       Quad core Intel Core i7-4790K (-HT-MCP-) cache: 8192 KB
           clock speeds: max: 4400 MHz 1: 4399 MHz 2: 4399 MHz 3: 4399 MHz
           4: 4399 MHz 5: 4400 MHz 6: 4400 MHz 7: 4399 MHz 8: 4399 MHz
Graphics:  Card-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
           Card-2: NVIDIA GM206 [GeForce GTX 960]
           Display Server: X.Org 1.18.4 drivers: nvidia,intel (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: GeForce GTX 960/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 375.39
Audio:     Card-1 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller
           driver: snd_hda_intel
           Card-2 NVIDIA Device 0fba driver: snd_hda_intel
           Card-3 Intel 9 Series Family HD Audio Controller
           driver: snd_hda_intel
           Card-4 Logitech driver: USB Audio
           Sound: Advanced Linux Sound Architecture v: k4.10.0-14-generic
Network:   Card: Qualcomm Atheros Killer E220x Gigabit Ethernet Controller
           driver: alx
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full
           mac: 74:d4:35:ed:48:6e
Drives:    HDD Total Size: 14949.3GB (45.7% used)
           ID-1: /dev/sda model: TOSHIBA_THNSNJ12 size: 128.0GB
           ID-2: /dev/sdb model: TOSHIBA size: 960.2GB
           ID-3: /dev/sdc model: TOSHIBA_THNSNJ25 size: 256.1GB (NOT USED)
           ID-4: /dev/sdd model: Hitachi_HDS72302 size: 2000.4GB
           ID-5: /dev/sde model: WL5000GSA6454 size: 5601.3GB
           ID-6: /dev/sdf model: ST6000DX000 size: 6001.2GB
           ID-7: USB /dev/sdg model: TRAVELDRIVE_005B size: 2.1GB
Partition: ID-1: / size: 118G used: 36G (33%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 881G used: 141G (17%) fs: ext4 dev: /dev/sdb1
           ID-3: swap-1 size: 2.06GB used: 0.00GB (0%) fs: swap dev: /dev/sdg1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 43C
           Fan Speeds (in rpm): cpu: 1078 fan-1: 1642 fan-3: 464 fan-4: 0 fan-5: 0
Info:      Processes: 261 Uptime: 28 min Memory: 1484.6/31987.9MB
           Client: Shell (bash) inxi: 2.2.35


GPU Temp of 43°C is with WZ2100 running idle in the background while I type this post, normal GPU temp is 29°C to 32°C with just web browsing and other light duty stuff running.

Last, but not least, can someone please post a Terminal command to launch WZ2100 using more than the default one single CPU Core (like 4 maybe)??
Last edited by Doruletz on 13 Apr 2017, 01:14, edited 4 times in total.
What do I think about Window$ ??? Just see my AVATAR...
User avatar
Doruletz
Trained
Trained
 
Posts: 90
Joined: 17 Sep 2015, 06:00
Location: Tennessee, USA

Re: FPS drops bellow 8 and lag in skirmish, huge 160x250 map

Postby Per » 12 Apr 2017, 18:16

Warzone should be CPU-limited on any modern GPU. To verify, open 'top' to see that CPU load is at 100% when you have less than 60fps (ie not vsync limited).

The worst offender is the shadows drawing, so turn that off if you have problems.

If turning off shadows doesn't help, then post your savegame here, so I can have a look...
Per
Warzone 2100 Team Member
Warzone 2100 Team Member
 
Posts: 3649
Joined: 03 Aug 2006, 19:39

Re: FPS drops bellow 8 and lag in skirmish, huge 160x250 map

Postby Berserk Cyborg » 12 Apr 2017, 18:18

Try using master and see if that makes any difference (compile guide). Turning off shadows can improve performance significantly as well. Also are you using any mods or have anything in your log files?
User avatar
Berserk Cyborg
Code contributor
Code contributor
 
Posts: 340
Joined: 26 Sep 2016, 19:56

Re: FPS drops bellow 8 and lag in skirmish, huge 160x250 map

Postby Doruletz » 12 Apr 2017, 23:10

Berserk Cyborg wrote:Try using master and see if that makes any difference (compile guide). Turning off shadows can improve performance significantly as well. Also are you using any mods or have anything in your log files?


@"Berserk Cyborg" and all others:

MASTER is exactly what I'm using. Version MASTER 1ce7e09 Build Nov 17, 2016.
And YES, I am using MODS, namely the UltScav MOD. In fact it's a modified version of ultimatescavs-1-17-RC2, in which I added the ability to limit or completely eliminate all Artillery Defense Structures (NO Mortar Pits, Howitzer, Rocket and Missile Emplacements), as well as the Missile and Mass Driver Fortresses.
Some people are using a full NO ARTY MOD, available for download in the ADD-ON section, but I never liked that.
I can make good use of mobile Artillery Units, I just don't like the Artillery Defense Structures.
In my opinion, a WZ2100 game should be played and won by clever usage and deployment of mobile battle units, not by building a S*H*I*T* load of Artillery Defense Structures and waiting for your opponent(s) to bring the war to you.
That is at least how I see it...
Also, all games I play are NO VTOL games. VTOLs are the only other thing I hate about WZ2100.

I mostly play WZ2100 by myself, just Skirmish games against multiple AI opponents, with or without an AI ally. It's usually just me against 3 or 4, maybe even 5 AIs. Sometimes I take an AI ally to help me with research, but most of the times I don't.

The thing is that on almost all other maps I don't have this problem, it's just this one map that I made from scratch, using FlaME 1.29 by running Mono 2.10 in Linux.
This particular map, which I rightfully called DO-SURF-N-TURF, is huge, being 160 x 250 tiles in size, and having lots of water, with islands, choke points, and rough terrain. Also the Scavs are very well equipped, I gave them lots of defensive structures and also plenty of Heavy Cannon Python Tracks and Scourge Mantis Tracks units, which are all held prisoners on islands, and meant to stave off any attempt at an early rush from my AI opponents.

Here is a snapshot of this 5 player (2 vs 3) map:

Image

I want to be able to play the game well into its late stages, with advanced weaponry such as Pulse and Heavy Laser, Scourge, Seraph and Archangel Missiles, Rail Gun and Gauss Cannons, etc.
Also, I hate having to linger or retreat due to heavy artillery fire whenever I decide to finish off one of my opponents.
That is why I make all my maps this way, and I always play what you can call a "NO ARTY STRUCTURES" game. I do however use mobile artillery intensively, having at least 2 or 3 battle groups of Howitzers and Archangel Missile Batteries assigned to sensor units at all times.
What do I think about Window$ ??? Just see my AVATAR...
User avatar
Doruletz
Trained
Trained
 
Posts: 90
Joined: 17 Sep 2015, 06:00
Location: Tennessee, USA

Re: FPS drops bellow 8 and lag in skirmish, huge 160x250 map

Postby Doruletz » 13 Apr 2017, 01:35

Per wrote:Warzone should be CPU-limited on any modern GPU. To verify, open 'top' to see that CPU load is at 100% when you have less than 60fps (ie not vsync limited).

The worst offender is the shadows drawing, so turn that off if you have problems.

If turning off shadows doesn't help, then post your savegame here, so I can have a look...


@"Per":

I know what you mean by having a CPU load of 100%, and up until recently I used to have that at all times (or at least everytime I bothered to exit full screen and check my System Monitor).
For some reason, maybe due to recent system updates, that is not the case now. My CPU usage stays around 28% up to a maximum of 60%.

I did not understand what you meant when you said "To verify, open 'top'". Can you explain that to me, please.
Also, I guess that by "shadows drawing" you mean the FSAA setting in Video Options, right?
As mentioned before in my initial post, I already tried to lower that from the maximum of x8 to x4 and x2, and I even turned it off altogether, with no result.

Here is a snapshot I "compiled". It shows all Video Options I have tried so far:

Image

Last but not least, you want me to save the game and post the saved game here, so you can see for yourself?
I guess I can do that, but as mentioned above, I'm using a MOD I made, which in fact it's a modified version of ultimatescavs-1-17-RC2, in which I added the ability to limit or completely eliminate all Artillery Defense Structures (NO Mortar Pits, Howitzer, Rocket and Missile Emplacements), as well as the Missile and Mass Driver Fortresses. SO I'm guessing I would have to provide that to you as well???
Please reply to clarify all things mentioned above and to let me know how you want me to proceed with the posting of savegame.

Thanks.

P.S.: I'm using MASTER, namely Version MASTER 1ce7e09 Build Nov 17, 2016
What do I think about Window$ ??? Just see my AVATAR...
User avatar
Doruletz
Trained
Trained
 
Posts: 90
Joined: 17 Sep 2015, 06:00
Location: Tennessee, USA

Re: FPS drops bellow 8 and lag in skirmish, huge 160x250 map

Postby Berserk Cyborg » 13 Apr 2017, 04:25

Doruletz wrote:I did not understand what you meant when you said "To verify, open 'top'".
The terminal command top is used to display process information.

Doruletz wrote:Also, I guess that by "shadows drawing" you mean the FSAA setting in Video Options, right?
Go to Options>Graphics Options and make sure shadows are off.

Doruletz wrote:P.S.: I'm using MASTER, namely Version MASTER 1ce7e09 Build Nov 17, 2016
That is before the 3.2.2 release. I recommend cloning the Warzone 2100 git repository and then you can pull in changes as they are made and recompile. Also some performance improvements have been made since then (as well as fixing the scavenger alliance bug you discovered earlier).
User avatar
Berserk Cyborg
Code contributor
Code contributor
 
Posts: 340
Joined: 26 Sep 2016, 19:56

Re: FPS drops bellow 8 and lag in skirmish, huge 160x250 map

Postby Doruletz » 13 Apr 2017, 10:05

Berserk Cyborg wrote:
Doruletz wrote:I did not understand what you meant when you said "To verify, open 'top'".
The terminal command top is used to display process information.

Doruletz wrote:Also, I guess that by "shadows drawing" you mean the FSAA setting in Video Options, right?
Go to Options>Graphics Options and make sure shadows are off.

Doruletz wrote:P.S.: I'm using MASTER, namely Version MASTER 1ce7e09 Build Nov 17, 2016
That is before the 3.2.2 release. I recommend cloning the Warzone 2100 git repository and then you can pull in changes as they are made and recompile. Also some performance improvements have been made since then (as well as fixing the scavenger alliance bug you discovered earlier).


@"Berserk Cyborg":

Thanks for all your help, buddy.

I will definitely look into the last suggestion, with cloning the Warzone 2100 git repository

Maybe you can help me with another issue, see this topic:
http://forums.wz2100.net/viewtopic.php?f=4&t=12831

What I want is Terminal Command that will launch WZ2100 with more than one single CPU Core being used. I will settle for 2 physical cores, wouldn't mind using all 4 cores...
What do I think about Window$ ??? Just see my AVATAR...
User avatar
Doruletz
Trained
Trained
 
Posts: 90
Joined: 17 Sep 2015, 06:00
Location: Tennessee, USA

Re: FPS drops bellow 8 and lag in skirmish, huge 160x250 map

Postby Bedell » 12 Oct 2017, 15:20

Thanks for the tips guys. I did them all and am getting a lot less lag and fps drops!
Bedell
New user
 
Posts: 1
Joined: 06 Oct 2017, 17:40


Return to Technical Help / Troubleshooting

cron