Page 2 of 2

Re: WZ crashes on multiple devices

PostPosted: 26 Aug 2016, 20:45
by Vincent
Actually debug Tools don't help with crash, they often use classic GL introspection functions so that they will provide the same reports as arb debug output. Tools from IHV only give access to the performance counters of their hardware while frame capture is vendor agnostic as far as I know.

On the other hand they're really useful to debug visual glitches as they record framebuffer content after every draw call which allows to detect which call is not correctly working and see all the state parameters (blend, depth text, constants...).

Re: WZ crashes on multiple devices

PostPosted: 29 Aug 2016, 18:48
by Cyp
Is e114b97c…9c261297 a step in the right direction?

Re: WZ crashes on multiple devices

PostPosted: 29 Aug 2016, 20:39
by Cyp
#4414 wrote:friend can not play with this game version unless compile by vs2013 then he have no crashes.
the problem is broken compiler.

Vincent wrote:Can confirm it crashes on Intel igpu. Unfortunatly Intel OpenGL drivers doesn't support fixed functions very well (and mixing fixed function and shaders is even worse) ; however they correctly support core context, they're even able to run the latest Doom game which relies on GL 4.3.


Was that using the standard cross-compiled .exe, or a version you compiled with MSVC?

Re: WZ crashes on multiple devices

PostPosted: 30 Aug 2016, 16:25
by Vincent
using the cross compiled exe

Re: WZ crashes on multiple devices

PostPosted: 30 Aug 2016, 16:43
by Vincent
I tested with msvc 2K15 build, it still crashes (in piedraw.cpp:555)

Re: WZ crashes on multiple devices

PostPosted: 31 Aug 2016, 19:13
by Per
Seems it crashes in the glDrawElements() call inside pie_Draw3DShape2() function.

Can you try the attached patch, and post the last few debug log calls that are output before it crashes?

Re: WZ crashes on multiple devices

PostPosted: 01 Sep 2016, 21:26
by Vincent
Code: Select all
--- Starting log [C:\Users\vljno\Documents\Warzone 2100 master\logs\WZlog-0901_211845.txt]---
info    |09:18:45: [realmain:1140] Using C:\Users\vljno\Documents\Warzone 2100 master\logs\WZlog-0901_211845.txt debug file
error   |09:18:45: [`anonymous-namespace'::initializeGLC:496] Failed to select font family DejaVu Sans as regular font
warning |09:18:45: [`anonymous-namespace'::initializeGLC:505] Failed to select the "Book" font face of font family DejaVu Sans (**Further warnings of this type are suppressed.)
error   |09:18:45: [`anonymous-namespace'::initializeGLC:514] iV_initializeGLC: Failed to select font family DejaVu Sans for the bold font
warning |09:18:45: [`anonymous-namespace'::initializeGLC:523] Failed to select the "Bold" font face of font family ÀqŒ (**Further warnings of this type are suppressed.)
info    |09:18:50: [seq_Play:510] unable to open 'sequences/cam1/c001.ogg' for playback
warning |09:19:14: [buildFeature:216] Feature not aligned. position (5422,4658), size (1,1) (**Further warnings of this type are suppressed.)
warning |09:19:14: [buildFeature:216] Feature not aligned. position (5068,4689), size (1,1) (**Further warnings of this type are suppressed.)
warning |09:19:14: [buildFeature:216] Feature not aligned. position (5323,4676), size (1,1) (**Further warnings of this type are suppressed.)
warning |09:19:14: [buildFeature:216] Feature not aligned. position (1908,1923), size (1,1) (**Further warnings of this type are suppressed.)
warning |09:19:14: [buildFeature:216] Feature not aligned. position (5474,6205), size (1,1) (**Further warnings of this type are suppressed.)
error   |09:19:17: [pie_Draw3DShape2:248] glDrawElements(GL_TRIANGLES, 20 * 3, GL_UNSIGNED_SHORT, BUFFER_OFFSET(0 * 20 * 3 * sizeof(uint16_t)) from features.json with 16 points and 20 polygons
error   |09:19:17: [khr_callback:140] GL::API(Performance:Medium) : API_ID_RECOMPILE_FRAGMENT_SHADER performance warning has been generated. Fragment shader recompiled due to state change.


The glc errors are probably not related to the crashes btw I get them on another computer which run wz fine.

Re: WZ crashes on multiple devices

PostPosted: 03 Sep 2016, 17:41
by Vincent
I narrowed down what cause the errors, in piedraw.cpp at line 211 :
Code: Select all
      glEnable(GL_ALPHA_TEST);
      glAlphaFunc(GL_GREATER, 0.001f);


Commenting the functions makes wz 2100 work (at least the alpha campaign first mission).

Re: WZ crashes on multiple devices

PostPosted: 04 Sep 2016, 00:06
by Vincent
Wz2100 works with latest commit (with MSVC build, didn't test with cross compiled one)

Re: WZ crashes on multiple devices

PostPosted: 09 Sep 2016, 08:28
by nooneisback
Can someone please explain me why this thing didn't work for me 4 weeks ago (Crashed after saying "Power resource"), then when I come back, everything works perfectly fine. No upgrading or anything.

Re: WZ crashes on multiple devices

PostPosted: 09 Sep 2016, 08:35
by Cyp
Don't know. Windows autoupdate? The phase of the moon?

Re: WZ crashes on multiple devices

PostPosted: 09 Sep 2016, 11:29
by nooneisback
Didn't update since I came back, it just started randomly working...

Re: WZ crashes on multiple devices

PostPosted: 20 Mar 2017, 02:24
by William
I got that error Too!
Code: Select all
error   |07:27:08: [khr_callback:140] GL::API(Performance:Medium) : API_ID_RECOMPILE_FRAGMENT_SHADER performance warning has been generated. Fragment shader recompiled due to state change.

I believe this is a problem with the cpu? :stressed: :x :augh:
Too bad i aint getting anymore cpu upgrades :stare: