Game keeps crashing after few seconds after the launch.

Do you need help? Ask here!

Bug reporting belongs here: http://developer.wz2100.net/newticket

Game keeps crashing after few seconds after the launch.

Postby GentleMithos » 29 Apr 2016, 00:34

Warzone 2100 stopped responding after like 10 seconds of the launch
GentleMithos
New user
 
Posts: 1
Joined: 29 Apr 2016, 00:32

Re: Game keeps crashing after few seconds after the launch.

Postby vexed » 29 Apr 2016, 04:25

System specs?
What version of Warzone?
What OS?
/facepalm ...Grinch stole Warzone🙈🙉🙊 contra principia negantem non est disputandum
Super busy, don't expect a timely reply back.
User avatar
vexed
Inactive
Inactive
 
Posts: 2411
Joined: 27 Jul 2010, 02:07

Re: Game keeps crashing after few seconds after the launch.

Postby wayward4now » 12 Jul 2016, 03:48

vexed wrote:System specs?
What version of Warzone?
What OS?

Warzone 3.2.0 build from source crashes immediately not finding a jack audio server, running Debian Sid. Jack has it's place for serious audiophiles but for studio work the jack user should also be running a dedicated box with a RT kernel. For the average Linux user alsa/pulse is more than enough. So, how to get rid of the jack dependency??
User avatar
wayward4now
Rookie
Rookie
 
Posts: 31
Joined: 22 Apr 2007, 09:40

Re: Game keeps crashing after few seconds after the launch.

Postby NoQ » 12 Jul 2016, 05:57

Jack is most likely unrelated. Could you post the crash dump?
User avatar
NoQ
Special
Special
 
Posts: 6092
Joined: 24 Dec 2009, 11:35
Location: /var/zone

Re: Game keeps crashing after few seconds after the launch.

Postby cybersphinx » 12 Jul 2016, 06:35

wayward4now wrote:Warzone 3.2.0 build from source crashes immediately not finding a jack audio server, running Debian Sid. Jack has it's place for serious audiophiles but for studio work the jack user should also be running a dedicated box with a RT kernel. For the average Linux user alsa/pulse is more than enough. So, how to get rid of the jack dependency??

Warzone uses OpenAL, sounds like yours is configured to use jack by default.
We want information... information... information.
cybersphinx
Inactive
Inactive
 
Posts: 1671
Joined: 01 Sep 2006, 19:17

Re: Game keeps crashing after few seconds after the launch.

Postby wayward4now » 29 Jul 2016, 08:28

I have an AMD 6 core tower with 16 gigs of ram and 4 gigs of nVidia vram with two video cards. All versions of warzone run slick as butter until the 3.2 series. The last thing I see on the terminal is a failure to load jack, but I hear the audio via alsa/pulseaudio. I get a black screen when I pick full screen. If I rm config in the dot-warzone directory, it starts just fine in default windowed mode. Older versions run spread across four monitors full screen and it is a hoot to play like that!! I'm not seeing a error log. Thanx, Ric
User avatar
wayward4now
Rookie
Rookie
 
Posts: 31
Joined: 22 Apr 2007, 09:40

Re: Game keeps crashing after few seconds after the launch.

Postby wayward4now » 29 Jul 2016, 10:08

The logs in ~/.warzone2100-3.2/logs contain nothing related to run errors
WZlog-0729_020205.txt
::::::::::::::

--- Starting log [/home/ric/.warzone2100-3.2/logs/WZlog-0729_020205.txt]-

--
info |02:02:05: [realmain:1140] Using /home/ric/.warzone2100-3.2/logs/
WZlog-0729_020205.txt debug file
User avatar
wayward4now
Rookie
Rookie
 
Posts: 31
Joined: 22 Apr 2007, 09:40


Return to Technical Help / Troubleshooting