Installed videos (sequences.wz) not loading onto war zone

Do you need help? Ask here!

Bug reporting belongs here: http://developer.wz2100.net/newticket
Post Reply
Xantum2
New user
Posts: 2
Joined: 03 Jan 2015, 07:57

Installed videos (sequences.wz) not loading onto war zone

Post by Xantum2 » 03 Jan 2015, 18:52

I loaded highest quality and read the instructions on the README.txt. I put the sequences.wz folder IN the main Warzone 2100 folder, but its not working :augh: . I installed it a 2nd time and the bar is lot moving an inch! last time it loaded fully from 5-10 min, Help! :augh:

User avatar
vexed
Inactive
Inactive
Posts: 2538
Joined: 27 Jul 2010, 02:07

Re: Installed videos (sequences.wz) not loading onto war zon

Post by vexed » 04 Jan 2015, 04:50

You do not state what platform you are using...so hard to help.

If you see base.wz & mp.wz then stick that file where these files are, and it should work.
/facepalm ...Grinch stole Warzone🙈🙉🙊 contra principia negantem non est disputandum
Super busy, don't expect a timely reply back.

Leigh759
New user
Posts: 4
Joined: 01 Feb 2015, 13:20

Re: Installed videos (sequences.wz) not loading onto war zon

Post by Leigh759 » 01 Feb 2015, 13:44

Hi there,

Hoping someone can help. I'm on Mac OS 10.10.1 and have just installed Warzone 3.1.2

I also can't get the videos to play.. I have put the .wz file only in the folder path specified for mac (screen shot attached) and even tried to re-install Warzone afterwards, change options within the game etc. I also tried using different versions for the folder, for example "Warzone 2100 3.1.2" without the extra ".2" and even older versions but still no joy :(

When opening the game, I can't see the intro video (it gives me a messages saying I need to download). However, playing the first mission, i get a small amount of video, the one that says "briefing commences", but where a proper video usually follows, it just cuts back to the gameplay.

Can anyone help?
Attachments
Screen Shot 2015-02-01 at 11.36.35.png

User avatar
vexed
Inactive
Inactive
Posts: 2538
Joined: 27 Jul 2010, 02:07

Re: Installed videos (sequences.wz) not loading onto war zon

Post by vexed » 03 Feb 2015, 04:35

Can you open up sequences.wz and tell me what you see ?
(It is a zip file, so you can rename it if you want, but change it back to .wz when done).
/facepalm ...Grinch stole Warzone🙈🙉🙊 contra principia negantem non est disputandum
Super busy, don't expect a timely reply back.

Leigh759
New user
Posts: 4
Joined: 01 Feb 2015, 13:20

Re: Installed videos (sequences.wz) not loading onto war zon

Post by Leigh759 » 03 Feb 2015, 22:32

Hi,

Many thanks for your reply! I've opened up the .wz file and it gives me the files and folders pictured. The "cam" folders also contain lots of other .ogg files..
Attachments
Screen Shot 2015-02-03 at 20.30.10.png

User avatar
vexed
Inactive
Inactive
Posts: 2538
Joined: 27 Jul 2010, 02:07

Re: Installed videos (sequences.wz) not loading onto war zon

Post by vexed » 04 Feb 2015, 04:20

Are you saying there is a sequences directory/folder inside another sequences directory/folder ?

It should be:
"sequences.wz"
Then open that up (with zip or whatever) and you should next see:
"sequences" (folder/directory)
"readme.txt"
"COPYING"
"COPYING.readme"
Then, if you open up the sequences directory, then, you should see all the .ogg files.

May I ask what version of sequences.wz did you download ?

Oh, and also, I don't see a "config" file, or the other directories in your first screen shot, just the lone sequences.wz file.
Do you have a ~/Library/Application Support/Warzone 2100 3.1 directory ? If so, do you see a config file along with other directories in that ? That is where sequences.wz should be.
/facepalm ...Grinch stole Warzone🙈🙉🙊 contra principia negantem non est disputandum
Super busy, don't expect a timely reply back.

Wolftrak
Trained
Trained
Posts: 57
Joined: 20 Apr 2009, 17:47

Re: Installed videos (sequences.wz) not loading onto war zon

Post by Wolftrak » 04 Feb 2015, 05:08

Just a quick note:

~/Library (Library folder in the user folder) is hidden. In order to get to it, open Finder, press the alt key on the keyboard and see under the Go menu. It should be listed there.

Leigh759
New user
Posts: 4
Joined: 01 Feb 2015, 13:20

Re: Installed videos (sequences.wz) not loading onto war zon

Post by Leigh759 » 04 Feb 2015, 23:28

Dear Vexed & Wolftrak

Thanks so much for your responses! Sorry for the confusion, I see what you mean.. I have just deleted all of the unzipped stuff repeated the process again to make sure it wasn't just me..

I started with only the un-extracted "sequences.wz" file and nothing else. I then extracted it, just for the purposes of seeing what's inside it, as per Vexed's suggestion. (I did this using "Archive Utility").
The result is shown on this third screenshot (attached). You can see the exact file path from left to right via the greyed folders.


In case of any confusion, this is exactly what I've done from scratch, also including answers to your other questions:


I installed Warzone 3.1.2 .dmg file, installed it and it runs fine, but without video.

I then downloaded the highest quality video from the website and that gave me the file sequences.wz, which is 964.3 MB in size.

Then I read the FAQ on video, which told me to put the sequences.wz file into the following folder:
"Mac OS X: ~/Library/Application Support/Warzone 2100 <version>/ (~ is /Users/<username>)"
I did that, and it gave me what's on my first screenshot.

I assumed "3.1.2" was correct as it just told me to put the "version" at the end. But nonetheless, I also tried re-naming the folder "3.1" "3.1.2" and older versions like "2.1" etc. just to see if that would work, closing and re-running Warzone each time, but I still didn't get video.

I don't know why is says "(~ is /Users/<username>)", because the Library folder does not exist within "Users", as you can see from the far left of the screenshot.

The specified folder for video did not exist inside Application Support at all when I installed Warzone, I had to create the folder myself.

My Library / Application Support folders are all visible, not hidden.

I definitely have no "config" file anywhere, I had already tried searching for this as I'd seen it mentioned in other posts. I've also double checked the original download .dmg file and also the extracted files within sequences.wz.
I even tried opening up the "package contents" of the Warzone application itself, but there are too many folders to search through and I don't know how to get my mac to run a search for files within an application.

Hope that helps! :)
Attachments
Screen Shot 2015-02-04 at 20.53.19.png

User avatar
vexed
Inactive
Inactive
Posts: 2538
Joined: 27 Jul 2010, 02:07

Re: Installed videos (sequences.wz) not loading onto war zon

Post by vexed » 05 Feb 2015, 04:13

Leigh759 wrote: I don't know why is says "(~ is /Users/<username>)", because the Library folder does not exist within "Users", as you can see from the far left of the screenshot.
It is there, but it is hidden. :ninja:
It looks like OS X has multiple 'Library' folders, and the specific one you want is IN the "/Users/Leigh759/Library/Warzone 2100 3.1" If that was your username on your machine.
Take a look at this pic to get a more clear picture.
You want the Library that is shown by the bottom orange arrow (3rd one down)
Image
That was from http://computers.tutsplus.com/tutorials ... -mac-31972

Once you do as they show, you will then see the Warzone 2100 3.1 folder, and then, you will also see the config file and everything else in that folder. Stick seqneces.wz in that, and you should be good to go.
Verify it by running WZ again, and selecting 'view intro' on the main menu.

That is also the place where you stick in new maps & mods and your log files.
/facepalm ...Grinch stole Warzone🙈🙉🙊 contra principia negantem non est disputandum
Super busy, don't expect a timely reply back.

User avatar
Square
Trained
Trained
Posts: 76
Joined: 06 Jan 2009, 15:45

Re: Installed videos (sequences.wz) not loading onto war zon

Post by Square » 05 Feb 2015, 13:56

hey leigh, have a look at my mod manager, it also installs sequences.wz: viewtopic.php?f=49&p=130961#p130958

Mac OS X has three Library folder:

Code: Select all

* System Library (/System/Library/)
* All User Library (/Library/)
* Single User Library (~/Library/)
The ~ in front of "~/Library/" means, that the folder is located in your home directory: "~" equals "/Users/jondoe/".
If you want to have a look inside that folder (1) go to Finder, (2) Press Shift, Command and G together (
Bildschirmfoto 2015-02-05 um 13.06.34.png
Bildschirmfoto 2015-02-05 um 13.06.34.png (8.07 KiB) Viewed 6093 times
) (3) Enter the Library Path from above:
Bildschirmfoto 2015-02-05 um 13.07.19.png
.

And voilà, this is the Library folder, that should contain all your Warzone Files.

Leigh759
New user
Posts: 4
Joined: 01 Feb 2015, 13:20

Re: Installed videos (sequences.wz) not loading onto war zon

Post by Leigh759 » 05 Feb 2015, 21:58

Awesome!

Many thanks to everyone for all your help! It now works perfectly and all videos working, the in-mission videos are triggering as they should as well.

I found the hidden OSX Library folders on using the info from Vexed and Square (who knew I had three and all in different places!) and I put the sequences.wz in the geniune "Warzone 2100 3.1" folder (which contained all the other files mentioned). (Previously I didn't realise what Wolftrak meant regarding the hidden library folder, doh!!)

So now my Warzone experience is complete! well, apart from the mods etc. but i'll try those later once I've satisfied my need for gaming nostalgia. Thank you so much again! :) :) :)

jack1770
New user
Posts: 1
Joined: 30 Apr 2016, 05:23

Re: Installed videos (sequences.wz) not loading onto war zon

Post by jack1770 » 30 Apr 2016, 05:40

hello

im trying to get the videos up on wz but am not having much luck. i am trying to get it up on a mac book air and have read many replies about mac but i cant find a library on my mac book? i dont seem to have a user or library.

jack1770

Post Reply