Missing executable error

Do you need help? Ask here!

Bug reporting belongs here: http://developer.wz2100.net/newticket
Post Reply
User avatar
WZ2100ModsFAn
Trained
Trained
Posts: 267
Joined: 15 Apr 2018, 17:25
Location: United States.

Missing executable error

Post by WZ2100ModsFAn » 07 Jul 2018, 20:45

the game crashes and mentions something about a missing executable

i'm using linux by the way

the error only happens when i modify nullbot somehow

Code: Select all

../sysdeps/unix/sysv/linux/waitpid.c: No such file or directory.
warning: Source file is more recent than executable.
warning: RTTI symbol not found for class 'std::_Sp_counted_ptr_inplace<std::__future_base::_Task_state<fpathRoute(MOVE_CONTROL*, unsigned int, int, int, int, int, PROPULSION_TYPE, DROID_TYPE, FPATH_MOVETYPE, int, bool, StructureBounds const&)::{lambda()#1}, std::allocator<int>, PATHRESULT ()>, fpathRoute(MOVE_CONTROL*, unsigned int, int, int, int, int, PROPULSION_TYPE, DROID_TYPE, FPATH_MOVETYPE, int, bool, StructureBounds const&)::{lambda()#1}, (__gnu_cxx::_Lock_policy)2>'
warning: RTTI symbol not found for class 'std::_Sp_counted_ptr_inplace<std::__future_base::_Task_state<fpathRoute(MOVE_CONTROL*, unsigned int, int, int, int, int, PROPULSION_TYPE, DROID_TYPE, FPATH_MOVETYPE, int, bool, StructureBounds const&)::{lambda()#1}, std::allocator<int>, PATHRESULT ()>, fpathRoute(MOVE_CONTROL*, unsigned int, int, int, int, int, PROPULSION_TYPE, DROID_TYPE, FPATH_MOVETYPE, int, bool, StructureBounds const&)::{lambda()#1}, (__gnu_cxx::_Lock_policy)2>'
Saved dump file to '/home/wzm/.local/share/warzone2100-master/logs/warzone2100.gdmp-9uMKEg'
If you create a bugreport regarding this crash, please include this file.
Segmentation fault
Apologies if i dont see your post
central time usa

User avatar
Berg
Regular
Regular
Posts: 2018
Joined: 02 Sep 2007, 23:25
Location: Australia

Re: Missing executable error

Post by Berg » 07 Jul 2018, 20:59

WZ2100ModsFAn wrote:the error only happens when i modify nullbot somehow
Then stop modifying nullbot.
This is a repeat topic of others you have tried.
If you change the code and break it its your fault.
Please debug your changes.

User avatar
WZ2100ModsFAn
Trained
Trained
Posts: 267
Joined: 15 Apr 2018, 17:25
Location: United States.

Re: Missing executable error

Post by WZ2100ModsFAn » 07 Jul 2018, 23:08

Berg wrote:
WZ2100ModsFAn wrote:the error only happens when i modify nullbot somehow
Then stop modifying nullbot.
This is a repeat topic of others you have tried.
If you change the code and break it its your fault.
Please debug your changes.
here's the debug log file

this time now i'm using windows
Warzone2100.RPT
The rpt file that goes with the log file
(27.01 KiB) Downloaded 14 times
WZlog-0707_160347.txt
The log file in debug with a crash from 10 players
(504.48 KiB) Downloaded 16 times
this is a fresh build with a mod alone in the autoload folder

okay it wasn't from modifying nullbot that was a problem
the problem was with the stats folder
Apologies if i dont see your post
central time usa

User avatar
Morgana
Trained
Trained
Posts: 67
Joined: 24 Feb 2016, 22:04

Re: Missing executable error

Post by Morgana » 08 Jul 2018, 14:31

make you but one new ai.

name the ai artificial intelligence.
I paint the images :geek:
for 3.1.5 -> 3.2.3 -> master :lecture:

User avatar
WZ2100ModsFAn
Trained
Trained
Posts: 267
Joined: 15 Apr 2018, 17:25
Location: United States.

Re: Missing executable error

Post by WZ2100ModsFAn » 08 Jul 2018, 18:57

Morgana wrote:make you but one new ai.

name the ai artificial intelligence.
nullbot wasn't the problem it was a stats problem

i realized that by renaming the stats folder then the 10 player map worked again
Apologies if i dont see your post
central time usa

Post Reply