Maps 10 players on 2.3.8

Warzone 2.3.x series. (Unsupported!)
If you issue is with 3.1.x, then DON'T post here, instead use technical support

Maps 10 players on 2.3.8

Postby flavitu » 25 Jan 2015, 03:26

I have a problem with version 3.1.1 that is available on new repository of ubuntu 14.04.
I receive a message that say there are a problem with opengl and few momments after game always crashes.

I suspect that my problem is my graphic card very old - ATI 9250 , I dont have intention to buy other graphic card , are expensive and in linux always have very poor support for graphic cards.

So I tyr my own solution , I install previous version on 14.04 - 2.3.8 - that I down on http://www.ubuntuupdates.org/package_metas/list?name=warzone2100

But I like the new option on 3.1.1 - maps with 10 players.

My question is I can edit some part of files to make version 2.3.8 accept maps of 10 players or more?

Thanks!
flavitu
Rookie
Rookie
 
Posts: 17
Joined: 25 Jan 2015, 03:18

Re: Maps 10 players on 2.3.8

Postby vexed » 25 Jan 2015, 04:26

Well, sure, you can edit the code to fix that, however, you will never be able to play a multilayer game that is in sync. That means, each of those 10 players will be doing different things on their screen from what you see on your screen.
If you mean in skirmish, then, I bet you don't have a very powerful CPU to be able to play 10p games anyway.
You can get a graphics card that will play 3.x for as little as $30 (sometimes even for less than $10 w/rebates), and yes, that works on linux as well.
/facepalm ...Grinch stole Warzone🙈🙉🙊 contra principia negantem non est disputandum
Super busy, don't expect a timely reply back.
User avatar
vexed
Inactive
Inactive
 
Posts: 2407
Joined: 27 Jul 2010, 02:07

Re: Maps 10 players on 2.3.8

Postby NoQ » 25 Jan 2015, 08:07

flavitu wrote:I have a problem with version 3.1.1 that is available on new repository of ubuntu 14.04.
I receive a message that say there are a problem with opengl and few momments after game always crashes.

I suspect that my problem is my graphic card very old - ATI 9250 , I dont have intention to buy other graphic card , are expensive and in linux always have very poor support for graphic cards.

I know this GPU, which many years ago was my first GPU to run wz. I'm not sure it is enough to run 3.1 even with good drivers (though trying to run with shaders disabled in the config may be a good idea; also note that 9250, by specification, does support OpenGL 1.4, which is enough to run 3.1 with shaders).

But there's something i'd like to point out: your GPU is already unsupported, it cannot get much worse. Open-source ATI drivers, as far as i remember, were not very efficient on this GPU. If you say that wz doesn't even start, it means that it hasn't got much better since then. And official ATI linux drivers are very quickly dropping support for old hardware. The game used to be running much better under fglrx, but since the support was dropped, you could no longer install the relevant version of fglrx on top of a newer kernel and X.org (not sure if it's possible find drivers for it under some windows8 either lol).

Finally, it's still a good idea to use 2.3.9 rather than 2.3.8. No, it won't give x-player maps support; also note that even if you backport the support for x-player maps, many of these maps already use the new features of the terrain renderer, or new game objects, and therefore will look like crap or even crash.
User avatar
NoQ
Special
Special
 
Posts: 6064
Joined: 24 Dec 2009, 11:35
Location: /var/zone

Re: Maps 10 players on 2.3.8

Postby flavitu » 26 Jan 2015, 01:15

Thanks for reply my problem.
flavitu
Rookie
Rookie
 
Posts: 17
Joined: 25 Jan 2015, 03:18

Re: Maps 10 players on 2.3.8

Postby Iluvalar » 31 Jan 2015, 21:21

vexed wrote:Well, sure, you can edit the code to fix that, however, you will never be able to play a multilayer game that is in sync. That means, each of those 10 players will be doing different things on their screen from what you see on your screen.

But your order are issued right away. No awkward 1 second delay during which your units keeps moving inside the flamers range. And no annoying bullet time or pause button to people who lose packets (intentionally or not). And god knows how much packets are lost during a standard game... And despite what you say... the synch in 2.3.9 was near perfect outside of the screen. The only issue was to make those syncs look good when the players were looking at them. It was not as bad at all as you guys pretend it was. It was fixable, without ZZZ or delay. You guys just took the easy road again and now try to stick to your own lies. I bet you even believe it... Not a single RTS, FPS or MOBA I know have this kind of ZZz and delay...

To answer the question : 2.3.9 is better then 2.3.8, it's easy to compile. No, it can't run a 10 player game without huge modification because colours are in textures files. Make sure you try out my NRS+ mod if you run in 2.3.9 totally worth it.
Heretic 2.3 improver and proud of it.
User avatar
Iluvalar
Regular
Regular
 
Posts: 1782
Joined: 02 Oct 2010, 18:44

Re: Maps 10 players on 2.3.8

Postby vexed » 01 Feb 2015, 05:27

Iluvalar wrote:
vexed wrote:Well, sure, you can edit the code to fix that, however, you will never be able to play a multilayer game that is in sync. That means, each of those 10 players will be doing different things on their screen from what you see on your screen.

But your order are issued right away. No awkward 1 second delay during which your units keeps moving inside the flamers range. And no annoying bullet time or pause button to people who lose packets (intentionally or not). And god knows how much packets are lost during a standard game... And despite what you say... the synch in 2.3.9 was near perfect outside of the screen. The only issue was to make those syncs look good when the players were looking at them. It was not as bad at all as you guys pretend it was. It was fixable, without ZZZ or delay. You guys just took the easy road again and now try to stick to your own lies. I bet you even believe it... Not a single RTS, FPS or MOBA I know have this kind of ZZz and delay...

Sigh. You don't even understand the problem with 2.x.
And, it wasn't a 'easy' road either.
To answer the question : 2.3.9 is better then 2.3.8, it's easy to compile. No, it can't run a 10 player game without huge modification because colours are in textures files. Make sure you try out my NRS+ mod if you run in 2.3.9 totally worth it.

You don't know what you are talking about yet again.

Locking thread, since there is no point in continuing this discussion.
/facepalm ...Grinch stole Warzone🙈🙉🙊 contra principia negantem non est disputandum
Super busy, don't expect a timely reply back.
User avatar
vexed
Inactive
Inactive
 
Posts: 2407
Joined: 27 Jul 2010, 02:07


Return to 2.3.x