Need Help Compiling 3.2b4 on Gentoo Linux. (QT5 not found)

For code related discussions and questions
Post Reply
Sur3
Greenhorn
Posts: 12
Joined: 29 May 2009, 03:46

Need Help Compiling 3.2b4 on Gentoo Linux. (QT5 not found)

Post by Sur3 » 07 Jul 2016, 23:52

Hello,

i tried to test Warzone 3.2 beta4 on my Gentoo Linux, but i cant compile it because during ./configure it doesnt find qt5 but qt5 is installed beside qt4..

Code: Select all

checking for QT5... no
configure: error: Qt 5 not found - required!
What can i do so wz finds my qt5 during compile? qtchooser for example finds it..

Thanks
SNM Magician

Cyp
Evitcani
Evitcani
Posts: 711
Joined: 17 Jan 2010, 23:35

Re: Need Help Compiling 3.2b4 on Gentoo Linux. (QT5 not foun

Post by Cyp » 08 Jul 2016, 08:19

Weird, works for me in Gentoo.

You can try adding something like adding «MOC5=/usr/lib/qt5/bin/moc UIC5=/usr/lib/qt5/bin/uic RCC5=/usr/lib/qt5/bin/rcc» to the ./configure command line, which I needed in a previous version (fixed in 9411baa09c7e74a272e62a0a343d763a181848b0).

Which paths do you have? What does «pkg-config --variable=exec_prefix Qt5Core» and «pkg-config --variable=host_bins Qt5Core» say?

Sur3
Greenhorn
Posts: 12
Joined: 29 May 2009, 03:46

Re: Need Help Compiling 3.2b4 on Gentoo Linux. (QT5 not foun

Post by Sur3 » 08 Jul 2016, 14:04

Cyp wrote:Which paths do you have? What does «pkg-config --variable=exec_prefix Qt5Core» and «pkg-config --variable=host_bins Qt5Core» say?

Code: Select all

pkg-config --variable=exec_prefix Qt5Core
/usr

Code: Select all

pkg-config --variable=host_bins Qt5Core
/usr/lib64/qt5/bin
Cyp wrote:You can try adding something like adding «MOC5=/usr/lib/qt5/bin/moc UIC5=/usr/lib/qt5/bin/uic RCC5=/usr/lib/qt5/bin/rcc» to the ./configure command line
Didnt help, I dont have uic though what ebuild does it belong to? (If you have gentoolkit: »equery b /usr/lib/qt5/bin/uic«)
Edit: Ok seemes uic is part of qtwidgets i'll install that and try if configure works then..

Sur3
Greenhorn
Posts: 12
Joined: 29 May 2009, 03:46

Re: Need Help Compiling 3.2b4 on Gentoo Linux. (QT5 not foun

Post by Sur3 » 08 Jul 2016, 16:34

Ok emerging qtwidgets didnt help, but probably i'm missing an other qt5 package, can you give me your »equery l qt\*«, so i can check if i am missing something?

User avatar
Terminator
Regular
Regular
Posts: 1063
Joined: 05 Aug 2006, 13:46
Location: Ukraine
Contact:

Re: Need Help Compiling 3.2b4 on Gentoo Linux. (QT5 not foun

Post by Terminator » 08 Jul 2016, 16:52

qt5_scripts ? and make sure your default QT is set to qt5
Death is the only way out... sh*t Happens !

Russian-speaking Social network Group http://vk.com/warzone2100

User avatar
Berg
Regular
Regular
Posts: 2025
Joined: 02 Sep 2007, 23:25
Location: Australia

Re: Need Help Compiling 3.2b4 on Gentoo Linux. (QT5 not foun

Post by Berg » 08 Jul 2016, 19:20


Cyp
Evitcani
Evitcani
Posts: 711
Joined: 17 Jan 2010, 23:35

Re: Need Help Compiling 3.2b4 on Gentoo Linux. (QT5 not foun

Post by Cyp » 08 Jul 2016, 20:30

I have the same output from pkg-config.
Sur3 wrote:Ok emerging qtwidgets didnt help, but probably i'm missing an other qt5 package, can you give me your »equery l qt\*«, so i can check if i am missing something?

Code: Select all

[IP-] [  ] dev-qt/qt3support-4.8.6-r1:4
[IP-] [  ] dev-qt/qtchooser-0_p20151008:0
[IP-] [  ] dev-qt/qtconcurrent-5.5.1:5
[IP-] [  ] dev-qt/qtcore-4.8.6-r2:4
[IP-] [  ] dev-qt/qtcore-5.5.1-r1:5
[IP-] [  ] dev-qt/qtdbus-4.8.6-r1:4
[IP-] [  ] dev-qt/qtdbus-5.5.1:5
[IP-] [  ] dev-qt/qtdeclarative-4.8.6-r1:4
[IP-] [  ] dev-qt/qtdeclarative-5.5.1-r1:5
[IP-] [  ] dev-qt/qtgui-4.8.6-r4:4
[IP-] [  ] dev-qt/qtgui-5.5.1-r1:5
[IP-] [  ] dev-qt/qthelp-4.8.6-r3:4
[IP-] [  ] dev-qt/qthelp-5.5.1-r1:5
[IP-] [  ] dev-qt/qtlockedfile-2.4.1_p20150629:0
[IP-] [  ] dev-qt/qtmultimedia-4.8.6-r1:4
[IP-] [  ] dev-qt/qtmultimedia-5.5.1-r2:5
[IP-] [  ] dev-qt/qtnetwork-5.5.1:5
[IP-] [  ] dev-qt/qtopengl-4.8.6-r1:4
[IP-] [  ] dev-qt/qtopengl-5.5.1:5
[IP-] [  ] dev-qt/qtprintsupport-5.5.1:5
[IP-] [  ] dev-qt/qtquick1-5.5.1-r1:5
[IP-] [  ] dev-qt/qtscript-4.8.6-r2:4
[IP-] [  ] dev-qt/qtscript-5.5.1-r1:5
[IP-] [  ] dev-qt/qtsingleapplication-2.6.1_p20150629:0
[IP-] [  ] dev-qt/qtsql-4.8.6-r1:4
[IP-] [  ] dev-qt/qtsql-5.5.1:5
[IP-] [  ] dev-qt/qtsvg-4.8.6-r1:4
[IP-] [  ] dev-qt/qtsvg-5.5.1-r1:5
[IP-] [  ] dev-qt/qttest-4.8.6-r1:4
[IP-] [  ] dev-qt/qttest-5.5.1:5
[IP-] [  ] dev-qt/qttranslations-4.8.6-r1:4
[IP-] [  ] dev-qt/qtwebkit-4.8.6-r1:4
[IP-] [  ] dev-qt/qtwebkit-5.5.1-r1:5
[IP-] [  ] dev-qt/qtwidgets-5.5.1-r1:5
[IP-] [  ] dev-qt/qtx11extras-5.5.1:5
[IP-] [  ] dev-qt/qtxml-5.5.1:5
[IP-] [  ] dev-qt/qtxmlpatterns-4.8.6-r1:4
[IP-] [  ] dev-qt/qtxmlpatterns-5.5.1-r1:5
[I--] [??] media-libs/qt-gstreamer-1.2.0-r1:0
[I--] [??] net-misc/qtnx-0.9:0
[IP-] [  ] x11-themes/qtcurve-1.8.18-r1:0

Does config.log say anything useful-looking?

Sur3
Greenhorn
Posts: 12
Joined: 29 May 2009, 03:46

Re: Need Help Compiling 3.2b4 on Gentoo Linux. (QT5 not foun

Post by Sur3 » 09 Jul 2016, 00:53

Cyp wrote:Does config.log say anything useful-looking?
Lol yes, thanks why didn't I come up with this myself.. :lol2:

Code: Select all

Package Qt5Script was not found in the pkg-config search path.
Now it compiles..
Thanks for all these helpful comments so far! :)

And by the way should i use sdl or qt backend whats the difference there?

Cyp
Evitcani
Evitcani
Posts: 711
Joined: 17 Jan 2010, 23:35

Re: Need Help Compiling 3.2b4 on Gentoo Linux. (QT5 not foun

Post by Cyp » 09 Jul 2016, 10:23

/me uses the Qt backend, think everyone else uses the SDL backend. Not sure if there's much difference, the SDL backend used to not support coloured cursors, but does now.

Post Reply