compile ??? Vexed ??? 0xc000007b

For code related discussions and questions
Post Reply
wz2101
Greenhorn
Posts: 13
Joined: 15 Jul 2014, 00:54

compile ??? Vexed ??? 0xc000007b

Post by wz2101 » 15 Jul 2014, 04:24

Hi all and vexed
I'm posting because I'm getting sick of this Project-setting-bs, lib updating and downloading and of that linker errors. I came to code and not for this.

I managed to compile the latest wz version. I used libpng15.dll instead of libpng16.dll and another theora_lib because the one i had didnt work (I don't want to spend so much time in searching for this silly, stubid, useless, .. lib, what exact version I dont even know). I also deleted this autorevision.bat script because it was getting annoying, same as the generation script for the moc files (qt). (Reason: Problems with pathes)
I did this on my own(Creating moc files with moc.exe and running autorevision..), so there came no linker errors up. Now the problem is.. I get a lot of warnings (about using constant types, unsigned instead of signed types, etc..) and after starting my compiled version I get the 0xc000007b error (Release) and and an similar error when compiling in debug modus. The filesize in DBG modus is about 6,7 Mb(Release: 3,5), what isn't nearly the same as the official release one. (Mine hasn't any libs included.. probably). Not to forget: I am using Qt 4.8.5 and VS 2010 sp1 packages etc installed, not like you(you probably use the newest). I have no clue about the best settings for WZ2100 and the Guide doesn't give any information that could be usefull for me, because either it's outdated or it's simply not enough.

I'm really wondering why there isn't any sensible tutorial for compiling WZ2100. Also why you dont just give to each new version your DevPackage?
I can't search for all those libs and I don't know what to download or what to compile.
So please vexed, revenues me of this horror, I just don't know the right settings for the projects and I want a one click DevPackage for the newest version. THANKS
hehe

User avatar
vexed
Inactive
Inactive
Posts: 2461
Joined: 27 Jul 2010, 02:07

Re: compile ??? Vexed ??? 0xc000007b

Post by vexed » 15 Jul 2014, 05:11

For compiling stuff, it is all the same on every platform, no matter what compiler environment you are using, be it linux, mac, or windows.
You get the required libs & headers (listed in the wiki), compile them for your platform of choce, then you compile warzone.
For linux, you got autotools to generate the makefile to make warzone.
For windows, you got the solution file to compile warzone.
For macs, you got Xcode project files to compile warzone.

For your specific issue, no idea, you don't give enough information to go on, but, sounds like you didn't compile something correctly, or, you don't have the correct dll's or missing files... an error message would help I would think.

As for not making windows packages available, the main reason is, time, and the windows builds (made by VS) are NOT 100% compatible with the cross-compiler version.
/facepalm ...Grinch stole Warzone๐Ÿ™ˆ๐Ÿ™‰๐Ÿ™Š contra principia negantem non est disputandum
Super busy, don't expect a timely reply back.

Per
Warzone 2100 Team Member
Warzone 2100 Team Member
Posts: 3750
Joined: 03 Aug 2006, 19:39

Re: compile ??? Vexed ??? 0xc000007b

Post by Per » 15 Jul 2014, 11:06

Try doing development on Linux instead. It is so much easier...

wz2101
Greenhorn
Posts: 13
Joined: 15 Jul 2014, 00:54

Re: compile ??? Vexed ??? 0xc000007b

Post by wz2101 » 15 Jul 2014, 21:11

When compiling i get this warning:
Project file contains ToolsVersion="12.0". This toolset may be unknown or missing, in which case you may be able to resolve this by installing the appropriate version of MSBuild, or the build may have been forced to a particular ToolsVersion for policy reasons. Treating the project as if it had ToolsVersion="4.0". For more information, please see http://go.microsoft.com/fwlink/?LinkId=291333.

Althought i have changed the "ToolsVersion" in all project files. I even have changed the v120 to v100, but it still appears.
Edit: Forget the lil Sound project and fixed this warning after changing the project toolversion. This error didn't cause my problem, I'm still having this side by side problem (debug).

Dlls? It seems like there is no relevant dll missing, but a wrong is being used:
Image


I'm using vc100 toolset and vs 10 so it shouldn't be msvcrt90.dll.
Is this the problem? How to change this dll?

Edit: I'm sure this causes the side by side error and all the others..

User avatar
vexed
Inactive
Inactive
Posts: 2461
Joined: 27 Jul 2010, 02:07

Re: compile ??? Vexed ??? 0xc000007b

Post by vexed » 16 Jul 2014, 04:51

What version of WZ are you trying to build anyway ?
If you are using git, then revert the changes made for VS2013, and that will fix the solution file for your version of VS.

That still looks like a lib conflict, not sure which one.
/facepalm ...Grinch stole Warzone๐Ÿ™ˆ๐Ÿ™‰๐Ÿ™Š contra principia negantem non est disputandum
Super busy, don't expect a timely reply back.

wz2101
Greenhorn
Posts: 13
Joined: 15 Jul 2014, 00:54

Re: compile ??? Vexed ??? 0xc000007b

Post by wz2101 » 16 Jul 2014, 06:07

I tried the master version.

when did you made the changes? I have git, maybe I'll look later.
I downloaded the 3.1.1 version (not vs 2013) and it worked after putting several dlls into the data folder. Now wz is running correctly.
So this means it was because of some missing .dlls, as you said.

Post Reply