Unable to compile 3.1.1

For code related discussions and questions
Post Reply
pititis
New user
Posts: 4
Joined: 17 Jan 2013, 00:51

Unable to compile 3.1.1

Post by pititis » 04 Jan 2014, 17:15

hello,

I need your light!. I'm getting this error trying to compile the 3.1.1 (on ubuntu). Compliling 3.1.0 is working without any issue.

Code: Select all

netplay.cpp: In function ‘int upnp_init(void*)’:
netplay.cpp:968:98: error: ‘struct UPNPDev’ has no member named ‘scope_id’
netplay.cpp:974:51: error: ‘struct UPNPDev’ has no member named ‘scope_id’
make[2]: *** [netplay.o] Error 1
Any idea please?

User avatar
vexed
Inactive
Inactive
Posts: 2471
Joined: 27 Jul 2010, 02:07

Re: Unable to compile 3.1.1

Post by vexed » 05 Jan 2014, 05:38

Update miniUPnP lib... you are using a old version.

https://github.com/Warzone2100/warzone2 ... 12ae862d39
/facepalm ...Grinch stole Warzone🙈🙉🙊 contra principia negantem non est disputandum
Super busy, don't expect a timely reply back.

pititis
New user
Posts: 4
Joined: 17 Jan 2013, 00:51

Re: Unable to compile 3.1.1

Post by pititis » 05 Jan 2014, 16:07

What do you mean with old version? I downloaded the 3.1.1 from sourceforge. It's the latest stable right?

User avatar
Berg
Regular
Regular
Posts: 2036
Joined: 02 Sep 2007, 23:25
Location: Australia

Re: Unable to compile 3.1.1

Post by Berg » 06 Jan 2014, 01:53

vexed wrote:Update miniUPnP lib... you are using a old version.
he meant you operating system was running an older version of miniUpnP

goto you software centre and put miniUpnP in the search box

install libminiupnpc-dev and libminiupnpc8

pititis
New user
Posts: 4
Joined: 17 Jan 2013, 00:51

Re: Unable to compile 3.1.1

Post by pititis » 11 Jan 2014, 03:39

Thank you, but there aren't updates on debian or ubuntu repos for libminiupnpc and libminiupnpc-dev (still 1.6), so building a package for ubuntu/debian with the 3.1.1 is now a little bit complicated. I will try to build the package libminiupnpc with the new version to satisface the dependencies.

My ppa with the 3.1 has been used about 300 times, so I will try again. Game isn't over yet :twisted:

Cheers

User avatar
vexed
Inactive
Inactive
Posts: 2471
Joined: 27 Jul 2010, 02:07

Re: Unable to compile 3.1.1

Post by vexed » 11 Jan 2014, 04:06

It is in the tarball & repo, under 3rdParty/miniupnpc

Also, http://www.playdeb.net/software/Warzone2100 has made 3.1.1 builds as well.
/facepalm ...Grinch stole Warzone🙈🙉🙊 contra principia negantem non est disputandum
Super busy, don't expect a timely reply back.

Post Reply