"body" should be "bodyPoints"?
https://github.com/Warzone2100/warzone2 ... ulsion.ini
"hitpoints" should be "bodyPoints"?
Merge propulsionsounds.ini to propulsions.ini?
may be we can merge propulsiontype.ini to propulsions.ini
+ simple strucure
+ easy to adjust each propulsions settings
- can`t change all type at once
https://github.com/Warzone2100/warzone2 ... s.ini#L247
"LightWorld" should be "lightWorld" or "highlightArea"
"body" should be "bodyPoints"
https://github.com/Warzone2100/warzone2 ... ucture.ini
some fields missed in header comments:
powerPoints, productionPoint, rearmPoints, repairPoints, researchPoints
baseWidth, baseBreadth => width, breadth (as in features.ini)
different name styles in structures and templates:
Code: Select all
"name": "sensorID", "name": "compSensor",
May be we can simplify structures.ini:
We have some field that depends from type:
productionPoints, rearmPoints, repairPoints
I suggest to replace them all with one field power.
If type == REPAIR FACILITY then power means repairPoints
If type == GENERATOR then power means poewrPoints
Looks like I finished researching stats.
current docs example.: https://googledrive.com/host/0B12sy1FQt ... hWUFQzSzA/