I Tried Reinstalling Warzone 2100 But!

Other talk that doesn't fit elsewhere.
This is for General Discussion, not General chat.
Post Reply
William
Trained
Trained
Posts: 165
Joined: 02 Sep 2015, 22:39

I Tried Reinstalling Warzone 2100 But!

Post by William » 27 Nov 2016, 05:35

I Get this Error

Code: Select all

$ sudo apt install warzone2100
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 aptitude:i386 : Depends: libapt-pkg4.12:i386 (>= 0.8.16~exp12ubuntu6) but it is not installable
                 Depends: libboost-iostreams1.46.1:i386 (>= 1.46.1-1) but it is not installable
                 Depends: libcwidget3:i386 but it is not installable
                 Depends: libept1.4.12:i386 but it is not installable
                 Depends: libncursesw5:i386 (>= 5.6+20070908) but it is not going to be installed
                 Depends: libsigc++-2.0-0c2a:i386 (>= 2.0.2) but it is not installable
                 Depends: libxapian22:i386 but it is not installable
                 Recommends: apt-xapian-index:i386 but it is not installable
                 Recommends: libparse-debianchangelog-perl:i386 but it is not installable
 ppa-purge : Depends: aptitude
 warzone2100 : Depends: warzone2100-data (<= 3.2.1-1~getdeb1) but it is not going to be installed
               Depends: warzone2100-data (>= 3.2.1) but it is not going to be installed
               Depends: libglc0 (>= 0.7.1) but it is not going to be installed
               Depends: libphysfs1 but it is not going to be installed
               Depends: libpng12-0 (>= 1.2.13-4) but it is not installable
               Depends: libsdl2-2.0-0 (>= 2.0.4) but it is not going to be installed
               Recommends: warzone2100-music (<= 3.2.1-1~getdeb1) but it is not going to be installed
               Recommends: warzone2100-music (>= 3.2.1) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

William
Trained
Trained
Posts: 165
Joined: 02 Sep 2015, 22:39

Re: I Tried Reinstalling Warzone 2100 But!

Post by William » 27 Nov 2016, 05:38

¡Quiero instalar warzone 2100! Sigue repitiendo !!!!

cybersphinx
Inactive
Inactive
Posts: 1691
Joined: 01 Sep 2006, 19:17

Re: I Tried Reinstalling Warzone 2100 But!

Post by cybersphinx » 27 Nov 2016, 07:38

"You might want to run 'apt-get -f install' to correct these [...] unmet dependencies"
We want information... information... information.

William
Trained
Trained
Posts: 165
Joined: 02 Sep 2015, 22:39

Re: I Tried Reinstalling Warzone 2100 But!

Post by William » 27 Nov 2016, 20:43

Tried that too and then this

Code: Select all

$ apt-get -f install warzone2100
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

William
Trained
Trained
Posts: 165
Joined: 02 Sep 2015, 22:39

Re: I Tried Reinstalling Warzone 2100 But!

Post by William » 27 Nov 2016, 20:46

I have even been doing sudo

Code: Select all

$ sudo apt-get -f install warzone2100
[sudo] password for william: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 aptitude:i386 : Depends: libapt-pkg4.12:i386 (>= 0.8.16~exp12ubuntu6) but it is not installable
                 Depends: libboost-iostreams1.46.1:i386 (>= 1.46.1-1) but it is not installable
                 Depends: libcwidget3:i386 but it is not installable
                 Depends: libept1.4.12:i386 but it is not installable
                 Depends: libncursesw5:i386 (>= 5.6+20070908) but it is not going to be installed
                 Depends: libsigc++-2.0-0c2a:i386 (>= 2.0.2) but it is not installable
                 Depends: libxapian22:i386 but it is not installable
                 Recommends: apt-xapian-index:i386 but it is not installable
                 Recommends: libparse-debianchangelog-perl:i386 but it is not installable
 ppa-purge : Depends: aptitude
 warzone2100 : Depends: warzone2100-data (<= 3.2.1-1~getdeb1) but it is not going to be installed
               Depends: warzone2100-data (>= 3.2.1) but it is not going to be installed
               Depends: libglc0 (>= 0.7.1) but it is not going to be installed
               Depends: libphysfs1 but it is not going to be installed
               Depends: libpng12-0 (>= 1.2.13-4) but it is not installable
               Depends: libsdl2-2.0-0 (>= 2.0.4) but it is not going to be installed
               Recommends: warzone2100-music (<= 3.2.1-1~getdeb1) but it is not going to be installed
               Recommends: warzone2100-music (>= 3.2.1) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

William
Trained
Trained
Posts: 165
Joined: 02 Sep 2015, 22:39

Re: I Tried Reinstalling Warzone 2100 But!

Post by William » 27 Nov 2016, 21:13

I even install the .deb package ran it in window but then

Code: Select all

$ warzone2100 --window
warzone2100: error while loading shared libraries: libphysfs.so.1: cannot open shared object file: No such file or directory

William
Trained
Trained
Posts: 165
Joined: 02 Sep 2015, 22:39

Re: I Tried Reinstalling Warzone 2100 But!

Post by William » 27 Nov 2016, 21:17

see Ive been trying every solution
William wrote:I Get this Error

Code: Select all

$ sudo apt install warzone2100
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 aptitude:i386 : Depends: libapt-pkg4.12:i386 (>= 0.8.16~exp12ubuntu6) but it is not installable
                 Depends: libboost-iostreams1.46.1:i386 (>= 1.46.1-1) but it is not installable
                 Depends: libcwidget3:i386 but it is not installable
                 Depends: libept1.4.12:i386 but it is not installable
                 Depends: libncursesw5:i386 (>= 5.6+20070908) but it is not going to be installed
                 Depends: libsigc++-2.0-0c2a:i386 (>= 2.0.2) but it is not installable
                 Depends: libxapian22:i386 but it is not installable
                 Recommends: apt-xapian-index:i386 but it is not installable
                 Recommends: libparse-debianchangelog-perl:i386 but it is not installable
 ppa-purge : Depends: aptitude
 warzone2100 : Depends: warzone2100-data (<= 3.2.1-1~getdeb1) but it is not going to be installed
               Depends: warzone2100-data (>= 3.2.1) but it is not going to be installed
               Depends: libglc0 (>= 0.7.1) but it is not going to be installed
               Depends: libphysfs1 but it is not going to be installed
               Depends: libpng12-0 (>= 1.2.13-4) but it is not installable
               Depends: libsdl2-2.0-0 (>= 2.0.4) but it is not going to be installed
               Recommends: warzone2100-music (<= 3.2.1-1~getdeb1) but it is not going to be installed
               Recommends: warzone2100-music (>= 3.2.1) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
William wrote:Tried that too and then this

Code: Select all

$ apt-get -f install warzone2100
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
William wrote:I have even been doing sudo

Code: Select all

$ sudo apt-get -f install warzone2100
[sudo] password for william: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 aptitude:i386 : Depends: libapt-pkg4.12:i386 (>= 0.8.16~exp12ubuntu6) but it is not installable
                 Depends: libboost-iostreams1.46.1:i386 (>= 1.46.1-1) but it is not installable
                 Depends: libcwidget3:i386 but it is not installable
                 Depends: libept1.4.12:i386 but it is not installable
                 Depends: libncursesw5:i386 (>= 5.6+20070908) but it is not going to be installed
                 Depends: libsigc++-2.0-0c2a:i386 (>= 2.0.2) but it is not installable
                 Depends: libxapian22:i386 but it is not installable
                 Recommends: apt-xapian-index:i386 but it is not installable
                 Recommends: libparse-debianchangelog-perl:i386 but it is not installable
 ppa-purge : Depends: aptitude
 warzone2100 : Depends: warzone2100-data (<= 3.2.1-1~getdeb1) but it is not going to be installed
               Depends: warzone2100-data (>= 3.2.1) but it is not going to be installed
               Depends: libglc0 (>= 0.7.1) but it is not going to be installed
               Depends: libphysfs1 but it is not going to be installed
               Depends: libpng12-0 (>= 1.2.13-4) but it is not installable
               Depends: libsdl2-2.0-0 (>= 2.0.4) but it is not going to be installed
               Recommends: warzone2100-music (<= 3.2.1-1~getdeb1) but it is not going to be installed
               Recommends: warzone2100-music (>= 3.2.1) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
William wrote:I even install the .deb package ran it in window but then

Code: Select all

$ warzone2100 --window
warzone2100: error while loading shared libraries: libphysfs.so.1: cannot open shared object file: No such file or directory

User avatar
Darkling
Rookie
Rookie
Posts: 19
Joined: 07 Feb 2016, 00:45

Re: I Tried Reinstalling Warzone 2100 But!

Post by Darkling » 28 Nov 2016, 01:23

So I recently upgraded my Ubuntu installation to 16.04 which meant that I had to reinstall everything (not unexpectedly). I did not try to install warzone from the software center since that is the older version 3.1.1 or so and teh current version is 3.2.1 (or you could try the master version, I guess). I tried installing through the playdeb link that is offered, but this did not work for me either(I think it was the physf or somesuch). So to install version 3.2.1 I needed to compile it on my own system. I first downloaded the warzone2100-3.2.1.tar.xz file from sourceforge although you can also get it from github (https://github.com/Warzone2100/warzone2100/releases).
I then extracted the contents of this folder into my home directory (it created a new folder in there called warzone2100-3.2.1.

I opened terminal (cntr-alt-t is the shortcut) and navigated to that directory using teh command

Code: Select all

cd warzone2100-3.2.1
The next command to run is

Code: Select all

./configure
this instruction tells it to check that you have all the dependencies need so that it can compile. I didn't and you probably won't either. As it runs, it'll get to the first point where you're missing stuff and then stop and tell you what you're missing, but after each pass through with ./confugure I'd end up entering somethiong like

Code: Select all

sudo apt-get install qtscript5-dev
to install the particular package that was needed (I was missing about half a dozen or so) and google was quite handy to identify the missing ones where the names didn't quite line up with what was needed.

Once I got to the point where ./configure ran through without encountering any errors the next step was to type

Code: Select all

make 
into the terminal. That process will take some time (although I had other stuff running in the background...). Once make is done, then you need to type

Code: Select all

sudo make install
into the terminal and warzone shuld start up. It'll create the launcher shortcut for it and you'll be able to play by typing warzone2100 into terminal after that as well.

User avatar
NoQ
Special
Special
Posts: 6225
Joined: 24 Dec 2009, 11:35
Location: /var/zone

Re: I Tried Reinstalling Warzone 2100 But!

Post by NoQ » 02 Dec 2016, 17:42

William wrote:Tried that too and then this

Code: Select all

$ apt-get -f install warzone2100
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
Your package manager is screwed, this has nothing to do with warzone.
Try making sure no dpkg processes are running (eg. reboot), remove the lock, try again.

William
Trained
Trained
Posts: 165
Joined: 02 Sep 2015, 22:39

Re: I Tried Reinstalling Warzone 2100 But!

Post by William » 15 Dec 2016, 03:17

how do i make sure no dpkg processes are running?

User avatar
Berg
Regular
Regular
Posts: 2202
Joined: 02 Sep 2007, 23:25
Location: Australia

Re: I Tried Reinstalling Warzone 2100 But!

Post by Berg » 15 Dec 2016, 03:56

sudo apt-get -f install warzone2100
You need permission to install new software the sudo command will ask for password for your user.
and that should work,
PS: Do not have any other software programs running.

Post Reply