Need help compiling Warzone v2.2.4....

Warzone 2.2.x series. (Unsupported--read only !)

Need help compiling Warzone v2.2.4....

Postby Dart00 » 24 Oct 2009, 06:07

Well today is day 4 of my Warzone 2100 adventure! I found the game in the repositorys and really liked it....It was version 2.1 something...problem was after the title screen before game play the sound stopped :(...and when I quit the game I got a full screen splash screen of something with a pumkin in it....I have to kill X to get my desktop back for a Virtual Terminal. Is this suposed to happen? Also few min into game play the game goes in to Window mode and I have to remaximize it. I think the sound bug must be a big with the older version...the newest version 2.2.4.

My specs:
- Easypeasy Ubuntu 9.04 Fully patched
- Kernel: 2.6.30.5-ep0
- Asus EEE 1000h
- 2GB RAM

Thats all I can think of the the top of my head. Problem is the newest version is not in the respositorys and they dont offer a .deb package. So my only option is to compile from source. Iv only been runny Ubuntu for bout 2 weeks testing it on as a primary OS, iv played with linux a lil but am not very advanced. Iv had to learn a lot to get this far lol.

So ya...I start to compile it useing the ./configure script and I get a error when it cheks for SDL Package...ok...so I go download the SDL package. :) Try again...New error....load another package. Well 4 days later I was able to fix all the ./configure errors up to the point of:

Code: Select all
checking SDL/SDL_opengl.h usability... no
checking SDL/SDL_opengl.h presence... no
checking for SDL/SDL_opengl.h... no
configure: error: SDL OpenGL header not found. Please install SDL with OpenGL support.


Then the script stops. I cant find OpenGL anywhere. Here is the list of packages I have had to install to get this far: (besides the linux headers)

Code: Select all
cmake
libogg-1.1.4
libpng-1.2.40
libtheora-1.1.1
libvorbis-1.2.3
openal-soft-1.8.466
physfs-2.0.0
popt-1.7
SDL-1.2.13
SDL_net-1.2.7
zlib-1.2.3


And then I get stuck with the above error. I really want to play this game, but its not playable due to the splash screen, Window problem and sound problem. Its just getting really discrouaging. Can anyone give me a hand please?
Dart00
New user
 
Posts: 2
Joined: 24 Oct 2009, 05:35

Re: Need help compiling Warzone v2.2.4....

Postby -Kosh- » 24 Oct 2009, 08:15

You have to get the -dev files for all the libs.
libsdl1.2-dev or whatever it is
This is a waste of space. Something important should be here.
-Kosh-
Trained
Trained
 
Posts: 203
Joined: 16 Sep 2009, 23:34

Re: Need help compiling Warzone v2.2.4....

Postby ODDity » 27 Oct 2009, 20:33

sudo apt-get build-dep warzone2100 (to install the development packages)

That should be that. Although if you can not run other openGL applications, it may be you need the correct drivers for your video card?

good luck.

ODDity
User avatar
ODDity
Trained
Trained
 
Posts: 73
Joined: 23 Oct 2009, 04:56


Return to 2.2.x

cron