2 gfx glitches on EeePC

Warzone 2.2.x series. (Unsupported--read only !)

2 gfx glitches on EeePC

Postby Powzone » 18 Sep 2009, 19:44

Yesterday I reinstalled my PC and the only game that made it in there was WZ 2.2.3. I noticed 2 possible bugs on my EeePC in comparison.

1. The player numbers aren't shown in the lobby:
map.png
EeePC map without player numbers.


2. The "north arrow" isn't shown besides the radar:
wz2100_shot_063.png
EeePC radar without arrow indicating north.


No big problem for me, as I can say, I'm still very used to 1.10 and this has been added later. Never noticed it before. I hope this is not a driver problem with the Intel chips, as mine are updated frequently. And as there are more EeePC people in here, they might notice the same problem or at least know about it now. :)

System specs down here in the signature... ;)
PC: Manjaro 17 XFCE / Intel Core i7 6700 / 32GB RAM / NVidia GTX1050Ti
NB: Manjaro 17 XFCE / Atom 1,6GHz / 2GB RAM / Intel 945 Express
User avatar
Powzone
Trained
Trained
 
Posts: 332
Joined: 17 Feb 2008, 17:25
Location: Germany

Re: 2 gfx glitches on EeePC

Postby i-NoD » 06 Oct 2009, 20:05

Powzone wrote:1. The player numbers aren't shown in the lobby:

I do remember from somewhere on the forum that such a glitch is caused by a poor intel's GFX card and their OpenGL drivers.

Powzone wrote:2. The "north arrow" isn't shown besides the radar:

Use rotateRadar=1 in wz config file. There is no arrow for static radar.
i-NoD
Code contributor
Code contributor
 
Posts: 306
Joined: 30 Nov 2008, 00:42
Location: In the middle of nowhere

Re: 2 gfx glitches on EeePC

Postby Powzone » 06 Oct 2009, 23:51

Ok! I got the arrow! I was just wondering having it on my PC and not on the laptop. :)

I'll have to be updating the drivers frequently then, to see if the numbers get fixed by Intel someday...

THX!
PC: Manjaro 17 XFCE / Intel Core i7 6700 / 32GB RAM / NVidia GTX1050Ti
NB: Manjaro 17 XFCE / Atom 1,6GHz / 2GB RAM / Intel 945 Express
User avatar
Powzone
Trained
Trained
 
Posts: 332
Joined: 17 Feb 2008, 17:25
Location: Germany

Re: 2 gfx glitches on EeePC

Postby Buginator » 10 Oct 2009, 03:59

Issue #1 is from the lack of a FBO (Frame Buffer Object) support.

About all you can do is keep trying different drivers, and hopefully, they will add the missing call.
and it ends here.
User avatar
Buginator
Professional
Professional
 
Posts: 3285
Joined: 04 Nov 2007, 02:20


Return to 2.2.x

cron