Two new problems.

Warzone 1.x series. (Aka retail version) (Unsupported!)

Two new problems.

Postby E-102 Gamma » 25 Feb 2011, 21:13

Well, I know for sure that I won't get widescreen in the 1.x versions of Warzone 2100, thanks to my previous thread.

The next best thing, now, is to run it in a 1280x1024 window. Would this be possible?

I found a "-window" launch option in WZ's executable, but when I add it to a shortcut and launch the shortcut, it gives me this error:

Image

...And then launches WZ in fullscreen. What, does the launch option only work if I'm running in 16 bbp? O_o

The reason I'm so desperate for windowed mode is that I recently got a 1080p monitor that has a bad habit of stretching smaller resolutions to the edges of its screen. WZ suffers quite badly because of this.

My next problem is that my screen goes black and the game crashes when any of my units get past the first oil derrick in the campaign. "Incoming Intelligence Report!" *Crash*. Anyone know what's causing this and how I might fix it? Would reinstalling help?

Edit: Before anyone asks, I run the game at 1280x1024 with the renderer set to D3D. Changing the resolution and render mode does not fix this problem.

Thanks in advance for any help.
User avatar
E-102 Gamma
Regular
Regular
 
Posts: 661
Joined: 07 Feb 2011, 21:30
Location: Portland, OR, USA

Re: Two new problems.

Postby E-102 Gamma » 27 Feb 2011, 23:43

Well, I just fixed my first problem by setting my Color Quality to 16 BBP. The game launched in a window and ran perfectly.

The second problem persists, though. "Incoming Intelligence Report--Report..." *Crash*. Anyone know what's causing this? Again, should I reinstall?

Thanks.
User avatar
E-102 Gamma
Regular
Regular
 
Posts: 661
Joined: 07 Feb 2011, 21:30
Location: Portland, OR, USA

Re: Two new problems.

Postby BunkerBlaster » 28 Feb 2011, 07:21

E-102 Gamma wrote:Well, I just fixed my first problem by setting my Color Quality to 16 BBP. The game launched in a window and ran perfectly.

The second problem persists, though. "Incoming Intelligence Report--Report..." *Crash*. Anyone know what's causing this? Again, should I reinstall?

Thanks.


Its most likely trying to play the video which you don't have or it is corrupt. Try downloading video again and put it in the Warzone directory. http://wz2100.net/download
BunkerBlaster
Trained
Trained
 
Posts: 268
Joined: 21 Feb 2010, 09:56

Re: Two new problems.

Postby E-102 Gamma » 28 Feb 2011, 21:26

Keep in mind that I'm trying to fix version 1.10.

I think I'll try reinstalling. I might have messed it up by pasting another computer's Warzone 2100 folder over mine while attempting to fix a completely different problem.
User avatar
E-102 Gamma
Regular
Regular
 
Posts: 661
Joined: 07 Feb 2011, 21:30
Location: Portland, OR, USA

Re: Two new problems.

Postby BunkerBlaster » 01 Mar 2011, 03:59

I never tried compiling ver 1.10 because I have original CD with 1.10 patch. But the problem you describe "Incoming Intelligence Report--Report..." *Crash*. " ... Its trying to play the video and it cannot.
BunkerBlaster
Trained
Trained
 
Posts: 268
Joined: 21 Feb 2010, 09:56

Re: Two new problems.

Postby E-102 Gamma » 05 Mar 2011, 07:48

Well, guys, I just fixed it. I had set it to run in compatibility mode for Win 98 / ME, and I had disabled visual themes. I simply turned off CM and re-enabled visual themes, and it worked.

So, wow. I solved both of my problems on my own. O_o

Thanks for trying to help, BunkerBlaster. :)

Sorry for any trouble I caused.
User avatar
E-102 Gamma
Regular
Regular
 
Posts: 661
Joined: 07 Feb 2011, 21:30
Location: Portland, OR, USA


Return to 1.x

cron