Sounds Are Broken in RC on Ubuntu Jaunty

Warzone 2.1.x series. (Unsupported--read only!)

Sounds Are Broken in RC on Ubuntu Jaunty

Postby nullack » 30 Nov 2008, 06:56

Jaunty has the 2.1 RC1 warzone build. Like Fedora 10, it also has the new pulse audio sound server. Other games play fine but warzone is all pops, fizzes and noisy static when trying to play the music, voice and sound effects.

This did not occur in beta 4.
nullack
Greenhorn
 
Posts: 7
Joined: 24 Aug 2008, 21:56

Re: Sounds Are Broken in RC on Ubuntu Jaunty

Postby Per » 02 Dec 2008, 00:45

Works fine with Pulseaudio here, on Fedora 10. Also worked fine on Fedora 9.
Per
Warzone 2100 Team Member
Warzone 2100 Team Member
 
Posts: 3604
Joined: 03 Aug 2006, 19:39

Re: Sounds Are Broken in RC on Ubuntu Jaunty

Postby nullack » 04 Dec 2008, 08:02

I just did a fresh install and can confirm the problem still exists.

Can anyone help me debug this further? Im happy to create Ubuntu or Warzone bug reports. All audio works fine except for Warzone.

I note these in the sys log while the game is executing

Dec 4 16:58:50 PPP pulseaudio[5840]: module-alsa-sink.c: Increasing wakeup watermark to 181.31 ms
nullack
Greenhorn
 
Posts: 7
Joined: 24 Aug 2008, 21:56

Re: Sounds Are Broken in RC on Ubuntu Jaunty

Postby Per » 04 Dec 2008, 15:55

Sorry, no idea what could be the problem.
Per
Warzone 2100 Team Member
Warzone 2100 Team Member
 
Posts: 3604
Joined: 03 Aug 2006, 19:39

Re: Sounds Are Broken in RC on Ubuntu Jaunty

Postby cybersphinx » 04 Dec 2008, 16:14

nullack wrote:Can anyone help me debug this further? Im happy to create Ubuntu or Warzone bug reports. All audio works fine except for Warzone.

Try some other program that uses OpenAL, e.g. "mplayer -ao openal some.movie". If that doesn't work, then you have to find out how to make OpenAL work with pulseaudio (or complain to Ubuntu to make them do it).
cybersphinx
Inactive
Inactive
 
Posts: 1666
Joined: 01 Sep 2006, 19:17

Re: Sounds Are Broken in RC on Ubuntu Jaunty

Postby fisk0 » 04 Mar 2009, 19:13

I had the same problem. I can't get anything using PulseAudio to work, but I managed to get sound in Warzone 2100 by editing OpenAL's config file (/etc/openal/something) to use OSS instead. There are helpful comments inside the config file that tells you what to do.
Desktop: AMD Athlon X3 440 3.0ghz, 4GB RAM, Radeon HD4200, Windows 7 Professional 64-bit
Laptop: AMD Athlon X2 QL-64 2.1Ghz, 3GB RAM, Radeon HD3200, Windows Vista Home Basic 32-bit & Ubuntu 9.04 64-bit
fisk0
Trained
Trained
 
Posts: 245
Joined: 17 Aug 2008, 16:59
Location: Stockholm, Sweden

Re: Sounds Are Broken in RC on Ubuntu Jaunty

Postby jaakan » 05 Mar 2009, 00:24

here is what I found
http://pulseaudio.org/ticket/488
fixed on/after 0.9.15 but Ubuntu Jaunty is currently at 0.9.14. Hopeful Ubuntu Jaunty will get the newer version with the fix before the final comes out.
User avatar
jaakan
Trained
Trained
 
Posts: 75
Joined: 15 Jun 2008, 01:51

Re: Sounds Are Broken in RC on Ubuntu Jaunty

Postby tk24 » 19 Sep 2009, 00:32

the problem exists in version 2.2 in version 2.1 i had no sounds what so ever
tk24
Greenhorn
 
Posts: 10
Joined: 06 Sep 2009, 15:14

Re: Sounds Are Broken in RC on Ubuntu Jaunty

Postby lav_coyote25 » 19 Sep 2009, 01:08

we are now on 2.2.3 - your best bet is to get the latest release...
User avatar
lav_coyote25
Professional
Professional
 
Posts: 3434
Joined: 08 Aug 2006, 23:18

Re: Sounds Are Broken in RC on Ubuntu Jaunty

Postby cybersphinx » 19 Sep 2009, 01:11

Test another program using OpenAL. If that also doesn't work, the problem is with Ubuntu, and you should report it there.
cybersphinx
Inactive
Inactive
 
Posts: 1666
Joined: 01 Sep 2006, 19:17


Return to 2.1.x