Unknown bug

Warzone 2.1.x series. (Unsupported--read only!)

Unknown bug

Postby Dr_Frodo » 30 Oct 2008, 19:39

Hi all, I'm new here but a long time fan of WZ and the resurrection project.

I've got a rather annoying bug that I'm not able to pinpoint the cause of. It has happened in two different builds (A nightly build for the FMVs, which worked fine throughout) and in the 2.1b5 build (currently using).

The bug is basically a game crash, no errors beforehand then bam! game closed. (the 'score screen' sometimes very, very quickly pops up (the one with info on kills & ranks) followed immediately by the game simply stopping).

It may be the fact that I use multi-turrets whenever I can (I tend to stick a bunker buster to the front of my tanks), but the crash has happened whilst I was building defences only, no tanks other than standard trucks.

It's rather annoying this bug, after playing for a couple of hours in skirmish for the game to simply exit it a major bug IMO.

I've not made a ticket as I have no idea what the error is or what's causing it, I just know it happens. If you need any more info, just ask.
User avatar
Dr_Frodo
Greenhorn
 
Posts: 10
Joined: 19 Oct 2008, 17:40

Re: Unknown bug

Postby Buginator » 30 Oct 2008, 20:59

Dr_Frodo wrote:It's rather annoying this bug, after playing for a couple of hours in skirmish for the game to simply exit it a major bug IMO.
I've not made a ticket as I have no idea what the error is or what's causing it, I just know it happens. If you need any more info, just ask.


If the game didn't create a stderr.txt and no crash dump, then it might not be game related at all. Usually, when a exit call happens, we dump the reason out to stderr.txt.

What system do you got (OS/vid card/drivers)?
and it ends here.
User avatar
Buginator
Professional
Professional
 
Posts: 3285
Joined: 04 Nov 2007, 02:20

Re: Unknown bug

Postby Dr_Frodo » 30 Oct 2008, 22:55

Installed the debug version, in the error file was as follows:
warning : [displayMultiBut] no automatic multibut highlight for width = 22
last message repeated 2 times
last message repeated 2 times (total 4 repeats)
last message repeated 4 times (total 8 repeats)
last message repeated 8 times (total 16 repeats)
last message repeated 16 times (total 32 repeats)
last message repeated 32 times (total 64 repeats)
last message repeated 64 times (total 128 repeats)
last message repeated 128 times (total 256 repeats)
last message repeated 79 times (total 335 repeats)
error : [widgSetButtonState] widgSetButtonState: Couldn't find button/click form from ID
error : [widgSetButtonState] Assert in Warzone: widget.c:1080 (false), last script event: 'N/A


OS: Win XP x64
CPU Core 2 Quad Q6600 @ 2.4GHz
Video: 2x 8800GT Alpha Dog, SLI
Drivers: GPUs - 178.24 (Latest drivers for the system), MOBO - 15.23 (Latest for MOBO)
User avatar
Dr_Frodo
Greenhorn
 
Posts: 10
Joined: 19 Oct 2008, 17:40

Re: Unknown bug

Postby Zi-Chan » 08 Dec 2008, 00:05

Hey Folks :)

I've downloaded and played the Trunk-r6074 containing the FMVs (not Debug) and experienced the same Error Dr_Frodo describes.

To reproduce it just click very fast (!) through the finished Researches. Crashed at me at the 6. Bar. Finished the first 4 Bars and then it crashed at the Second Bar of the Second Researches, so the 6. Bar at all.

error |000000226350: [iV_GetCharWidth] iV_GetCharWidth: couldn't retrieve a bounding box for the character
last message repeated 2 times
last message repeated 2 times (total 4 repeats)
last message repeated 4 times (total 8 repeats)
last message repeated 8 times (total 16 repeats)
last message repeated 16 times (total 32 repeats)
last message repeated 32 times (total 64 repeats)
last message repeated 64 times (total 128 repeats)
last message repeated 128 times (total 256 repeats)

Looks like a Bug, an Overload, of the new Sound-System with the 256 Sources.

Regards,
Zi-Chan
:ninja:
User avatar
Zi-Chan
Trained
Trained
 
Posts: 180
Joined: 12 Aug 2008, 01:06

Re: Unknown bug

Postby HolyDragoon » 09 Dec 2008, 18:18

That problem isn't new... i saw it happen several times in multiplay games. I thought it was already reported?

Goes at least as far as the beta-4
"Relativity applies to Physics, not Ethics." - Albert Einstein
User avatar
HolyDragoon
Trained
Trained
 
Posts: 60
Joined: 13 Jun 2008, 13:02
Location: Portugal

Re: Unknown bug

Postby Buginator » 14 Dec 2008, 01:14

Zi-Chan wrote:Hey Folks :)

I've downloaded and played the Trunk-r6074 containing the FMVs (not Debug) and experienced the same Error Dr_Frodo describes.

To reproduce it just click very fast (!) through the finished Researches. Crashed at me at the 6. Bar. Finished the first 4 Bars and then it crashed at the Second Bar of the Second Researches, so the 6. Bar at all.

error |000000226350: [iV_GetCharWidth] iV_GetCharWidth: couldn't retrieve a bounding box for the character
last message repeated 2 times
last message repeated 2 times (total 4 repeats)
last message repeated 4 times (total 8 repeats)
last message repeated 8 times (total 16 repeats)
last message repeated 16 times (total 32 repeats)
last message repeated 32 times (total 64 repeats)
last message repeated 64 times (total 128 repeats)
last message repeated 128 times (total 256 repeats)

Looks like a Bug, an Overload, of the new Sound-System with the 256 Sources.

Regards,
Zi-Chan


Naw, it won't crash if it goes over 256 sources. It just will sound horrible.

The sound code does need a major overhaul though, and it will get done one of these days.

As for the other issue, when it says '[iV_GetCharWidth] iV_GetCharWidth: couldn't retrieve a bounding box for the character' that is most likely because it didn't get cleaned up correctly, and it is working on a bad widget ID.
and it ends here.
User avatar
Buginator
Professional
Professional
 
Posts: 3285
Joined: 04 Nov 2007, 02:20

Re: Unknown bug

Postby Zi-Chan » 18 Dec 2008, 23:10

Buginator wrote:Naw, it won't crash if it goes over 256 sources. It just will sound horrible.

But it did crash - if the Game doesn't i usually don't open the Error-File. I experienced that Error again some Days ago. Crashed again with those Errors - this Time it went over 256 like at Dr_Frodo.
:ninja:
User avatar
Zi-Chan
Trained
Trained
 
Posts: 180
Joined: 12 Aug 2008, 01:06

Re: Unknown bug

Postby Buginator » 25 Jan 2009, 00:03

Zi-Chan wrote:But it did crash - if the Game doesn't i usually don't open the Error-File. I experienced that Error again some Days ago. Crashed again with those Errors - this Time it went over 256 like at Dr_Frodo.


Seriously, it will not crash per se. It will start sounding bad though.

The "iV_GetCharWidth: couldn't retrieve a bounding box for the character"
is not related to sound *at all*.

That is another issue.

That is why we need bug reports to be posted on trac, with full error logs, and crash dumps.
and it ends here.
User avatar
Buginator
Professional
Professional
 
Posts: 3285
Joined: 04 Nov 2007, 02:20

Re: Unknown bug

Postby Phoenix666 » 25 Jan 2009, 09:48

error |000000226350: [iV_GetCharWidth] iV_GetCharWidth: couldn't retrieve a bounding box for the character

This is key line of error
i have the same error when i use standart .mo file with russian(i write about it in other topic)

Zi which language are you use?
User avatar
Phoenix666
Trained
Trained
 
Posts: 106
Joined: 21 Sep 2008, 20:38
Location: Russia


Return to 2.1.x

cron