iritating sound

Warzone 2.1.x series. (Unsupported--read only!)

iritating sound

Postby DarkCheetah » 25 Oct 2008, 13:23

hello guys, this sounds weird but , the CD warzone's sound is not like bugged and all , but in this beta version (ressurections) it seems like OpenAl can't take the sound of warzone , i'v played a 4v4 (alot of times) and have detected after 10 min's the sound started to scratch , like making iritating noises , how am i able to prevent them?
User avatar
DarkCheetah
Trained
Trained
 
Posts: 335
Joined: 30 Apr 2008, 19:44

Re: iritating sound

Postby Buginator » 25 Oct 2008, 21:55

Fixed.
(more or less that is...)
and it ends here.
User avatar
Buginator
Professional
Professional
 
Posts: 3285
Joined: 04 Nov 2007, 02:20

Re: iritating sound

Postby DarkCheetah » 25 Oct 2008, 23:11

what u mean by that? they'r fixing it?
User avatar
DarkCheetah
Trained
Trained
 
Posts: 335
Joined: 30 Apr 2008, 19:44

Re: iritating sound

Postby Buginator » 26 Oct 2008, 06:31

DarkCheetah wrote:what u mean by that? they'r fixing it?

While I don't usually talk in the 3rd person, yes, they have a fix (more or less) for it.

What does the 'more or less' part mean? It means that on XP, the # of 'channels' was limited to 16 on most all systems, unless they had a dedicated sound card. On linux (& mac?) it was 256 available 'channels'.
With the 'fix', it now uses 256 'channels' on XP, which is also the default for vista.

However, to *really* fix it, then we need to make a real sound manager.

Hope that clears things up?
and it ends here.
User avatar
Buginator
Professional
Professional
 
Posts: 3285
Joined: 04 Nov 2007, 02:20

Re: iritating sound

Postby DarkCheetah » 26 Oct 2008, 15:26

yup! , but where can i get the fix? becuase evrytime i play 2.5 BETA 5 and play for 5 mins on a 4v4 then my sound is losing quality...
User avatar
DarkCheetah
Trained
Trained
 
Posts: 335
Joined: 30 Apr 2008, 19:44

Re: iritating sound

Postby Buginator » 28 Oct 2008, 21:21

DarkCheetah wrote:yup! , but where can i get the fix? becuase evrytime i play 2.5 BETA 5 and play for 5 mins on a 4v4 then my sound is losing quality...


The fix will be in the next (RC) 2.1, or in the nightly builds starting tonight... (if you care to test the sound.)
and it ends here.
User avatar
Buginator
Professional
Professional
 
Posts: 3285
Joined: 04 Nov 2007, 02:20

Re: iritating sound

Postby DarkCheetah » 29 Oct 2008, 00:49

RC? and yes i gladly test , i am actualy a beta tester , i always play Beta 5 now :3 and found this sound bug ^^
User avatar
DarkCheetah
Trained
Trained
 
Posts: 335
Joined: 30 Apr 2008, 19:44

Re: iritating sound

Postby DarkCheetah » 11 Nov 2008, 03:52

Buginator wrote:
DarkCheetah wrote:yup! , but where can i get the fix? becuase evrytime i play 2.5 BETA 5 and play for 5 mins on a 4v4 then my sound is losing quality...


The fix will be in the next (RC) 2.1, or in the nightly builds starting tonight... (if you care to test the sound.)


i tested the RC client , also there is the sound bug , one thing i say its a bit less but still , scratching non-stop...
User avatar
DarkCheetah
Trained
Trained
 
Posts: 335
Joined: 30 Apr 2008, 19:44


Return to 2.1.x