Text doesn't appear correctly.

Warzone 2.1.x series. (Unsupported--read only!)
Locked
italian
Rookie
Rookie
Posts: 19
Joined: 20 Feb 2007, 18:51

Text doesn't appear correctly.

Post by italian » 23 Jul 2008, 21:58

80% of the text doesn't show correctly.
For example (attached file):
Attachments
textproblem2.png
You have viewed that the text appears randomly.
textproblem.png
First example.

doom3r
Regular
Regular
Posts: 502
Joined: 29 Aug 2007, 15:04

Re: Text doesn't appear correctly.

Post by doom3r » 23 Jul 2008, 22:14

I just checked if I had the same problem with Italian language on but it looks all right to me. Have you tried to install the "DeJaVuSansMono" font from the "fonts" dir in Warzone? [by installing, I mean copying the file to "c:/windows/fonts"]

About the Italian language, I still have to complete the translation (ehm xD), it would be great if you gave me some feedback about that (it is actually 50%).

italian
Rookie
Rookie
Posts: 19
Joined: 20 Feb 2007, 18:51

Re: Text doesn't appear correctly.

Post by italian » 23 Jul 2008, 22:18

doom3r wrote:I just checked if I had the same problem with Italian language on but it looks all right to me. Have you tried to install the "DeJaVuSansMono" font from the "fonts" dir in Warzone? [by installing, I mean copying the file to "c:/windows/fonts"]

About the Italian language, I still have to complete the translation (ehm xD), it would be great if you gave me some feedback about that (it is actually 50%).
1)Yes, but it's the same.

2)I could translate, because I've played Warzone 2100 for ps1 in Italian.

User avatar
DevUrandom
Regular
Regular
Posts: 1690
Joined: 31 Jul 2006, 23:14

Re: Text doesn't appear correctly.

Post by DevUrandom » 23 Jul 2008, 23:12

We had this issue already some time ago. I even thought we fixed it.
And it is not related to WZ not finding the font.

italian
Rookie
Rookie
Posts: 19
Joined: 20 Feb 2007, 18:51

Re: Text doesn't appear correctly.

Post by italian » 23 Jul 2008, 23:15

DevUrandom wrote:We had this issue already some time ago. I even thought we fixed it.
And it is not related to WZ not finding the font.
And it's the beta4 version.

[UPDATE] This is my debug log.
Attachments
stderr.txt
(17.39 KiB) Downloaded 252 times

User avatar
Buginator
Professional
Professional
Posts: 3285
Joined: 04 Nov 2007, 02:20

Re: Text doesn't appear correctly.

Post by Buginator » 24 Jul 2008, 07:16

What hardware do you got?

Have you tried different video drivers?

EvilGuru
Regular
Regular
Posts: 615
Joined: 23 Jun 2007, 22:41

Re: Text doesn't appear correctly.

Post by EvilGuru » 24 Jul 2008, 11:35

This looks very similar to a bug we got in OS X when we updated from GLC 0.6 to 0.7. I think it was to do with rendering text as textures, but I am not totally sure there.

Regards, Freddie.

italian
Rookie
Rookie
Posts: 19
Joined: 20 Feb 2007, 18:51

Re: Text doesn't appear correctly.

Post by italian » 24 Jul 2008, 12:41

EvilGuru wrote:This looks very similar to a bug we got in OS X when we updated from GLC 0.6 to 0.7. I think it was to do with rendering text as textures, but I am not totally sure there.

Regards, Freddie.
I've Windows XP Professional SP3.
Buginator wrote:What hardware do you got?
I've ATI RADEON 9200 SERIES.

EvilGuru
Regular
Regular
Posts: 615
Joined: 23 Jun 2007, 22:41

Re: Text doesn't appear correctly.

Post by EvilGuru » 24 Jul 2008, 13:19

My iBook (which ran OS X) and the system on which I experienced the above bug on also had an 9200. I am unsure if they are related or not -- does anyone else have a 9200 and if so does it work?

Regards, Freddie.

User avatar
craigengbrecht
Trained
Trained
Posts: 51
Joined: 21 Jul 2008, 03:49
Location: Red Deer, AB
Contact:

Re: Text doesn't appear correctly.

Post by craigengbrecht » 02 Aug 2008, 22:16

I have a 9200 and a 9250 they both work dandy with SP3 XP PRO, so I don't know what the problem could be.
Though if you update the drivers with ANY**** windows drivers from Microsoft, then that may be your problem, I have found that any drivers for ATI, from M$ caused problems in ALL apps... funny eh?
AMD FX X8 3.88Ghz
16GB KVM 1333Mhz
ASUS M5A97
ASUS EAH 6850 1GB
3x ASUS 1920x1080 VW246H
1x 5000GB Primary
1x 1TB Internal
1x 3TB Internal

italian
Rookie
Rookie
Posts: 19
Joined: 20 Feb 2007, 18:51

Re: Text doesn't appear correctly.

Post by italian » 03 Aug 2008, 13:25

The problem was the OpenGL driver. I've updated this driver and it function correctly.

User avatar
Alpha93
Trained
Trained
Posts: 261
Joined: 02 Aug 2008, 20:23
Location: Italy,in YOUR computer
Contact:

Re: Text doesn't appear correctly.

Post by Alpha93 » 03 Aug 2008, 13:31

Well,you should keep your driver up to date...can you give me your msn adress via PM?
Xfire-->chris37killer

Locked