2.1 Beta 4: Plays Beautifully!

Warzone 2.1.x series. (Unsupported--read only!)
Infidelus
Rookie
Rookie
Posts: 26
Joined: 02 Apr 2007, 13:41

Re: 2.1 Beta 4: Plays Beautifully!

Post by Infidelus » 27 Jul 2008, 20:19

I'm open to suggestions.

I'm not a developer, but I'm happy to try.

We didn't do anything special to get the results we did. IP game of 8 players, 2 human, 6 computer. All we'd really done at that point was build our command centre's, factory, research bays and started doing the early on research. After about 10 mins we allied up (after we remembered which button it was to bring up that menu :))

Five minutes or so later, the enemy started flying in and destroying our stuff, at which point, as mentioned, the trucks all went on strike as far as repairs went.

That's about the total of what we did, give or take building a couple of walls and machine gun turrets to block ground based enemy out.

Infidelus
Rookie
Rookie
Posts: 26
Joined: 02 Apr 2007, 13:41

Re: 2.1 Beta 4: Plays Beautifully!

Post by Infidelus » 27 Jul 2008, 23:28

I don't know if this helps at all, but:

I reinstalled beta 2 over the top of beta 4 and played again with mate this evening. Same worker strike happened.

Quit out. Deleted Warzone folder. Reinstalled RC2 again, and all worked as expected (except we still got humped over by air attack far too quickly :D )

madfalcon81
Trained
Trained
Posts: 46
Joined: 05 Jan 2008, 18:44

Re: 2.1 Beta 4: Plays Beautifully!

Post by madfalcon81 » 28 Jul 2008, 01:34

beta 4 doesnt start...did that with font installing and nothign...it simply doesnt start..no error message..nothing..

Per
Warzone 2100 Team Member
Warzone 2100 Team Member
Posts: 3775
Joined: 03 Aug 2006, 19:39

Re: 2.1 Beta 4: Plays Beautifully!

Post by Per » 28 Jul 2008, 14:18

Infidelus wrote:I don't know if this helps at all, but:

I reinstalled beta 2 over the top of beta 4 and played again with mate this evening. Same worker strike happened.

Quit out. Deleted Warzone folder. Reinstalled RC2 again, and all worked as expected (except we still got humped over by air attack far too quickly :D )
Can you test if this problem is also present in the trunk (development snapshots)?

If so, you can try to run it from the console (if on linux or macosx), enter cheat mode, and press ctrl+l to enable tracing on a striking droid. Then watch the console output for anything interesting. If on Windows, no need to start from console, but you will need to reopen the file stdout.txt (or is it stderr.txt?) periodically to see the output. This functionality is not properly implemented in 2.1. Also make sure you use a debug build.

User avatar
NucNut
Trained
Trained
Posts: 92
Joined: 04 Sep 2007, 12:58
Location: Western Australia, Earth, Sol, Milky Way

Re: 2.1 Beta 4: Plays Beautifully!

Post by NucNut » 28 Jul 2008, 15:25

drive mode? DRIVE MODE?! How do i activate it? Always Loved this feature on the psx :D

So how do i activate it? So... i have to activate debug mode (thats using the --cheat command line option right?) and then what? use the arrows keys?

Hard to believe i've been involved with WZ for ages, yet i can still be a n00b :rolleyes:
REDAC Aerospace: Proving that aircraft and terrain don't mix since 2005 :D
XFire Profile: dogzeroonefox

User avatar
Black Project
Regular
Regular
Posts: 734
Joined: 04 Apr 2008, 20:53

Re: 2.1 Beta 4: Plays Beautifully!

Post by Black Project » 28 Jul 2008, 15:44

NucNut wrote:drive mode? DRIVE MODE?! How do i activate it? Always Loved this feature on the psx :D

So how do i activate it? So... i have to activate debug mode (thats using the --cheat command line option right?) and then what? use the arrows keys?

Hard to believe i've been involved with WZ for ages, yet i can still be a n00b :rolleyes:
Right, you need to run the game in command line option, just note the space between the "warzone2100.exe" and the --cheat

Will be something like this

warzone2100.exe" --cheat

During playing the game, press left SHIFT+BACKSPACE, after this, select a unit, and press SPACE to enter to the tracking mode of your unit, now press left SHIFT+D to activate the drive mode, to deactivate it, press left SHIFT+D.

Remember: the tracking mode must be activated to activate the drive mode.

Use the arrows keys to move your unit.

Infidelus
Rookie
Rookie
Posts: 26
Joined: 02 Apr 2007, 13:41

Re: 2.1 Beta 4: Plays Beautifully!

Post by Infidelus » 28 Jul 2008, 20:26

Per wrote:
Infidelus wrote:I don't know if this helps at all, but:

I reinstalled beta 2 over the top of beta 4 and played again with mate this evening. Same worker strike happened.

Quit out. Deleted Warzone folder. Reinstalled RC2 again, and all worked as expected (except we still got humped over by air attack far too quickly :D )
Can you test if this problem is also present in the trunk (development snapshots)?

If so, you can try to run it from the console (if on linux or macosx), enter cheat mode, and press ctrl+l to enable tracing on a striking droid. Then watch the console output for anything interesting. If on Windows, no need to start from console, but you will need to reopen the file stdout.txt (or is it stderr.txt?) periodically to see the output. This functionality is not properly implemented in 2.1. Also make sure you use a debug build.
I can try, once I work out where and how to compile it for Windows. The hardest part is going to be convincing my mate to do the same and play it again. He's not very patient, and rather stubborn (minor understatement ;))

Probably won't get a chance to try until the weekend due to conflicting work schedules.

Infidelus
Rookie
Rookie
Posts: 26
Joined: 02 Apr 2007, 13:41

Re: 2.1 Beta 4: Plays Beautifully!

Post by Infidelus » 04 Aug 2008, 21:04

Quick update.

Tried the latest SVN someone's compliled that's linked to in the 'Real Nightly Builds' thread (4th August).

Unfortunately, as soon as you change the map, it the game dumps out, so not much chance of testing that at all. Mate is fed up of arsing around installing different versions, so I don't expect he'll be helping do any testing. Not sure how much time I'll get to either, so I suspect we'll just wait and see if it works in the next beta.

Found another bug as well while playing on beta 4. There seems to be some sync problems (which I'm sure you guys are aware of). Upshot of this is, one person looking at an area on the map is seeing a fight going on, while on the other person's PC, there's nothing moving but the tumbleweed. Might explain some of these vehicles/buildings getting blown up without seeming cause.

Locked