2.1 Beta 4: Plays Beautifully!

Warzone 2.1.x series. (Unsupported--read only!)
User avatar
Molotov
Trained
Trained
Posts: 34
Joined: 07 Jul 2008, 23:22
Location: Texas
Contact:

2.1 Beta 4: Plays Beautifully!

Post by Molotov » 21 Jul 2008, 06:20

As it's been said, some bugs remain. However, the only one I've encountered was the out-of-sync multiplayer disconnect!
The music is great, gameplay is at its best so far!
(I also REALLY appreciate that the devs lowered the volume of the oil derrick sounds. THANK YOU SO MUCH)
Great work!
You have five minutes to comply,
0R 3|$3 1T$ FR%1N6 T1M3!!!!!11!!!1!

User avatar
craigengbrecht
Trained
Trained
Posts: 51
Joined: 21 Jul 2008, 03:49
Location: Red Deer, AB
Contact:

Re: 2.1 Beta 4: Plays Beautifully!

Post by craigengbrecht » 21 Jul 2008, 07:20

After posting some bug reports of the new one, I followed Molotov's advice changed out the font, and played...
Got so distracted that 2.5 hrs later here I am to post that I agree 110% with Molotov!
AMD FX X8 3.88Ghz
16GB KVM 1333Mhz
ASUS M5A97
ASUS EAH 6850 1GB
3x ASUS 1920x1080 VW246H
1x 5000GB Primary
1x 1TB Internal
1x 3TB Internal

User avatar
Kreuvf
Global Moderator
Global Moderator
Posts: 244
Joined: 22 Sep 2006, 20:56
Contact:

Re: 2.1 Beta 4: Plays Beautifully!

Post by Kreuvf » 22 Jul 2008, 20:06

Same experience here :-)

Best thing that could ever happen to Warzone 2100

And it even works with Windows 98 xD
Contact only via [url=https://warzone2100.de/impressum.php]e-mail[/url]. GPG encryption supported ([url=https://gpg.kreuvf.de/kreuvf2015.asc]my key[/url]).

User avatar
wari
Trained
Trained
Posts: 106
Joined: 05 Dec 2007, 18:25
Location: Dublin

Re: 2.1 Beta 4: Plays Beautifully!

Post by wari » 23 Jul 2008, 10:46

Yeah plays very well, thanks to the team that produced it!

User avatar
HolyDragoon
Trained
Trained
Posts: 60
Joined: 13 Jun 2008, 13:02
Location: Portugal

Re: 2.1 Beta 4: Plays Beautifully!

Post by HolyDragoon » 25 Jul 2008, 16:32

The wierdest thing.

The beta 2 didn't work on this computer, no matter how much i tried.

Installed the Beta 4... wham! Playing with no problem!
"Relativity applies to Physics, not Ethics." - Albert Einstein

Kamaze
Regular
Regular
Posts: 1017
Joined: 30 Jul 2006, 15:23

Re: 2.1 Beta 4: Plays Beautifully!

Post by Kamaze » 25 Jul 2008, 18:47

HolyDragoon wrote:The wierdest thing.

The beta 2 didn't work on this computer, no matter how much i tried.

Installed the Beta 4... wham! Playing with no problem!
You're right.
Pretty strange that some bugs get fixed with newer releases.
We should may change it!
We all have the same heaven, but not the same horizon.

User avatar
Powzone
Trained
Trained
Posts: 332
Joined: 17 Feb 2008, 17:25
Location: Germany

Re: 2.1 Beta 4: Plays Beautifully!

Post by Powzone » 25 Jul 2008, 20:21

Kamaze wrote:Pretty strange that some bugs get fixed with newer releases.
We should may change it!
I LOLed!! :D
Manjaro XFCE / Intel Core i7 6700 / 32GB RAM / NVidia GTX1050Ti

User avatar
Black Project
Regular
Regular
Posts: 734
Joined: 04 Apr 2008, 20:53

Re: 2.1 Beta 4: Plays Beautifully!

Post by Black Project » 25 Jul 2008, 23:44

Molotov wrote:As it's been said, some bugs remain. However, the only one I've encountered was the out-of-sync multiplayer disconnect!
The music is great, gameplay is at its best so far!
(I also REALLY appreciate that the devs lowered the volume of the oil derrick sounds. THANK YOU SO MUCH)
Great work!
I agree with Molotov, another thing i liked is the DRIVE MODE when you activate the DEBUG MODE, it's very funny you drive your own unit, but very funny with VTOLs, especially if you go to MP.WZ/STATS/PROPULSIONS and put the weight of the VTOL propulsion to 0 and the MAX SPEED to 5000 KM/H, very cool,the same i did with the HOVER, i also did it to make a nice drift with the hover units :D :D :D :D :D :D :D :D :D :D :D :D :D
HolyDragoon wrote:The wierdest thing.

The beta 2 didn't work on this computer, no matter how much i tried.

Installed the Beta 4... wham! Playing with no problem!
It's because the 2.1 BETA 2 refuses to create the setting folder of it, i don't know if i am right, you will know after you see it: viewtopic.php?f=19&t=1498. So you must create this folder manually.

User avatar
HolyDragoon
Trained
Trained
Posts: 60
Joined: 13 Jun 2008, 13:02
Location: Portugal

Re: 2.1 Beta 4: Plays Beautifully!

Post by HolyDragoon » 26 Jul 2008, 03:12

Black Project wrote:
I agree with Molotov, another thing i liked is the DRIVE MODE when you activate the DEBUG MODE, it's very funny you drive your own unit, but very funny with VTOLs, especially if you go to MP.WZ/STATS/PROPULSIONS and put the weight of the VTOL propulsion to 0 and the MAX SPEED to 5000 KM/H, very cool,the same i did with the HOVER, i also did it to make a nice drift with the hover units :D :D :D :D :D :D :D :D :D :D :D :D :D
HolyDragoon wrote:The wierdest thing.

The beta 2 didn't work on this computer, no matter how much i tried.

Installed the Beta 4... wham! Playing with no problem!
It's because the 2.1 BETA 2 refuses to create the setting folder of it, i don't know if i am right, you will know after you see it: viewtopic.php?f=19&t=1498. So you must create this folder manually.
Oh, so that's the problem.

My video card is kind of sucky, so i Thought Warzone was telling me to get a new one.

Also, how do you drive when debug on? A command?

Also, I lol'd at the multi turrets. Lancer + Heavy Cannon :D
"Relativity applies to Physics, not Ethics." - Albert Einstein

User avatar
Buginator
Professional
Professional
Posts: 3285
Joined: 04 Nov 2007, 02:20

Re: 2.1 Beta 4: Plays Beautifully!

Post by Buginator » 26 Jul 2008, 07:12

Black Project wrote: I agree with Molotov, another thing i liked is the DRIVE MODE when you activate the DEBUG MODE, it's very funny you drive your own unit, but very funny with VTOLs, especially if you go to MP.WZ/STATS/PROPULSIONS and put the weight of the VTOL propulsion to 0 and the MAX SPEED to 5000 KM/H, very cool,the same i did with the HOVER, i also did it to make a nice drift with the hover units :D :D :D :D :D :D :D :D :D :D :D :D :D
*cough*, now how did you find that? xD
One of these days, I need to actually complete this, since this was for the most part, only a test (so it is still a very BETA feature).
I need someone to invent a time machine, so I can get all these things done. :3

doom3r
Regular
Regular
Posts: 502
Joined: 29 Aug 2007, 15:04

Re: 2.1 Beta 4: Plays Beautifully!

Post by doom3r » 26 Jul 2008, 11:55

DRIVE MODE
Wow looks like Drive Mode is likely to come soon, maybe without the usage of the debug menu (I hope so :P)...
It's been almost a year since I posted the idea to port the drive mode from PSX Warzone to PC Warzone, but finally we have it!
I'm going to try that right now...

User avatar
kipman725
Trained
Trained
Posts: 84
Joined: 03 Feb 2007, 01:52
Location: UK

Re: 2.1 Beta 4: Plays Beautifully!

Post by kipman725 » 26 Jul 2008, 14:47

I firstly tried WZ 2100 Beta 4 on debian lenny/sid 64bit running dual headed with xinerama: I had to get warzone running in a window to avoid very corupted graphics, but this happens with other games aswell so I susupect it's lack of xinerama support? after that everyhting worked fine.
I then tried on windows xp pro with no problems on a 4 person internet match :D
I then tried my debian box single headed and encountered no problems.

On an unrelated note the warzone packages for debian are in the sid repos and debian testing is due to be freezed within a week? so would it be posible to get warzone moved to testing as I managed to fufill its dependanices entirly from testing and it has met the time citation, could be the architectures requirment slowing it?

some suggestions: better in game chat, at the moment the chat messages are very easy to miss and stay on the screen for a very breif moment of time. Also revamp rockets as minipods should be avilable soon after the first machine gun upgrades they are that weak.

User avatar
Buginator
Professional
Professional
Posts: 3285
Joined: 04 Nov 2007, 02:20

Re: 2.1 Beta 4: Plays Beautifully!

Post by Buginator » 27 Jul 2008, 06:15

kipman725 wrote:I firstly tried WZ 2100 Beta 4 on debian lenny/sid 64bit running dual headed with xinerama: I had to get warzone running in a window to avoid very corupted graphics, but this happens with other games aswell so I susupect it's lack of xinerama support? after that everyhting worked fine.
I then tried on windows xp pro with no problems on a 4 person internet match :D
I then tried my debian box single headed and encountered no problems.

On an unrelated note the warzone packages for debian are in the sid repos and debian testing is due to be freezed within a week? so would it be posible to get warzone moved to testing as I managed to fufill its dependanices entirly from testing and it has met the time citation, could be the architectures requirment slowing it?

some suggestions: better in game chat, at the moment the chat messages are very easy to miss and stay on the screen for a very breif moment of time. Also revamp rockets as minipods should be avilable soon after the first machine gun upgrades they are that weak.
Which video card do you got?

As for debian, there is a discussion about this on the ML, you may want to check what has been said:
https://mail.gna.org/public/warzone-dev ... index.html

For the chat, there is a small buffer, hit the ` key. (Key above the TAB key, and below the ESC key also has ~ on it on US keyboards)

Infidelus
Rookie
Rookie
Posts: 26
Joined: 02 Apr 2007, 13:41

Re: 2.1 Beta 4: Plays Beautifully!

Post by Infidelus » 27 Jul 2008, 17:45

I have to disagree with some of the posts about how beautifully beta 4 plays.

Me and a friend just upgraded to this version for a multiplayer game, and ... to be brutally honest, it's a huge step backwards in playability.

Eight player game, with me and him allied.

Everything worked lovely until the enemy came in with their vtol attacks (after about 15 minutes gameplay!!!), and then both mine and his trucks suddenly went on strike!

Didn't matter how many times we clicked on either the derricks (not on fire), or any other building, they just wouldn't build or repair them. If you clicked to move them, they seemed happy enough to do that, but ask them to repair or build something, and anyone would think they were on the picket line saying "no more repairs, no more repairs".

Back to beta 2 now for us, which worked a hell of a lot better.

Sorry to sound negative. You guys put in an awful lot of effort, and for the most part, the game is always an improvement with newer builds. Seems this build hasn't turned out quite so well (from our perspective anyway).

Per
Warzone 2100 Team Member
Warzone 2100 Team Member
Posts: 3775
Joined: 03 Aug 2006, 19:39

Re: 2.1 Beta 4: Plays Beautifully!

Post by Per » 27 Jul 2008, 19:11

Can you find a way that we can reproduce and thereby fix that bug?

Locked