Page 17 of 17

Re: MAC users, where are you guys?

PostPosted: 09 Oct 2008, 10:07
by EvilGuru
shishkebab wrote:Hi,

I'm glad to hear that the FMVs will work on macs! Great Job! I just have one small problem. Whenever I open a beta (one I compile myself or pre-built), I get the error listed in the mac compile guide on the wiki:
Code: Select all
dyld: Library not loaded: /usr/X11R6/lib/libfontconfig.1.dylib
 Referenced from: Warzone.app/Contents/MacOS/../Frameworks/QuesoGLC.framework/Versions/A/QuesoGLC
 Reason: image not found

However, the fix listed there does not help. I went to the folder, and the symlinks that the commands created are there, the only problem is that they do not link to anything. Is there something I am doing wrong, or did I skip a step somewhere? If you could help me out that would be great!

Thanks!

You need to install X11.app. This comes with 10.5 and can be found on the install CD of 10.4.

Regards, Freddie.

Re: MAC users, where are you guys?

PostPosted: 09 Oct 2008, 22:22
by shishkebab
Thank you! I thought I had installed X11 with the rest of the dev tools. I guess this explains why it works on my other laptop with X11. Thanks!

Re: MAC users, where are you guys?

PostPosted: 16 Oct 2008, 11:06
by twilight
hey everybody,

sorry that I have been away for a while, but yeah, new job, moving to another
area and stuff.

Anyway, I wanted to say that I still have the bug with the crazy ground-textures
on Tiger 10.4.11. But I figured out, with the new Beta, that when I change
the texture size to 32, then the bug is gone.

As soon as I go up to 64 or 128 the bug shows again.

Maybe that helps figuring that out?

Greetings

EDIT: Oh, yeah, and thx for the work you did :-) you are great!

Re: MAC users, where are you guys?

PostPosted: 16 Oct 2008, 18:19
by Kharos
I'm a mac user, it works fin for me, although the toolbar is a bit pixelated, compared with the glitchy version u can get off brothersoft.com. :)

Re: MAC users, where are you guys?

PostPosted: 16 Nov 2008, 09:51
by wz_macosx
Baum wrote:
Omikronman wrote:Line Location Tool:0: Command /Developer/usr/bin/gcc-4.0 failed with exit code 1
Line Location Tool:0: cycle in dylib re-exports with /Developer/SDKs/MacOSX10.4u.sdk/usr/X11R6/lib/libGL.dylib

If on Leopard, are you using Xcode 3.1?


I had this error in buidling QuesoGLC code, but this error can be avoided by adding the following to "Other Linker Flags" in the Linking section of the target:

Code: Select all
-dylib_file /System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib: /System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib


I happened to run across this problem the other day, and tried it out while downloading the updated xcode and the source built fine. 2.1_RC1 Leopard 10.5.5

Cheers

Re: MAC users, where are you guys?

PostPosted: 22 Nov 2008, 00:37
by WorkerB
I just wanted to relate that the hardest part for me was figuring out how to install X11. Once I did that, the Mac OS X Universal Binary worked fine.
I'm on an iMac G5 2.1 PPC 1GB ram ATI Radeon X600 XT

Only weird thing so far has been a random speedup while playing.

Re: MAC users, where are you guys?

PostPosted: 04 Aug 2010, 09:46
by digt
It has been a while since I played this game last and it's come a long way. I've played this game on a Core 2 Duo iMac, a Core 2 Duo MacBook Pro running OS 10.5.8 and it plays great compared to the last time I tried.

Kudos to everyone and especially the Mac devs.