Assert in Warzone: frameresource.c:525

Intended behaviour or bugs in other software.

Assert in Warzone: frameresource.c:525

Postby Haudrauf » 03 Sep 2006, 03:41

Warzone2100 Version
2.0.4 (built from source)

Operating System
Linux goten 2.6.16-gentoo-r3 #1 PREEMPT Fri Aug 18 18:14:43 CEST 2006 i686 AMD Athlon(tm) Processor GNU/Linux

Hardware Information
AMD Athlon Thunderbird 1200mhz, NVidia Geforce 2 GTS, 384mb ram

Warzone2100 Configuration
Standard? :)

Bug Description
Warzone taught me save often .. but then there's a higher possibility I get savegames which will only work 10 seconds and then crash. Here it is:
Code: Select all
(gdb) run
Starting program: /usr/local/bin/warzone2100 1024x768 --savegame hehe2.gam --fullscreen
[Thread debugging using libthread_db enabled]
[New Thread -1224562992 (LWP 30695)]
ALSA lib confmisc.c:670:(snd_func_card_driver) cannot find card '1'
ALSA lib conf.c:3479:(_snd_config_evaluate) function snd_func_card_driver returned error: No such device
ALSA lib confmisc.c:391:(snd_func_concat) error evaluating strings
ALSA lib conf.c:3479:(_snd_config_evaluate) function snd_func_concat returned error: No such device
ALSA lib confmisc.c:1070:(snd_func_refer) error evaluating name
ALSA lib conf.c:3479:(_snd_config_evaluate) function snd_func_refer returned error: No such device
ALSA lib conf.c:3947:(snd_config_expand) Evaluate error: No such device
ALSA lib pcm.c:2146:(snd_pcm_open_noupdate) Unknown PCM surround51:1,0
[New Thread -1270031440 (LWP 30698)]
error:      resGetDataFromHash: Unknown ID:
error:      Assert in Warzone: frameresource.c:525 : resGetDataFromHash (FALSE)
error:      resGetDataFromHash: Unknown ID:
error:      Assert in Warzone: frameresource.c:525 : resGetDataFromHash (FALSE)

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1270031440 (LWP 30698)]
0xb7ca1745 in alDistanceModel () from /usr/lib/libopenal.so.0
(gdb) Fatal signal: Segmentation Fault (SDL Parachute Deployed)
Terminated


I couldn't start backtracing since the screen was stuck when it hang. I needed to kill gdb.

Man I hope this isn't that possible OpenAL problem (my first bugreport: http://wz.rootzilla.de/forum/index.php?topic=71.0) again...
Attachments
hehe2.zip
(288.61 KiB) Downloaded 545 times
Last edited by Haudrauf on 03 Sep 2006, 03:47, edited 1 time in total.
Haudrauf
Greenhorn
 
Posts: 6
Joined: 27 Aug 2006, 15:31

Re: Assert in Warzone: frameresource.c:525

Postby Haudrauf » 03 Sep 2006, 03:55

After installing a different OpenAL version - with which WZ can't work and thus has no sound - it had no crash after loading the savegame and I could play on.

I think this issue is hard linked to the openal 0.0.8. Would be better to make it a dependency for a higher (hopefully fixed) version then.

And btw, create a --nosound parameter for the commandline please. Arf.
Haudrauf
Greenhorn
 
Posts: 6
Joined: 27 Aug 2006, 15:31

Re: Assert in Warzone: frameresource.c:525

Postby Haudrauf » 04 Sep 2006, 19:13

DevUrandom,

this prolly is the same problem with OpenAL having wrong output device setting in /etc/openalrc.

Though, I still suggest a --nosound parameter.
Haudrauf
Greenhorn
 
Posts: 6
Joined: 27 Aug 2006, 15:31

Re: Assert in Warzone: frameresource.c:525

Postby DevUrandom » 04 Sep 2006, 23:44

--nosound has been implemented in r322. ;)
User avatar
DevUrandom
Regular
Regular
 
Posts: 1690
Joined: 31 Jul 2006, 23:14


Return to Not a bug