Crash when scavenger solder shoot twice

Intended behaviour or bugs in other software.

Crash when scavenger solder shoot twice

Postby evadim » 11 Nov 2006, 21:00

Warzone2100 Version
Warzone2100 2.0.4 & 2.0.5-rc1

Operating System
System uname: 2.6.18-gentoo-r2 i686 Pentium III (Coppermine)
Gentoo Base System version 1.12.6
gcc-4.1.1, glibc-2.4-r4, 2.6.18-gentoo-r2 i686

Hardware Information
Radeon 9200 (RV280)

author:        Gareth Hughes, Keith Whitwell, others.
description:    ATI Radeon
license:        GPL and additional rights
vermagic:      2.6.18-gentoo-r2 mod_unload PENTIUMIII gcc-4.1
depends:        drm
parm:          no_wb:Disable AGP writeback for scratch registers
(int)
Xorg 7.1

Warzone2100 Configuration
config in attach

Bug Description
when scavenger solder shoot twice - segfault, i'm attach save - 1-2 min. play and look for it
Attachments
savegame.tar.gz
(102.83 KiB) Downloaded 492 times
config.txt
(465 Bytes) Downloaded 514 times
backtrace.txt
(2.46 KiB) Downloaded 499 times
Last edited by Kamaze on 22 Nov 2006, 10:29, edited 1 time in total.
evadim
New user
 
Posts: 4
Joined: 01 Oct 2006, 20:42

Re: Crash when scavenger solder shoot twice

Postby DevUrandom » 11 Nov 2006, 23:35

Could it be the same as http://wz2100.net/forum/index.php?topic=53.0 ?
What version of OpenAL are you using? (I thought the bug might have been fixed allready, maybe I am wrong...)
User avatar
DevUrandom
Regular
Regular
 
Posts: 1690
Joined: 31 Jul 2006, 23:14

Re: Crash when scavenger solder shoot twice

Postby evadim » 12 Nov 2006, 11:35

Thanks a lot & sorry for garbage post, simple upgrade from openal 0.0.8 to  0.0.8-r1 (gentoo) fix it.
evadim
New user
 
Posts: 4
Joined: 01 Oct 2006, 20:42

Re: [SOLVED] Crash when scavenger solder shoot twice

Postby DevUrandom » 12 Nov 2006, 15:11

Anytime...
User avatar
DevUrandom
Regular
Regular
 
Posts: 1690
Joined: 31 Jul 2006, 23:14


Return to Not a bug

cron