Page 1 of 1

Game Segfaults on Startup

PostPosted: 22 Oct 2006, 18:50
by POLAX
Warzone versions (2.0.4 and 2.0.5-rc1) segfault on startup right after opening a window or grabbing the full screen.

I am running it on Gentoo Linux with a 2.6.17 kernel, Pentium4 (no HT) Processor (82845 Intel Mainboard chipset), and ATI Radeon 9800Pro video card with the open-source R300 drivers.  Below is more detailed info and attached is an strace dump from when I run the game (it's actually just a gzipped file, not whatever I had to pretend to make it in order to be allowed to attach it):
physfs = 1.0.1
libmad = 0.15.1b
libjpeg (http://www.ijg.org) = 6b-r4
libogg = 1.1.2
libpng = 0.6.4
libsdl = 1.2.8-r1
libvorbis = 1.1.0
openal = 0.0.8
sdl-net = 1.2.5
glut = 1.0
opengl = 7.0

IMHO - The file extension restrictions for these posts is a brain-dead idea.

Re: Game Segfaults on Startup

PostPosted: 23 Oct 2006, 00:32
by evadim
I had a same problem,
solved:
emerge ati-drivers

run it in xterm & look error's

Re: Game Segfaults on Startup

PostPosted: 23 Oct 2006, 02:18
by POLAX
...I'm glad to know that worked for you and that you can confirm it's a driver issue.  However, that's hardly a solution unless games are your first priority in life and your computer is a dedicated "Warzone Gaming Platform".  I need open drivers to guarantee zero funny business, in other words I don't agree with ATI's TOS (Terms of Service) for those drivers.

At least we know that the issue is that the game doesn't work with the open and easier-to-debug with drivers so that needs to be addressed.  The driver info and version I'm using is:
parm:          no_wb:Disable AGP writeback for scratch registers
parmtype:      no_wb:int
author:        Gareth Hughes, Keith Whitwell, others.
description:    ATI Radeon
license:        GPL and additional rights
vermagic:      2.6.17-gentoo-r8-82845P4 mod_unload PENTIUM4 REGPARM gcc-3.4
depends:        drm

Xorg 7.1.1 radeon_drv version 4.2.0

Re: Game Segfaults on Startup

PostPosted: 23 Oct 2006, 12:00
by DevUrandom
Could you provide a backtrace? This might help...

Re: Game Segfaults on Startup

PostPosted: 24 Oct 2006, 02:35
by POLAX
DevUrandom wrote:Could you provide a backtrace? This might help...


The PDF file I attached on my original post is actually a gzipped text file (gz) with the backtrace.  Just rename it to warzone2100.strace.gz

Re: Game Segfaults on Startup

PostPosted: 24 Oct 2006, 13:42
by cybersphinx
That's an strace, not a backtrace. To get a backtrace, run Warzone (ideally a debug version) in gdb (in a terminal window):
Code: Select all
$ gdb warzone2100
> r --window --viewport 800x600
[windowed, because otherwise you can't get at the gdb window, and small enough to fit your screen windowed]
[crash]
> bt
> bt full

Re: Game Segfaults on Startup

PostPosted: 24 Oct 2006, 15:34
by Suprano
hm i think only 'bt full' is enough..

--Ano

Re: Game Segfaults on Startup

PostPosted: 11 Nov 2006, 21:05
by evadim
I'm back to open source radeon driver (old driver don't compile on kernel-2.6.18, new driver don't support my card (radeon 9200)) - game work fine.

Re: Game Segfaults on Startup

PostPosted: 22 Nov 2006, 10:42
by Kamaze
Looks solved.

--> Not a Bug.

Re: Game Segfaults on Startup

PostPosted: 09 May 2008, 16:42
by The Shu Dragon Sniper
This is completely offtopic, but are we allowed to post new threads? Because i have somje bugs i think id like to report...

Re: Game Segfaults on Startup

PostPosted: 13 May 2008, 07:29
by Buginator
The Shu Dragon Sniper wrote:This is completely offtopic, but are we allowed to post new threads? Because i have somje bugs i think id like to report...


please read this topic - http://forums.wz2100.net/?topic=691.0


That is your best bet.

I thought Kamaze locked this section.

Re: Game Segfaults on Startup

PostPosted: 13 May 2008, 08:45
by The Shu Dragon Sniper
kthxbai :D