Transport not arriving in Campaign 2 Mission 1

Bugs that have been fixed for or in a later version

Re: Campaign 2, Mission 1?

Postby ioamnesia » 24 Jan 2007, 01:35

Alright, I've tested and retested and found a solution... argh. If you go straight from Campaign 1 to campaign 2, the transport will not arrive. If you save the game in between campaign 1 and 2 and continue on, the transport will NOT arrive. If you try to load the saved game, there will be a runtime error. To save it effectively you must complete the last mission of campaign one, save, exit to menu and load, then the transport will arive. I have the saves for all possibilities if you want them. I also have saves for after C2M1 if you want to skip ahead. My tactic for winning without reinforcements is to hold the base long enough to get about 9 hover heavybody heavycannons and a repair station. Play conservatively, take out the southeast, then northwest then north. AND PRAY. hold the hardpoints at all cost.
ioamnesia
Rookie
Rookie
 
Posts: 16
Joined: 22 Jan 2007, 23:52

Re: Campaign 2, Mission 1?

Postby DevUrandom » 24 Jan 2007, 11:52

Ok, what I am interested in are those savegames where the transport does _not_ arrive. :)
You may also send all of them, but don't forget a description, so I know which savegame is at which place in the campaign.
Thanks!
User avatar
DevUrandom
Regular
Regular
 
Posts: 1690
Joined: 31 Jul 2006, 23:14

Re: Campaign 2, Mission 1?

Postby ioamnesia » 24 Jan 2007, 23:23

Alrighty, here they are :)

I know I save the games with wierd names, don't gimme crap lol.

Heres the rundown:
test3 is a save at the beginning of the last level of c1, load the transport and end of mission
inbetween is a save at the end of mission screen where you exit after you create it. It works and the timer will be there.
qxp2vuez is a save that is identical to inbetween except you hit continue game after creating it. It will cause a runtime error.
after2_1 is the save after 2.1 is completed and won.

Hope these help.

btw, I'm running windows, didn't mention that before
Attachments
saves.zip
(700.77 KiB) Downloaded 836 times
ioamnesia
Rookie
Rookie
 
Posts: 16
Joined: 22 Jan 2007, 23:52

Re: Campaign 2, Mission 1?

Postby DevUrandom » 25 Jan 2007, 00:22

Seems like a lot of those .bjo files are in the archive, but the actual .gam savegame is missing...
Could you give it another try and upload a complete archive?
User avatar
DevUrandom
Regular
Regular
 
Posts: 1690
Joined: 31 Jul 2006, 23:14

Re: Campaign 2, Mission 1?

Postby ioamnesia » 25 Jan 2007, 00:34

DOH! Here ya go.
Attachments
saves.zip
(702.46 KiB) Downloaded 824 times
ioamnesia
Rookie
Rookie
 
Posts: 16
Joined: 22 Jan 2007, 23:52

Re: Campaign 2, Mission 1?

Postby np » 26 Jan 2007, 01:56

Just to confirm the reported savegame behavior:

1. A save at the alpha transport load-up mini-mission doesn't work
2. A save on the first screen of the subsequent debriefing works
3. A save at beta base can't be made to work

By "work", I mean that if one reloads the save, either during a failed playthrough or in a fresh run of WZ, reinforcements will be available.

It is also worth noting that wrf-fix does not seem to be necessary (even on linux), so it seems the bouncycaps in the .wrf is, at least in this instance, a red herring.

Good news!  Now that there's a workaround, you don't have to fix it  ;)
np
New user
 
Posts: 5
Joined: 16 Jan 2007, 06:25

Re: Campaign 2, Mission 1?

Postby DevUrandom » 26 Jan 2007, 14:03

Yes, I can confirm the bug, too.
- test3 doesn't work
- inbetween works
- *2vuez crashes with this error:
error:      Unknown research - R-Vehicle-Body12

And this backtrace:
#0  0xb7f04410 in __kernel_vsyscall ()
No symbol table info available.
#1  0x45555540 in raise () from /lib/libc.so.6
No symbol table info available.
#2  0x45556c6e in abort () from /lib/libc.so.6
No symbol table info available.
#3  0x08143336 in getResearchIdFromName (pName=0xbf9097a4 "R-Vehicle-Body12") at game.c:6713
        inc = 192
#4  0x08144758 in loadSaveStructureV (pFileData=0xb5d43518 "A0ResearchFacility", filesize=10260, numStructures=42, version=33)
    at game.c:7466
        psSaveStructure = (SAVE_STRUCTURE *) 0xbf9096f4
        sSaveStructure = {
  name = "A0ResearchFacility\0001\202\225?~\233f\000\000\000\000ZNA1�E\202\225?\000\000\000\000\210�\207,DVoiE", id = 181016,
  x = 896, y = 6272, z = 14, direction = 0, player = 0, inFire = 0, burnStart = 0, burnDamage = 0, status = 1 '\001',
  currentBuildPts = 32767, body = 32767, armour = 19, resistance = 150, dummy1 = 0, subjectInc = 0, timeStarted = 31577739, output = 0,
  capacity = 0, quantity = 0, factoryInc = 1142884238, loopsPerformed = 202 '�, powerAccrued = 112, dummy2 = 257965276,
  droidTimeStarted = 1, timeToBuild = 0, timeStartHold = 0, visible = "\000\000\000\000\000",
  researchName = "R-Vehicle-Body12\000\a1\202\225?~\233f\000\000\000\000ZNA1�E\202\225?\000\000\000\000~��210\036,D�iE",
  currentPowerAccrued = 100, commandId = 257965276}
        psStructure = (STRUCTURE *) 0xb53a6d34
        psFactory = (FACTORY *) 0xb53aeeb8
        psResearch = (RESEARCH_FACILITY *) 0xb53aeeec
        psRepair = (REPAIR_FACILITY *) 0xb7ee7440
        psReArmPad = (REARM_PAD *) 0xb7edb394
        psStats = (STRUCTURE_STATS *) 0xb2b6ee28
---Type to continue, or q to quit---
        psModule = (STRUCTURE_STATS *) 0xb2b6eb6c
        capacity = 0
        count = 5
        statInc = 26
        found = 1
        NumberOfSkippedStructures = 0
        burnTime = 0
        i = 8
        sizeOfSaveStructure = 244
        researchId = 3050588964
        __FUNCTION__ = "loadSaveStructureV"
        __PRETTY_FUNCTION__ = "loadSaveStructureV"
#5  0x08142c42 in loadSaveStructure (pFileData=0xb5d43054 "A0ResourceExtractor", filesize=10260) at game.c:6447
        psHeader = (STRUCT_SAVEHEADER *) 0xb5d43048
#6  0x0813a48f in loadGame (pGameToLoad=0x82fc520 "savegame/cxp2vuez.gam", keepObjects=0, freeMem=1, UserSaveGame=1) at game.c:2319
        aFileName = "savegame/cxp2vuez\\struct.bjo\000o\000\000(\004�bKM_0002\000\000\000\000\000\000\000\000\000Manufacture\000 Display\000y\000ff\000iting\000e\000ause!\000\001\000\000\0008�#\203!\bCw\t�\000\000\000\000pCw\tpCw\t\000\000\000\000H��\024\bCw\t�202!\b\024\000\000\000\a@\034\b\000\000\000", '\0' , "�202!\b\000\000\000\000X\000\000\000\001\000\000\000\032\001\000\000F\024\000\000\003\000\000\000\0200\b4"...
        fileExten = 18
        fileSize = 10260
        pl = 143717208
        pFileData = 0xb5d43048 "stru!"
        player = 8
        inc = 9
---Type to continue, or q to quit---
        i = 8
        j = 8
        psCurr = (DROID *) 0x0
        missionScrollMinX = 0
        missionScrollMinY = 0
        missionScrollMaxX = 0
        missionScrollMaxY = 0
        __FUNCTION__ = "loadGame"
        __PRETTY_FUNCTION__ = "loadGame"
#7  0x080b824b in levLoadData (pName=0x82a12c0 "CAM_2A", pSaveName=0x82fc520 "savegame/cxp2vuez.gam", saveType=3) at levels.c:887
        psNewLevel = (LEVEL_DATASET *) 0x8a189c8
        psBaseData = (LEVEL_DATASET *) 0x8a18288
        psChangeLevel = (LEVEL_DATASET *) 0x8a18778
        i = 9
        psCurrHeap = (BLOCK_HEAP *) 0xbf909ae8
        bCamChangeSaveGame = 1
        __FUNCTION__ = "levLoadData"
        __PRETTY_FUNCTION__ = "levLoadData"
#8  0x0813d6c4 in gameLoadV (pFileData=0xb5d43050 "*", filesize=4060, version=33) at game.c:4102
        psSaveGame = (SAVE_GAME *) 0x8234040
        inc = 32 ' '
        i = 8
        j = 8
        sizeOfSaveGame = 4052
        player = 8
---Type to continue, or q to quit---
        date = "Jan 26 2007\000\000\000\000\000\000\020\000\000\b\000\000\000\000\000\000\000zE\000\000\000\000zE\000\000\000\000m�\000\000\000\000Y�003\000(\021eE \021eE\b\000\000\000\210\234\2208\021eE \021eE\001\000\000\000�017\000\000(\021eE \021eE$�E�017\000\000\213\020YEܬcE \021eE \001�b\213\020YE�dE \021eE\000S\b\213\020YE�dE \021eE\210\026\b\b\234\220LhE \021eE\210\026\b\001\000\000\000\210\026\b@t�b\000\000\000X\002\000\000\030\234\220 hE\210\234\220"...
        powerSaved = {{currentPower = 1983, extractedPower = 0}, {currentPower = 0, extractedPower = 0}, {currentPower = 0,
    extractedPower = 0}, {currentPower = 0, extractedPower = 0}, {currentPower = 0, extractedPower = 0}, {currentPower = 0,
    extractedPower = 0}, {currentPower = 0, extractedPower = 0}, {currentPower = 0, extractedPower = 0}}
        __FUNCTION__ = "gameLoadV"
        __PRETTY_FUNCTION__ = "gameLoadV"
#9  0x0813bb93 in gameLoad (pFileData=0xb5d43050 "*", filesize=4060) at game.c:3239
        psHeader = (GAME_SAVEHEADER *) 0xb5d43048
#10 0x081387fc in loadGameInit (pGameToLoad=0x82fc520 "savegame/cxp2vuez.gam") at game.c:1327
        pFileData = 0xb5d43048 "stru!"
        fileSize = 4060
#11 0x080bc5fc in main (argc=1, argv=0xbf909df4) at main.c:603
        frameRet = FRAME_OK
        quit = 0
        Restart = 1
        paused = 0
        bVidMem = 0
        dispBitDepth = 8
        introVideoControl = 3
        loopStatus = 0
        psPaletteBuffer = (iColour *) 0x0
        pSize = 768


To sum the transport problem up:
In CAM2_1 the transport will not arrive (nor will you get the transport-timeout) if you just continue from CAM1_*
If you reload a savegame made in between the missions, from the mission-accomplished-screen, after CAM1_* is finished, you will get the reinforcements.

I currently have no idea what the problem with test3 might be. If I should guess, then I'd say WZ is confused by the reloading of files required for CAM2, which makes it forget about the reinforcement settings...
Does anyone have more knowledge about those wrf files and what's going on in the background?
I guess the fix is not big, so I hope we can get it into 2.0.6...
Last edited by DevUrandom on 26 Jan 2007, 14:13, edited 1 time in total.
User avatar
DevUrandom
Regular
Regular
 
Posts: 1690
Joined: 31 Jul 2006, 23:14

Transport not arriving - Campaign 3 mission 1

Postby ioamnesia » 30 Jan 2007, 23:09

Whoo hoo, here we go again. confirmed it twice. If you complete C2M11 and continue on to C3M1, no transport and the level ends after 5 seconds with mission failed. If you save in between, and reload it, all is well. In between will work.  Before C2 End is saved right before the end, recycle all units to proceed and view bug.
Attachments
before c2 end.zip
(152.32 KiB) Downloaded 836 times
inbetween.zip
(141.77 KiB) Downloaded 886 times
ioamnesia
Rookie
Rookie
 
Posts: 16
Joined: 22 Jan 2007, 23:52

Re: [CONFIRMED] Transport not arriving in Campaign 2 Mission 1

Postby np » 31 Jan 2007, 07:23

Probably not useful information since it's undoubtedly the same bug, but campaign 3, mission 1 suffers from a similar problem.  It's slightly more unfriendly, in that you immediately fail the mission after starting it, presumably because you don't have any units.  Reloading from a save made immediately after the last mission of campaign 2 works.
np
New user
 
Posts: 5
Joined: 16 Jan 2007, 06:25

Re: [CONFIRMED] Transport not arriving in Campaign 2 Mission 1

Postby ioamnesia » 31 Jan 2007, 18:25

I have opened a separate bug thread with saves.
ioamnesia
Rookie
Rookie
 
Posts: 16
Joined: 22 Jan 2007, 23:52

Re: [CONFIRMED] Transport not arriving in Campaign 2 Mission 1

Postby DevUrandom » 31 Jan 2007, 20:47

Merged the other into this, as it is the same bug...

I found the cause for this:
[url=http://svn.gna.org/viewcvs/warzone/trunk/data/gamedesc.lev?rev=331&view=diff&r1=331&r2=330&p1=trunk/data/gamedesc.lev&p2=/trunk/data/gamedesc.lev]
r331: Possible fix for bug #5188 (Wrong tileset)[/url]

The problem with that change is that, if I revert it, the map looks like total crap, because the wrong texture is loaded.
Does anyone have an idea how this bug could be fixed while keeping the CAM_2/CAM_3 dataset for the CAM_2A mission?

This bug is fixed in r708/r709. Fix will be in 2.0.6.
Last edited by DevUrandom on 05 Feb 2007, 16:35, edited 1 time in total.
User avatar
DevUrandom
Regular
Regular
 
Posts: 1690
Joined: 31 Jul 2006, 23:14

Previous

Return to Fixed bugs