Page 1 of 2

Warzone 2100 Lobby question w/Poll!

Posted: 10 Mar 2019, 06:02
by vexed
Greetings fans, as we get closer and closer to releasing Warzone 2100 3.3.0, we have a issue that we need feedback on.

Right now, we basically allow multiple versions of the game to connect to the lobby.
The problem with that is, it fragments the community into basically 3 groups.

That means there are less of each group to play games with.

If we drop support for everything except the latest release, which will be 3.3.0, then everyone will have the same version of the game, and there will be lots more players available to play against.

So, I am just wondering what does everyone think of not allowing anything but the 3.3.0 Beta for a few weeks, so we can make sure everything is good on the multiplayer side of things?

Also note that we WILL be dropping *all* support for anything other than 3.3.0 when we do finally make a release.

Re: Warzone 2100 Lobby question w/Poll!

Posted: 10 Mar 2019, 07:35
by Prot
For my opinion that 3.1.5 is very different from 3.2++
And those players who play 3.1.5 before 3.3, not will be happy.
And force player to move from 3.1.5 is bad idea, that call only negative for developers.
I think is better way drop only 3.2 branch, because 3.2 and 3.3 is same, but 3.3 is very stable from 3.2.
But for now, drop all version except 3.3.0 for some time i think it's a good idea to see reaction of players and maybe more bugreports of 3.3.0.

Re: Warzone 2100 Lobby question w/Poll!

Posted: 10 Mar 2019, 11:34
by moltengear
I also dislike the idea of removing the 3.1.5 version.
Very important elements for the 3.3.0 version and also for the removal of the 3.1.5 version are not made.
It's true!
1) There is no spectator support.
2) The absence of more flexible settings for weapons and structures.
3) Ability to play at start with an open map
4) Selecting the balance of the original 1.10 version, 3.1.5 version, new version.

This would make life easier for those who create maps or mods.

Re: Warzone 2100 Lobby question w/Poll!

Posted: 10 Mar 2019, 11:47
by qwerty-man
I for one version. Players need to unite on one version. Then it will be easier to collect games.

Re: Warzone 2100 Lobby question w/Poll!

Posted: 10 Mar 2019, 11:57
by Forgon
Drop support for version 3.2, since we need to get over with it.
The latest Beta still contains no fixes for many of its problems, though.
Therefore, 3.1.5 should continue to be an option for players.

Older versions can be supported, too (why not?).

Re: Warzone 2100 Lobby question w/Poll!

Posted: 10 Mar 2019, 12:03
by moltengear
The mod could be made in such a way that it does not make hard settings. The mod simply makes the default settings, but the host could also correct some settings. This is possible if you make more flexible settings.

Re: Warzone 2100 Lobby question w/Poll!

Posted: 10 Mar 2019, 15:18
by xNEXTx
The situation of the game is tough.
Most players use version 3.1.5 only because of the weapon's balance of accuracy. This does not change, even if you remove only 3.2.3 version it will not change the situation. As was 2 "camps players" and 2 will remain. It is possible that most of 3.2.3 will go to 3.1.5. Why? The answer is simple - there are more people playing.
Even if done in the new version of the accuracy of weapons, as in 3.1.5 - people will not move to 3.3.0 version. What for? They are well there is an old and familiar better than something new and strange. Again, if everyone is playing a 2016 release game, then who will be testing and reporting bugs in the new versions?
Progress must move forward, but now only degradation is visible.
Only one version can survive.
And only you can decide what version it will be.

Re: Warzone 2100 Lobby question w/Poll!

Posted: 10 Mar 2019, 21:23
by Berg
xNEXTx wrote:
10 Mar 2019, 15:18
Progress must move forward, but now only degradation is visible.
Only one version can survive.
And only you can decide what version it will be.


One game to rule them all!

sorry I could not help myself.

Leave only 3.3.0beta1

Re: Warzone 2100 Lobby question w/Poll!

Posted: 11 Mar 2019, 02:18
by vexed
Prot wrote:
10 Mar 2019, 07:35
But for now, drop all version except 3.3.0 for some time i think it's a good idea to see reaction of players and maybe more bugreports of 3.3.0.
Starting today, that is what we are going to do.
If there are MP bugs (or campaign bugs or...) we need to know ASAP.

We rather do a official release of 3.3.0 with as few bugs as possible.

So, The lobby will only be hosting 3.3.0 beta games.

If you want to play any other version of Warzone online, you still can, just use join by IP for MP games.

Re: Warzone 2100 Lobby question w/Poll!

Posted: 11 Mar 2019, 12:04
by lamborgg
umm, why the heck would you even think of dropping support for 3.1.5?!?..

i've been using the 3.1.x versions for years now, i very much liked the 2.x.x series even better (back then) i had it on my old pc for years but then i lost the data as my pc died off and couldn't find the installer again.

i would rather drop 3.2.x support than the ever so popular 3.1.5.

3.1.5 is seriously the most popular, have you even seen how many downloads there is compared to 3.2.x versions??

Re: Warzone 2100 Lobby question w/Poll!

Posted: 11 Mar 2019, 13:41
by pastdue
The immediate situation is that we need help testing 3.3.0_beta1 to ensure the best possible 3.3.0 release. So please test it, report bugs (so we can fix them), and - ideally - we can end up with a 3.3.0 release that everyone can use (instead of a split multiplayer community).

Re: Warzone 2100 Lobby question w/Poll!

Posted: 11 Mar 2019, 17:46
by WZ2100ModsFAn
Dropping support for both versions can be a good idea for now.
3.2.x is unstable version good reason to drop support for this version.
3.1.x may never know if something bad happens for dropping support for this version.
Then maybe one day we will have 3.3.x as stable as 3.1.x
There will be some criticism for dropping support for 3.1.

Re: Warzone 2100 Lobby question w/Poll!

Posted: 11 Mar 2019, 17:49
by moltengear
I remember games that had quite a few bugs, but the players were so amazed at the game itself that they still played despite the bugs. So this new version was not perceived by the players. I will say frankly. From the players' point of view, 3.2.3 version is worse than 3.1.5.
3.3.0 version is actually 3.2.4.
And this new version is from developers for developers, not for players.
And we should not force ordinary players to test.
Instead of such an inscription from the server - "Download 3.3.0 beta, 3.1.5 & 3.2.3 are unsupported",
we could write so - "We need testing 3.2.4 beta, 3.2.3 are unsupported".

Re: Warzone 2100 Lobby question w/Poll!

Posted: 11 Mar 2019, 18:26
by WZ2100ModsFAn
moltengear wrote:
11 Mar 2019, 17:49
And this new version is from developers for developers, not for players.
I highly doubt that developers will not let anyone test this version.
It's a beta not a developer version.
And anyone is free to test the developer version.
Correct me if i'm wrong.

Re: Warzone 2100 Lobby question w/Poll!

Posted: 13 Mar 2019, 03:19
by _Mc_
Yes, you can already remove support for 3.1.5 and 3.2.3 .. I do not understand how people play it, because there is very low FPS in the battle, this is one of the reasons why it stopped playing in the version above 2.3.9 ..
I would not even ask if I closed the support, as the game has undergone positive changes. This is stability and balance
(thanks google translate, I hope you understand me)