Help needed testing 3.2.x Campaign games!

The projects speaking tube.
Add your two cents if you want to.

Re: Help needed testing 3.2.x Campaign games!

Postby Bethrezen » 15 Aug 2017, 18:10

It scales on all difficulties. Bugs in insane are still bugs in easy. You can just use the mod I posted a few posts above until buildbot is working


The reason I ask is because I noticed when I put it on easy briefly that you actually start with less power on easy on alpha 1 then you do on insane

On easy you start with 884 but on insane you start with 3250 which is why I was wondering if the scaling only applied to insane for now since one would assume that you would start with more power on easy then you would on insane.
Bethrezen
Trained
Trained
 
Posts: 438
Joined: 25 Sep 2009, 02:05

Re: Help needed testing 3.2.x Campaign games!

Postby Berserk Cyborg » 15 Aug 2017, 18:29

Fixed. I must have forgot about that mission when I later went to undo the scaling with starting power.

Edit: Seeing as I have the cam3-2 scripts basically finished, I will push the fix along with the new conversion shortly.
User avatar
Berserk Cyborg
Code contributor
Code contributor
 
Posts: 476
Joined: 26 Sep 2016, 19:56

Re: Help needed testing 3.2.x Campaign games!

Postby alfred007 » 15 Aug 2017, 21:23

Started testing again with master 88c1e9c.
Alpha1-4 looks good, also no problems with saved games. Again some info messages in the logs of the away-missions with no influence in gameplay. Last log is from quitting and restarting the game and testing some saved games.
At the beginning of alpha 4 there is no sound, that reinforcements are enabled, like you get in other away-missions. Saved game is added, just start the transporter and listen to .... nothing.
When you upgrade your power generator during alpha 2 with the power module the first video in alpha 3 is skipped. You just see the second video.
What I think about is, that you should research the power module just in alpha 3 and not in alpha 2 like it is with cobra body in alpha 8/9 or command turret in alpha 5/6. So what do you think about giving a 5 minute timer at the beginning of alpha 3 for researching the power module and upgrading the power generator and then reset the timer to the original 15 minutes for the away mission in alpha 3? That would be secure, that the first video is played and would make power management a bit tighter, because that you can't upgrade your power generator in alpha 2 means you get less energy.
Attachments
logs alpha 1-4.zip
(69.58 KiB) Downloaded 23 times
alfred007
Trained
Trained
 
Posts: 256
Joined: 31 Jul 2016, 06:25
Location: Germany

Re: Help needed testing 3.2.x Campaign games!

Postby Bethrezen » 15 Aug 2017, 21:28

Ok so just updated to the latest master
warzone2100-master-20170815-101215-88c1e9c.exe (15-Aug-2017)

Here are the results so far

Alpha 01, Alpha 02, Alpha 03, Alpha 04

These all seem fine

Alpha 05
I'm getting some errors here's the log

Code: Select all
     --- Starting log [C:\Documents and Settings\<user name>\Desktop\Warzone 2100_portable-master\Warzone 2100 master\logs\WZlog-0815_172107.txt]---
    info    |05:55:06: [triggerEventSeen:1287] Scripts not initialized yet
    info    |05:55:06: [triggerEventSeen:1287] Assert in Warzone: qtscript.cpp:1287 (scriptsReady), last script event: 'N/A'
    info    |05:55:06: [triggerEventSeen:1287] Scripts not initialized yet
    info    |05:55:06: [triggerEventSeen:1287] Assert in Warzone: qtscript.cpp:1287 (scriptsReady), last script event: 'N/A'
    info    |05:55:07: [mapTile:431] mapTile: x value is too big (45,23) in 44x93
    info    |05:55:07: [mapTile:431] Assert in Warzone: map.h:431 (x < mapWidth + 1), last script event: 'N/A'
    info    |05:55:07: [mapTile:431] mapTile: x value is too big (45,24) in 44x93
    info    |05:55:07: [mapTile:431] Assert in Warzone: map.h:431 (x < mapWidth + 1), last script event: 'N/A'
    info    |05:55:07: [mapTile:431] mapTile: x value is too big (46,23) in 44x93
    info    |05:55:07: [mapTile:431] Assert in Warzone: map.h:431 (x < mapWidth + 1), last script event: 'N/A'
    info    |05:55:07: [mapTile:431] mapTile: x value is too big (46,24) in 44x93
    info    |05:55:07: [mapTile:431] Assert in Warzone: map.h:431 (x < mapWidth + 1), last script event: 'N/A'
    info    |05:55:07: [mapTile:431] mapTile: x value is too big (47,23) in 44x93
    info    |05:55:07: [mapTile:431] Assert in Warzone: map.h:431 (x < mapWidth + 1), last script event: 'N/A'
    info    |05:55:07: [mapTile:431] mapTile: x value is too big (47,24) in 44x93
    info    |05:55:07: [mapTile:431] Assert in Warzone: map.h:431 (x < mapWidth + 1), last script event: 'N/A'
    info    |05:55:07: [mapTile:431] mapTile: x value is too big (48,23) in 44x93
    info    |05:55:07: [mapTile:431] Assert in Warzone: map.h:431 (x < mapWidth + 1), last script event: 'N/A'
    info    |05:55:07: [mapTile:431] mapTile: x value is too big (48,24) in 44x93
    info    |05:55:07: [mapTile:431] Assert in Warzone: map.h:431 (x < mapWidth + 1), last script event: 'N/A'
    info    |05:55:07: [mapTile:431] mapTile: x value is too big (49,23) in 44x93
    info    |05:55:07: [mapTile:431] Assert in Warzone: map.h:431 (x < mapWidth + 1), last script event: 'N/A'
    info    |05:55:07: [mapTile:431] mapTile: x value is too big (49,24) in 44x93
    info    |05:55:07: [mapTile:431] Assert in Warzone: map.h:431 (x < mapWidth + 1), last script event: 'N/A'
    info    |05:55:07: [mapTile:431] mapTile: x value is too big (50,23) in 44x93
    info    |05:55:07: [mapTile:431] Assert in Warzone: map.h:431 (x < mapWidth + 1), last script event: 'N/A'
    info    |05:55:07: [mapTile:431] mapTile: x value is too big (50,24) in 44x93
    info    |05:55:07: [mapTile:431] Assert in Warzone: map.h:431 (x < mapWidth + 1), last script event: 'N/A'
    info    |05:57:04: [mapTile:431] mapTile: x value is too big (45,23) in 44x93
    info    |05:57:04: [mapTile:431] Assert in Warzone: map.h:431 (x < mapWidth + 1), last script event: 'N/A'
    info    |05:57:04: [mapTile:431] mapTile: x value is too big (45,24) in 44x93
    info    |05:57:04: [mapTile:431] Assert in Warzone: map.h:431 (x < mapWidth + 1), last script event: 'N/A'
    info    |05:57:04: [mapTile:431] mapTile: x value is too big (46,23) in 44x93
    info    |05:57:04: [mapTile:431] Assert in Warzone: map.h:431 (x < mapWidth + 1), last script event: 'N/A'
    info    |05:57:04: [mapTile:431] mapTile: x value is too big (46,24) in 44x93
    info    |05:57:04: [mapTile:431] Assert in Warzone: map.h:431 (x < mapWidth + 1), last script event: 'N/A'
    info    |05:57:04: [mapTile:431] mapTile: x value is too big (47,23) in 44x93
    info    |05:57:04: [mapTile:431] Assert in Warzone: map.h:431 (x < mapWidth + 1), last script event: 'N/A'
    info    |05:57:04: [mapTile:431] mapTile: x value is too big (47,24) in 44x93
    info    |05:57:04: [mapTile:431] Assert in Warzone: map.h:431 (x < mapWidth + 1), last script event: 'N/A'
    info    |05:57:04: [mapTile:431] mapTile: x value is too big (48,23) in 44x93
    info    |05:57:04: [mapTile:431] Assert in Warzone: map.h:431 (x < mapWidth + 1), last script event: 'N/A'
    info    |05:57:04: [mapTile:431] mapTile: x value is too big (48,24) in 44x93
    info    |05:57:04: [mapTile:431] Assert in Warzone: map.h:431 (x < mapWidth + 1), last script event: 'N/A'
    info    |05:57:04: [mapTile:431] mapTile: x value is too big (49,23) in 44x93
    info    |05:57:04: [mapTile:431] Assert in Warzone: map.h:431 (x < mapWidth + 1), last script event: 'N/A'
    info    |05:57:04: [mapTile:431] mapTile: x value is too big (49,24) in 44x93
    info    |05:57:04: [mapTile:431] Assert in Warzone: map.h:431 (x < mapWidth + 1), last script event: 'N/A'
    info    |05:57:04: [mapTile:431] mapTile: x value is too big (50,23) in 44x93
    info    |05:57:04: [mapTile:431] Assert in Warzone: map.h:431 (x < mapWidth + 1), last script event: 'N/A'
    info    |05:57:04: [mapTile:431] mapTile: x value is too big (50,24) in 44x93
    info    |05:57:04: [mapTile:431] Assert in Warzone: map.h:431 (x < mapWidth + 1), last script event: 'N/A'
    info    |06:03:05: [triggerEventSeen:1287] Scripts not initialized yet
    info    |06:03:05: [triggerEventSeen:1287] Assert in Warzone: qtscript.cpp:1287 (scriptsReady), last script event: 'N/A'
    info    |06:03:05: [triggerEventSeen:1287] Scripts not initialized yet
    info    |06:03:05: [triggerEventSeen:1287] Assert in Warzone: qtscript.cpp:1287 (scriptsReady), last script event: 'N/A'
    info    |06:16:08: [loadLabels:980] Unit 57 belonging to player 7 not found from label group_1
    info    |06:16:08: [loadLabels:980] Assert in Warzone: qtscriptfuncs.cpp:980 (psObj), last script event: '<none>'
    info    |06:16:08: [loadLabels:980] Unit 66 belonging to player 7 not found from label group_1
    info    |06:16:08: [loadLabels:980] Assert in Warzone: qtscriptfuncs.cpp:980 (psObj), last script event: '<none>'
    info    |06:16:08: [loadLabels:980] Unit 67 belonging to player 7 not found from label group_1
    info    |06:16:08: [loadLabels:980] Assert in Warzone: qtscriptfuncs.cpp:980 (psObj), last script event: '<none>'
    info    |06:16:08: [loadLabels:980] Unit 68 belonging to player 7 not found from label group_1
    info    |06:16:08: [loadLabels:980] Assert in Warzone: qtscriptfuncs.cpp:980 (psObj), last script event: '<none>'
    info    |06:16:08: [loadLabels:980] Unit 225 belonging to player 7 not found from label group_2
    info    |06:16:08: [loadLabels:980] Assert in Warzone: qtscriptfuncs.cpp:980 (psObj), last script event: '<none>'
    info    |06:16:08: [loadLabels:980] Unit 227 belonging to player 7 not found from label group_2
    info    |06:16:08: [loadLabels:980] Assert in Warzone: qtscriptfuncs.cpp:980 (psObj), last script event: '<none>'
    info    |06:16:08: [loadLabels:980] Unit 235 belonging to player 7 not found from label group_2
    info    |06:16:08: [loadLabels:980] Assert in Warzone: qtscriptfuncs.cpp:980 (psObj), last script event: '<none>'
    info    |06:16:08: [loadLabels:980] Unit 279 belonging to player 7 not found from label group_2
    info    |06:16:08: [loadLabels:980] Assert in Warzone: qtscriptfuncs.cpp:980 (psObj), last script event: '<none>'
    info    |06:16:08: [loadLabels:980] Unit 280 belonging to player 7 not found from label group_2
    info    |06:16:08: [loadLabels:980] Assert in Warzone: qtscriptfuncs.cpp:980 (psObj), last script event: '<none>'
    info    |06:16:08: [loadLabels:980] Unit 281 belonging to player 7 not found from label group_2
    info    |06:16:08: [loadLabels:980] Assert in Warzone: qtscriptfuncs.cpp:980 (psObj), last script event: '<none>'
    info    |06:16:08: [loadLabels:980] Unit 282 belonging to player 7 not found from label group_2
    info    |06:16:08: [loadLabels:980] Assert in Warzone: qtscriptfuncs.cpp:980 (psObj), last script event: '<none>'
    info    |06:16:08: [loadLabels:980] Unit 340 belonging to player 7 not found from label group_3
    info    |06:16:08: [loadLabels:980] Assert in Warzone: qtscriptfuncs.cpp:980 (psObj), last script event: '<none>'
    info    |06:16:13: [removeFromGroup:430] Bad group count in group -2 (was 0)
    info    |06:16:13: [removeFromGroup:430] Assert in Warzone: qtscriptfuncs.cpp:430 (newValue >= 0), last script event: '<none>'
    info    |06:16:13: [removeFromGroup:430] Bad group count in group -2 (was 0)
    info    |06:16:13: [removeFromGroup:430] Assert in Warzone: qtscriptfuncs.cpp:430 (newValue >= 0), last script event: '<none>'
    info    |06:26:26: [loadLabels:980] Unit 57 belonging to player 7 not found from label group_1
    info    |06:26:26: [loadLabels:980] Assert in Warzone: qtscriptfuncs.cpp:980 (psObj), last script event: '<none>'
    info    |06:26:26: [loadLabels:980] Unit 66 belonging to player 7 not found from label group_1
    info    |06:26:26: [loadLabels:980] Assert in Warzone: qtscriptfuncs.cpp:980 (psObj), last script event: '<none>'
    info    |06:26:26: [loadLabels:980] Unit 67 belonging to player 7 not found from label group_1
    info    |06:26:26: [loadLabels:980] Assert in Warzone: qtscriptfuncs.cpp:980 (psObj), last script event: '<none>'
    info    |06:26:26: [loadLabels:980] Unit 68 belonging to player 7 not found from label group_1
    info    |06:26:26: [loadLabels:980] Assert in Warzone: qtscriptfuncs.cpp:980 (psObj), last script event: '<none>'
    info    |06:26:26: [loadLabels:980] Unit 225 belonging to player 7 not found from label group_2
    info    |06:26:26: [loadLabels:980] Assert in Warzone: qtscriptfuncs.cpp:980 (psObj), last script event: '<none>'
    info    |06:26:26: [loadLabels:980] Unit 227 belonging to player 7 not found from label group_2
    info    |06:26:26: [loadLabels:980] Assert in Warzone: qtscriptfuncs.cpp:980 (psObj), last script event: '<none>'
    info    |06:26:26: [loadLabels:980] Unit 235 belonging to player 7 not found from label group_2
    info    |06:26:26: [loadLabels:980] Assert in Warzone: qtscriptfuncs.cpp:980 (psObj), last script event: '<none>'
    info    |06:26:26: [loadLabels:980] Unit 279 belonging to player 7 not found from label group_2
    info    |06:26:26: [loadLabels:980] Assert in Warzone: qtscriptfuncs.cpp:980 (psObj), last script event: '<none>'
    info    |06:26:26: [loadLabels:980] Unit 280 belonging to player 7 not found from label group_2
    info    |06:26:26: [loadLabels:980] Assert in Warzone: qtscriptfuncs.cpp:980 (psObj), last script event: '<none>'
    info    |06:26:26: [loadLabels:980] Unit 281 belonging to player 7 not found from label group_2
    info    |06:26:26: [loadLabels:980] Assert in Warzone: qtscriptfuncs.cpp:980 (psObj), last script event: '<none>'
    info    |06:26:26: [loadLabels:980] Unit 282 belonging to player 7 not found from label group_2
    info    |06:26:26: [loadLabels:980] Assert in Warzone: qtscriptfuncs.cpp:980 (psObj), last script event: '<none>'
    info    |06:26:26: [loadLabels:980] Unit 340 belonging to player 7 not found from label group_3
    info    |06:26:26: [loadLabels:980] Assert in Warzone: qtscriptfuncs.cpp:980 (psObj), last script event: '<none>'
    info    |06:28:31: [removeFromGroup:430] Bad group count in group -2 (was 0)
    info    |06:28:31: [removeFromGroup:430] Assert in Warzone: qtscriptfuncs.cpp:430 (newValue >= 0), last script event: '<none>'
    info    |06:28:31: [removeFromGroup:430] Bad group count in group -2 (was 0)
    info    |06:28:31: [removeFromGroup:430] Assert in Warzone: qtscriptfuncs.cpp:430 (newValue >= 0), last script event: '<none>'
    info    |06:38:16: [triggerEventSeen:1287] Scripts not initialized yet
    info    |06:38:16: [triggerEventSeen:1287] Assert in Warzone: qtscript.cpp:1287 (scriptsReady), last script event: 'N/A'
    info    |06:38:16: [triggerEventSeen:1287] Scripts not initialized yet
    info    |06:38:16: [triggerEventSeen:1287] Assert in Warzone: qtscript.cpp:1287 (scriptsReady), last script event: 'N/A'
    error   |07:08:31: [js_hackRemoveMessage:4035] cannot find message - C1-3_BASE1
    error   |07:08:33: [js_removeObject:2357] Object id 164681 not found belonging to player 12
    error   |07:08:33: [callFunction:209] 0 : camSafeRemoveObject(obj = [object Object]) at script/campaign/libcampaign.js:138
    error   |07:08:33: [callFunction:209] 1 : __camPickupArtifact(artifact = [object Object]) at script/campaign/libcampaign.js:709
    error   |07:08:33: [callFunction:209] 2 : cam_eventPickup(feature = [object Object], droid = [object Object]) at script/campaign/libcampaign.js:2766
    error   |07:08:33: [callFunction:209] 3 : <global>() at -1
    info    |07:08:33: [callFunction:212] Uncaught exception calling function "cam_eventPickup" at line 138: ReferenceError: psObj failed in js_removeObject at line 2357
    info    |07:08:33: [callFunction:212] Assert in Warzone: qtscript.cpp:212 (false), last script event: 'N/A'


Code: Select all
--- Starting log [C:\Documents and Settings\<user name>\Desktop\Warzone 2100_portable-master\Warzone 2100 master\logs\WZlog-0815_201006.txt]---
error   |08:16:00: [recvStructureInfo:349] Could not find structure 270 to change production for
Bethrezen
Trained
Trained
 
Posts: 438
Joined: 25 Sep 2009, 02:05

Re: Help needed testing 3.2.x Campaign games!

Postby Berserk Cyborg » 15 Aug 2017, 22:21

alfred007 wrote:At the beginning of alpha 4 there is no sound, that reinforcements are enabled, like you get in other away-missions. Saved game is added, just start the transporter and listen to .... nothing.
Works for me. There is a ticket about this happening sometimes (perhaps related to loading mods from a savegame?). Remove the updated-campaign mod since the buildbot is working again.

alfred007 wrote:When you upgrade your power generator during alpha 2 with the power module the first video in alpha 3 is skipped. You just see the second video.
Intentional behavior in the original script. Not much use telling the player to upgrade the power generator if they already did.

Bethrezen wrote:
Code: Select all
    error   |07:08:31: [js_hackRemoveMessage:4035] cannot find message - C1-3_BASE1
    error   |07:08:33: [js_removeObject:2357] Object id 164681 not found belonging to player 12
    error   |07:08:33: [callFunction:209] 0 : camSafeRemoveObject(obj = [object Object]) at script/campaign/libcampaign.js:138
    error   |07:08:33: [callFunction:209] 1 : __camPickupArtifact(artifact = [object Object]) at script/campaign/libcampaign.js:709
    error   |07:08:33: [callFunction:209] 2 : cam_eventPickup(feature = [object Object], droid = [object Object]) at script/campaign/libcampaign.js:2766
    error   |07:08:33: [callFunction:209] 3 : <global>() at -1
    info    |07:08:33: [callFunction:212] Uncaught exception calling function "cam_eventPickup" at line 138: ReferenceError: psObj failed in js_removeObject at line 2357
    info    |07:08:33: [callFunction:212] Assert in Warzone: qtscript.cpp:212 (false), last script event: 'N/A'


Still looking into this. Probably related to saving and not picking up a dropped artifact.

Edit: Pushed the newly converted 3-2(s) scripts along with the power fix in the first Alpha mission.
User avatar
Berserk Cyborg
Code contributor
Code contributor
 
Posts: 476
Joined: 26 Sep 2016, 19:56

Re: Help needed testing 3.2.x Campaign games!

Postby Bethrezen » 16 Aug 2017, 04:02

What I think about is, that you should research the power module just in alpha 3 and not in alpha 2 like it is with cobra body in alpha 8/9 or command turret in alpha 5/6. So what do you think about giving a 5 minute timer at the beginning of alpha 3 for researching the power module and upgrading the power generator and then reset the timer to the original 15 minutes for the away mission in alpha 3?


I get the distinct impression what you are describing may well have been the way this was designed originally but after testing pumpkin ultimately decided that this would be an unnecessary annoyance to players so they change it to the way it was where the vid would only play if you forgot to build the power module and personally I'm of the same opinion, this is an unnecessary annoyance, that fails to achieve the stated aim therefore it's probably better to just leave it the way it was.
Bethrezen
Trained
Trained
 
Posts: 438
Joined: 25 Sep 2009, 02:05

Re: Help needed testing 3.2.x Campaign games!

Postby alfred007 » 16 Aug 2017, 15:19

alfred007 wrote: At the beginning of alpha 4 there is no sound, that reinforcements are enabled, like you get in other away-missions. Saved game is added, just start the transporter and listen to .... nothing.

Berserk Cyborg wrote:Works for me. There is a ticket about this happening sometimes (perhaps related to loading mods from a savegame?). Remove the updated-campaign mod since the buildbot is working again.


Is still not working for me. I updated to master 70b6cda, deleted the mod and started a new game on easy. I played fast through till alpha 4 and still no sound. I looked in the code of the stages and found that in away-missions the following order is coded for the call that reinforcements are enabled.

playSound("pcv440.ogg"); // Reinforcements are available. (for example line 158 of cam1-7.js)

This code does not exist in cam1-2.js
alfred007
Trained
Trained
 
Posts: 256
Joined: 31 Jul 2016, 06:25
Location: Germany

Re: Help needed testing 3.2.x Campaign games!

Postby alfred007 » 16 Aug 2017, 16:13

I found a bug in alpha 5. I reloaded a saved game where I already have left my base. When I attacked the scavenger base no reinforcements were enabled. When I reload a saved game where I was still in my homebase everything works fine. Logs and saved games are added.
Attachments
Bug alpha 5.zip
(270.61 KiB) Downloaded 26 times
alfred007
Trained
Trained
 
Posts: 256
Joined: 31 Jul 2016, 06:25
Location: Germany

Re: Help needed testing 3.2.x Campaign games!

Postby Berserk Cyborg » 16 Aug 2017, 18:08

alfred007 wrote:Is still not working for me. I updated to master 70b6cda, deleted the mod and started a new game on easy. I played fast through till alpha 4 and still no sound. I looked in the code of the stages and found that in away-missions the following order is coded for the call that reinforcements are enabled.
I see, I thought you were talking about the music. Fixed.

Huh, looks like enemy base detection fails after save-load for some reason (seeing the scavenger base should enable reinforcements). Despite that, reinforcements still come when you get closer to the NP base.
User avatar
Berserk Cyborg
Code contributor
Code contributor
 
Posts: 476
Joined: 26 Sep 2016, 19:56

Re: Help needed testing 3.2.x Campaign games!

Postby Bethrezen » 16 Aug 2017, 20:37

Ok so just updated to the latest master
warzone2100-master-20170816-013952-70b6dca.exe (16 Aug 2017)

Here are the results so far

Alpha 01, Alpha 02, Alpha 03, Alpha 04

These seem fine

Alpha 05

This seemed fine though i did note some odd behaviour from the enemy commander, where normally the commander and a group of attached units would come out of the base and attack you as soon as you approach the base, for some reason this time the commander didn't seem to want to come out and instead as soon as the computers units took a couple of hits they would run away, is that a deliberate change or is the enemy commander simply malfunctioning ?

i was also getting some bad group count notifications, here's the log

Code: Select all
--- Starting log [C:\Documents and Settings\<user name>\Desktop\Warzone 2100_portable-master\Warzone 2100 master\logs\WZlog-0816_182211.txt]---
info    |06:40:39: [removeFromGroup:430] Bad group count in group -1 (was 0)
info    |06:40:39: [removeFromGroup:430] Assert in Warzone: qtscriptfuncs.cpp:430 (newValue >= 0), last script event: 'N/A'
info    |06:40:43: [removeFromGroup:430] Bad group count in group -1 (was -1)
info    |06:40:43: [removeFromGroup:430] Assert in Warzone: qtscriptfuncs.cpp:430 (newValue >= 0), last script event: 'N/A'
info    |06:40:47: [removeFromGroup:430] Bad group count in group -1 (was -2)
info    |06:40:47: [removeFromGroup:430] Assert in Warzone: qtscriptfuncs.cpp:430 (newValue >= 0), last script event: 'N/A'
info    |06:41:04: [removeFromGroup:430] Bad group count in group -1 (was -3)
info    |06:41:04: [removeFromGroup:430] Assert in Warzone: qtscriptfuncs.cpp:430 (newValue >= 0), last script event: 'N/A'
info    |06:53:44: [removeFromGroup:430] Bad group count in group -1 (was 0)
info    |06:53:44: [removeFromGroup:430] Assert in Warzone: qtscriptfuncs.cpp:430 (newValue >= 0), last script event: 'N/A'
info    |06:54:46: [removeFromGroup:430] Bad group count in group -1 (was 0)
info    |06:54:46: [removeFromGroup:430] Assert in Warzone: qtscriptfuncs.cpp:430 (newValue >= 0), last script event: 'N/A'
info    |06:54:55: [removeFromGroup:430] Bad group count in group -1 (was -1)
info    |06:54:55: [removeFromGroup:430] Assert in Warzone: qtscriptfuncs.cpp:430 (newValue >= 0), last script event: 'N/A'
info    |06:54:56: [removeFromGroup:430] Bad group count in group -1 (was -2)
info    |06:54:56: [removeFromGroup:430] Assert in Warzone: qtscriptfuncs.cpp:430 (newValue >= 0), last script event: 'N/A'
info    |06:54:59: [removeFromGroup:430] Bad group count in group -1 (was -3)
info    |06:54:59: [removeFromGroup:430] Assert in Warzone: qtscriptfuncs.cpp:430 (newValue >= 0), last script event: 'N/A'
info    |07:07:51: [removeFromGroup:430] Bad group count in group -1 (was 0)
info    |07:07:51: [removeFromGroup:430] Assert in Warzone: qtscriptfuncs.cpp:430 (newValue >= 0), last script event: 'N/A'
info    |07:16:36: [removeFromGroup:430] Bad group count in group -1 (was 0)
info    |07:16:36: [removeFromGroup:430] Assert in Warzone: qtscriptfuncs.cpp:430 (newValue >= 0), last script event: 'N/A'
info    |07:16:38: [removeFromGroup:430] Bad group count in group -1 (was -1)
info    |07:16:38: [removeFromGroup:430] Assert in Warzone: qtscriptfuncs.cpp:430 (newValue >= 0), last script event: 'N/A'
info    |07:16:39: [removeFromGroup:430] Bad group count in group -1 (was -2)
info    |07:16:39: [removeFromGroup:430] Assert in Warzone: qtscriptfuncs.cpp:430 (newValue >= 0), last script event: 'N/A'
info    |07:16:52: [removeFromGroup:430] Bad group count in group -1 (was -3)
info    |07:16:52: [removeFromGroup:430] Assert in Warzone: qtscriptfuncs.cpp:430 (newValue >= 0), last script event: 'N/A'
Bethrezen
Trained
Trained
 
Posts: 438
Joined: 25 Sep 2009, 02:05

Re: Help needed testing 3.2.x Campaign games!

Postby alfred007 » 16 Aug 2017, 21:14

In alpha 6 the NP reinforcement time is independent of difficulty. Is this wanted or a fault?
alfred007
Trained
Trained
 
Posts: 256
Joined: 31 Jul 2016, 06:25
Location: Germany

Re: Help needed testing 3.2.x Campaign games!

Postby Berserk Cyborg » 16 Aug 2017, 21:47

Bethrezen wrote:This seemed fine though i did note some odd behaviour from the enemy commander, where normally the commander and a group of attached units would come out of the base and attack you as soon as you approach the base, for some reason this time the commander didn't seem to want to come out and instead as soon as the computers units took a couple of hits they would run away, is that a deliberate change or is the enemy commander simply malfunctioning?

i was also getting some bad group count notifications, here's the log
They do attack. That group is told to be defensive and only will attack when something the New Paradigm owns is attacked or you get too close to the defense area. I also stopped that group notification stuff by using an area label instead of a group label. It's a source side problem really.

alfredd007 wrote:In alpha 6 the NP reinforcement time is independent of difficulty. Is this wanted or a fault?
Will change it.

Edit:
It appears that the events for eventObjectSeen() and eventGroupSeen() are not being caught after load. Explains why base detection does not work after saveload in the campaign library. I need to investigate this some more.
User avatar
Berserk Cyborg
Code contributor
Code contributor
 
Posts: 476
Joined: 26 Sep 2016, 19:56

Re: Help needed testing 3.2.x Campaign games!

Postby Bethrezen » 17 Aug 2017, 14:00

Alpha 06

While this level seems to play normally there is something weird going on because it wont end, despite the fact that I've destroyed everything, i confirmed this by reloading and putting on the deity cheat to reveal the map so i could make sure i didn't missed anything.

I've attached a save that has about 1 minute left on the clock all you need to is take the squad of lancers up on the ridge south a little and destroy the last 2 turrets, while you are doing this another drop ship should fly in so you will have to kill them to but after that the level should end but it doesn't

Also i did get one error here's the log.

Code: Select all
--- Starting log [C:\Documents and Settings\<user name>\Desktop\Warzone 2100_portable-master\Warzone 2100 master\logs\WZlog-0817_112631.txt]---
error   |12:28:25: [js_hackRemoveMessage:4035] cannot find message - C1C_LZ1
Attachments
Alpha 06 end.7z
(59.21 KiB) Downloaded 27 times
Bethrezen
Trained
Trained
 
Posts: 438
Joined: 25 Sep 2009, 02:05

Re: Help needed testing 3.2.x Campaign games!

Postby alfred007 » 17 Aug 2017, 15:58

Ready with testing alpha 5-7

Alpha 5
Except the reported bug everything runs normal. The NP was very defensive like it was with Bethrezen . After the video they attacked me once and then no more. Even when I attacked them with artillery they did not attack me until I tried to build a sensor near their base. It is a little bit too defensive in my opinion. And I think they were more agressive in 3.2.3 and in older master versions. I remember one stage where they attacked me again and again just because I came too near to their base. And now they don't attack me even when I attack them.

Alpha 6
Runs normal with me. I tried to reproduce the reported bug from Bethrezen but I couldn't. Also everything ok with reloaded games.
One thing that maybe should be fixed are the stucked scavengers that you can see on the picture from Bethrezen. They stand their until I destroy the walls and the mortar pit.

untitled1.jpg
untitled1.jpg (96.64 KiB) Viewed 1097 times



Alpha 7
Also everything runs normal. The moved NP LZ looks good, no more units at the edge of the cliff. Reloaded games also works normal.

And still the known messages in the logs.
Attachments
logs alpha 5-7.zip
(13.61 KiB) Downloaded 24 times
alfred007
Trained
Trained
 
Posts: 256
Joined: 31 Jul 2016, 06:25
Location: Germany

Re: Help needed testing 3.2.x Campaign games!

Postby Bethrezen » 17 Aug 2017, 19:51

Alpha 5
Except the reported bug everything runs normal. The NP was very defensive like it was with Bethrezen . After the video they attacked me once and then no more. Even when I attacked them with artillery they did not attack me until I tried to build a sensor near their base. It is a little bit too defensive in my opinion. And I think they were more agressive in 3.2.3 and in older master versions. I remember one stage where they attacked me again and again just because I came too near to their base. And now they don't attack me even when I attack them.


Hummm… seems you are picking up on the same thing as me, so its not just on my end then.

Alpha 6
Runs normal with me. I tried to reproduce the reported bug from Bethrezen but I couldn't. Also everything ok with reloaded games.
One thing that maybe should be fixed are the stucked scavengers that you can see on the picture from Bethrezen. They stand their until I destroy the walls and the mortar pit.


The issue with the units coming form the factory not attacking seems fine though like before i do note that the scav's are still getting stuck.
Bethrezen
Trained
Trained
 
Posts: 438
Joined: 25 Sep 2009, 02:05

PreviousNext

Return to News and announcements