Page 1 of 4

Release 3.2.2

PostPosted: 04 Dec 2016, 01:35
by Per
Hello everyone,

Release 3.2.2 is out! This is a quick bugfix release, and the most important bug fix is related to crashes on Windows with Intel graphics drivers. We are aware of other bugs having been reported, and we will look at those as well, but we felt that we needed to get these fixes out there sooner rather than later.

It is available at our usual location: https://sourceforge.net/projects/warzone2100/files/releases/3.2.2/

If you wish to compile it yourself directly from our repo:
Code: Select all
git fetch origin --tags
git checkout 3.2.2

then proceed as normal with the build process.

Please report all bugs to http://developer.wz2100.net/newticket, and not on the forums.

2016-12-04: Version 3.2.2
General
  • Change: Improved debug menu (e89e162540, 550f6eb01e)
  • Change: Improved handling of multiplayer map/mod downloads (4b73c266fd)
  • Fix: Fixed super heavy-gunner dependency (#4490, 116ac5c679)
  • Fix: Do not crash on invalid research orders (c6e9dfcf65)
  • Fix: Improved Windows XP compatibility (e58323f8cb)
  • Fix: Do not enter an infinite loop on loading invalid stored templates (a394991dd1)
Graphics
  • Change: Fixed functionality graphics rewritten to use programmable shaders - this should fix crashes on Windows with Intel drivers (several commits, too many tickets)
  • Fix: Make water tiles visible even when just the water surface is visible (4e6d245b75, #4504)
ModdingCampaignAI
Please keep reporting those bugs! :lecture:

Re: Release 3.2.2

PostPosted: 04 Dec 2016, 02:25
by Berg
Code: Select all
berg@berg-desktop ~/bin/warzone2100-3.2.2 $ ./autogen.sh
+ checking for autoconf >= 2.56 ... found 2.69, ok.
+ checking for automake >= 1.11 ... found 1.14.1, ok.
+ running aclocal ...
+ running autoheader ...
+ running autoconf ...
+ running automake ...
configure.ac:75: warning: The 'AM_PROG_MKDIR_P' macro is deprecated, and its use is discouraged.
configure.ac:75: You should use the Autoconf-provided 'AC_PROG_MKDIR_P' macro instead,
configure.ac:75: and use '$(MKDIR_P)' instead of '$(mkdir_p)'in your Makefile.am files.
tests/Makefile.am:31: warning: source file '../tools/map/mapload.cpp' is in a subdirectory,
tests/Makefile.am:31: but option 'subdir-objects' is disabled
automake: warning: possible forward-incompatibility.
automake: At least a source file is in a subdirectory, but the 'subdir-objects'
automake: automake option hasn't been enabled.  For now, the corresponding output
automake: object file(s) will be placed in the top-level directory.  However,
automake: this behaviour will change in future Automake versions: they will
automake: unconditionally cause object files to be placed in the same subdirectory
automake: of the corresponding sources.
automake: You are advised to start using 'subdir-objects' option throughout your
automake: project, to avoid future incompatibilities.
+ removing config.cache ...

Now type './configure && make' to compile.
berg@berg-desktop ~/bin/warzone2100-3.2.2 $ ./configure && make
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
/home/berg/bin/warzone2100-3.2.2/missing: Unknown `--is-lightweight' option
Try `/home/berg/bin/warzone2100-3.2.2/missing --help' for more information
configure: WARNING: 'missing' script is too old or missing
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking whether UID '1000' is supported by ustar format... yes
checking whether GID '1000' is supported by ustar format... yes
checking how to create a ustar tar archive... gnutar
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking for style of include used by make... GNU
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking whether gcc understands -c and -o together... yes
checking dependency style of gcc... gcc3
checking for gcc option to accept ISO C99... -std=gnu99
checking for gcc -std=gnu99 option to accept ISO Standard C... (cached) -std=gnu99
checking for gcc... ccompiler
checking for ranlib... ranlib
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking dependency style of g++... gcc3
checking for g++... cxxcompiler
checking whether perl executable path has been provided... no
checking for perl... /usr/bin/perl
checking for a sed that does not truncate output... /bin/sed
checking for grep that handles long lines and -e... /bin/grep
checking for perl version... This is perl 5, version 18, subversion 2 (v5.18.2) built for x86_64-linux-gnu-thread-multi
checking for gawk... (cached) gawk
checking for zip... zip
checking for unzip... unzip
checking for a2x... no
checking for wkhtmltopdf... wkhtmltopdf
checking for pdflatex... no
checking for hevea... no
checking for hacha... no
checking how to run the C preprocessor... gcc -std=gnu99 -E
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking minix/config.h usability... no
checking minix/config.h presence... no
checking for minix/config.h... no
checking whether it is safe to define __EXTENSIONS__... yes
./configure: line 6286: AX_C___BUILTIN_EXPECT: command not found
checking for strlcpy... no
checking for strlcat... no
checking whether gcc -std=gnu99 accepts -fstack-protector... yes
checking whether g++ accepts -fstack-protector... yes
checking alloca.h usability... yes
checking alloca.h presence... yes
checking for alloca.h... yes
checking sys/ucontext.h usability... yes
checking sys/ucontext.h presence... yes
checking for sys/ucontext.h... yes
checking whether NLS is requested... yes
checking for msgfmt... /usr/bin/msgfmt
checking for gmsgfmt... /usr/bin/msgfmt
checking for xgettext... /usr/bin/xgettext
checking for msgmerge... /usr/bin/msgmerge
checking for ld used by GCC... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for shared library run path origin... done
checking for CFPreferencesCopyAppValue... no
checking for CFLocaleCopyCurrent... no
checking for GNU gettext in libc... yes
checking whether to use NLS... yes
checking where the gettext function comes from... libc
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for pkg-config >= 0.9... found 0.26, ok
checking for backend... SDL
checking for QT5... yes
checking for moc-qt5... no
checking for moc... /usr/lib/x86_64-linux-gnu/qt5/bin/moc
checking for uic-qt5... no
checking for uic... /usr/lib/x86_64-linux-gnu/qt5/bin/uic
checking for rcc-qt5... no
checking for rcc... /usr/lib/x86_64-linux-gnu/qt5/bin/rcc
checking for X... libraries , headers
checking whether to build NSIS installer... no
checking whether to compile in debug mode... no
checking whether the C compiler accepts the -Werror -Wno-switch flag... yes
checking whether the C compiler accepts the -Werror -Wno-enum-compare flag... yes
checking for SDL... yes
checking for PNG... yes
checking for THEORA... yes
checking for OPENAL... yes
checking for VORBIS... yes
checking for VORBISFILE... yes
checking for GLEW... yes
checking for LIBCRYPTO... yes
checking for nearbyint in -lm... yes
checking physfs.h usability... yes
checking physfs.h presence... yes
checking for physfs.h... yes
checking for PHYSFS_mount in -lphysfs... yes
checking X11/extensions/Xrandr.h usability... yes
checking X11/extensions/Xrandr.h presence... yes
checking for X11/extensions/Xrandr.h... yes
checking for main in -lGL... yes
checking for main in -lGLU... yes
checking for FRIBIDI... yes
checking for FREETYPE... yes
checking for HARFBUZZ... configure: error: Package requirements (harfbuzz) were not met:

No package 'harfbuzz' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables HARFBUZZ_CFLAGS
and HARFBUZZ_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.



The is console output..
I can compile 3.2.1 so what has changed?

Re: Release 3.2.2

PostPosted: 04 Dec 2016, 02:29
by Per
You will need to install the harfbuzz package on your system. We replaced the font rendering library.

Re: Release 3.2.2

PostPosted: 04 Dec 2016, 02:35
by Lord_Kane
Woohoo! BUG FIXES YAY!~

Re: Release 3.2.2

PostPosted: 04 Dec 2016, 03:16
by Berg
I compiled it after installing "sudo apt-get install libharfbuzz-dev"
On my mint mate machine.
But now when I try to host it freezes at the multi player host menu!
I have no crash log its not saving anything just the start of game announce on console.

Re: Release 3.2.2

PostPosted: 04 Dec 2016, 05:15
by Rommel
Are we gonna get a Mac release for this version? I don't even think I found a mac version for the last version :(

Re: Release 3.2.2

PostPosted: 04 Dec 2016, 13:02
by Terminator
Per wrote:You will need to install the harfbuzz package on your system. We replaced the font rendering library.


Probably wiki linux compile guide should be updated

Re: Release 3.2.2

PostPosted: 04 Dec 2016, 13:34
by Terminator
is it always was like that proggres bar covers time-remaining

Re: Release 3.2.2

PostPosted: 04 Dec 2016, 15:13
by Per
Terminator wrote:Probably wiki linux compile guide should be updated

I thought I did. Where is it not updated?
Terminator wrote:is it always was like that proggres bar covers time-remaining

It is a known, new bug.

Re: Release 3.2.2

PostPosted: 04 Dec 2016, 15:18
by Terminator
Per wrote:
Terminator wrote:Probably wiki linux compile guide should be updated

I thought I did. Where is it not updated?


Oh, sorry, didnt pay attantion to wiki commits, only saw Berg's posts here in this topic.

Re: Release 3.2.2

PostPosted: 04 Dec 2016, 16:03
by Tzeentch
I also found a spec file for this on an ftp server, so this could be a simple one line install command.

like rpm install basicially, or rpmbuild.

Re: Release 3.2.2

PostPosted: 04 Dec 2016, 23:42
by Berserk Cyborg
The new debug menu is really a great improvement over the old one. The fog option seems to be broken though (unless creating garbled purple/pink tiles everywhere was intended).

Also someone should update the front page to reflect the new release.

Re: Release 3.2.2

PostPosted: 06 Dec 2016, 11:02
by Berg
Click image to see frames per second
wz2100-20161206_195230-Sk-Rush.png
Well i got it running but i had to use open source drivers the official ati drivers fail and i get a great frame rate of 7fps

PS: after installing the new drivers the frame rate for 3.1.5 also went to crap so i reverted and now cant play 3.2.2 again

Re: Release 3.2.2

PostPosted: 07 Dec 2016, 00:07
by awunes
Haven't played in a while. Son wants to play online again, so I'm needing to update to 3.2.2.

Downloaded
Compiled
Installed
Ran -----------> (into error: [screenInitialise:241] OpenGL 2.0 no supported! Please upgrade your drivers.)

Main question:

Is there any way to configure so as to not need OpenGL 2.0?


I'm not able to upgrade drivers or hardware at this time. The hardware simply doesn't support OpenGL 2.0

Here's my computer info:

System: Host: primary-desktop Kernel: 3.13.0-24-generic x86_64 (64 bit, gcc: 4.8.2)
Desktop: Gnome Distro: Linux Mint 17 Qiana
Machine: System: Dell product: OptiPlex 755
Mobo: Dell model: 0GM819 Bios: Dell version: A22 date: 06/11/2012
CPU: Dual core Intel Pentium Dual CPU E2220 (-MCP-) cache: 1024 KB flags: (lm nx sse sse2 sse3 ssse3) bmips: 9576.08
Clock Speeds: 1: 1200.00 MHz 2: 1200.00 MHz
Graphics: Card: Intel 82Q35 Express Integrated Graphics Controller bus-ID: 00:02.0
X.Org: 1.15.1 drivers: intel (unloaded: fbdev,vesa) Resolution: 1360x768@60.0hz
GLX Renderer: Mesa DRI Intel Q35 GLX Version: 1.4 Mesa 10.1.3 Direct Rendering: Yes
Audio: Card: Intel 82801I (ICH9 Family) HD Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture ver: k3.13.0-24-generic

-----------------

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Q35
OpenGL version string: 1.4 Mesa 10.1.3
OpenGL extensions:

Re: Release 3.2.2

PostPosted: 07 Dec 2016, 00:24
by Per
awunes wrote:Is there any way to configure so as to not need OpenGL 2.0?

No.